Bug 1976110 - [4.8.z backport] [OCP 4.7] "configure-ovs.sh" leaves static ip in old interface
Summary: [4.8.z backport] [OCP 4.7] "configure-ovs.sh" leaves static ip in old interface
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.7
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.8.z
Assignee: Jaime Caamaño Ruiz
QA Contact: Ross Brattain
URL:
Whiteboard:
: 1975171 1979391 (view as bug list)
Depends On: 1971715
Blocks: 1974962 1975171 1975174
TreeView+ depends on / blocked
 
Reported: 2021-06-25 08:33 UTC by OpenShift BugZilla Robot
Modified: 2021-10-20 16:13 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Network configuration specific to ovn-kubernetes might be lost after cluster node reboot. Consequence: After cluster node reboot, on network configurations making use of link aggregation, cluster network connectivity is lost. Fix: Correctly persist ovn-kubernetes specific network configuration across reboots of the cluster nodes. Result: Network configuration specific to ovn-kubernetes persists across reboots and connectivity is not lost..
Clone Of:
Environment:
Last Closed: 2021-09-27 19:53:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 2644 0 None open [release-4.8] Bug 1976110: configure-ovs: fix nondeterministic master in slave profiles 2021-08-09 13:07:43 UTC
Red Hat Product Errata RHBA-2021:3632 0 None None None 2021-09-27 19:53:38 UTC

Comment 1 Jaime Caamaño Ruiz 2021-06-25 08:37:28 UTC
*** Bug 1975171 has been marked as a duplicate of this bug. ***

Comment 3 Steven Hardy 2021-08-06 09:10:34 UTC
*** Bug 1979391 has been marked as a duplicate of this bug. ***

Comment 4 Ross Brattain 2021-09-01 14:38:40 UTC
Tested on vSphere

RHCOS bonding kargs static
RHEL 7.9 bonding DHCP
RHCOS teaming static IP
RHEL 7.9 nm static IP

Comment 14 errata-xmlrpc 2021-09-27 19:53:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.13 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3632


Note You need to log in before you can comment on or make changes to this bug.