Bug 197750 - scp: wrong exit status
scp: wrong exit status
Status: CLOSED DUPLICATE of bug 190147
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssh (Show other bugs)
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-07-05 18:36 EDT by Andrew Ernst
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-07 08:21:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Andrew Ernst 2006-07-05 18:36:16 EDT
Description of problem:  scp returns non-zero exit statuses under RedHat 4.  The
same commands executed under RHEL 3 and Fedora Core 5 all return 0, but RedHat 4
does not.  This is for copying files locally using scp.

Version-Release number of selected component (if applicable):

How reproducible:
Always, under i386 and athlon architectures.

Steps to Reproduce:
1.  mkdir /tmp/t
2.  /usr/bin/scp -v -r /tmp/t /tmp/p; echo $?
Actual results:

Executing: cp -r /tmp/t /tmp/p

Expected results:

Executing: cp -r /tmp/t /tmp/p

Additional info:
Tested this under RHEL 4 on multiple machines, with the same result.
Comment 1 Andrew Ernst 2006-07-05 23:11:17 EDT
I should point out that the exit status is 0 when you copy a file to a remote
host, but not when you copy a file locally:

[user@server tmp]$ scp -r -v /tmp/t /tmp/l; echo $?
Executing: cp -r /tmp/t /tmp/l
Comment 2 Tomas Mraz 2006-07-07 08:21:14 EDT

*** This bug has been marked as a duplicate of 190147 ***

Note You need to log in before you can comment on or make changes to this bug.