Bug 197826 - Review Request: perl-IO-Socket-SSL
Review Request: perl-IO-Socket-SSL
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On: 197827
Blocks: FC-ACCEPT
  Show dependency treegraph
 
Reported: 2006-07-06 13:48 EDT by Warren Togami
Modified: 2013-01-09 20:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-18 13:07:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2006-07-06 13:48:26 EDT
Spec URL: http://togami.com/~warren/fedora/perl-IO-Socket-SSL.spec
SRPM URL: http://togami.com/~warren/fedora/perl-IO-Socket-SSL-0.97-1.src.rpm
Description: Nearly transparent SSL encapsulation for IO::Socket::INET 

Spamasssasin requires this for SSL encryption between spamc and spamd.

This also requires the inclusion of perl-Net-SSLeay currently in Extras.
Comment 1 Jesse Keating 2006-07-10 14:15:48 EDT
NEEDSWORK:
- Noarch package, so OPTIMIZE not needed, ditto removing .bs files
- BuildRequires should be perl(NET::SSLeay) not the package name.

rpmlint only has one warning:
W: perl-IO-Socket-SSL file-not-utf8 /usr/share/man/man3/IO::Socket::SSL.3pm.gz
Comment 2 Ville Skyttä 2006-07-10 14:29:14 EDT
This package is already in Extras, maintained by jpo, and that version has the
reported issues fixed as well as some other enhancements over the submitted one.
 The release tag in this one would also cause a broken upgrade path.
Comment 3 Jesse Keating 2006-07-10 15:07:36 EDT
Warren, please update to the Extras version of the package for this review.

Ville, we need to bring this package into Core for spamassassin to support ipv6
and ssl communication.
Comment 4 Ville Skyttä 2006-07-10 15:38:56 EDT
Yep, noticed.
Comment 6 Jesse Keating 2006-07-14 16:11:37 EDT
Looks good.  approving.

Adding to dist.
Comment 7 Jesse Keating 2006-07-18 13:07:29 EDT
Was built into rawhide.
Comment 8 Jose Pedro Oliveira 2006-07-18 13:50:38 EDT
Warren,

Could you update IO::Socket::SSL to version 0.991?
http://search.cpan.org/dist/IO-Socket-SSL/

Tia,
jpo

PS - Still no Fedora Core bugzilla component.

Note You need to log in before you can comment on or make changes to this bug.