Bug 197902 - Problem with nicknames different from ethN on dhcp activated network interfaces
Problem with nicknames different from ethN on dhcp activated network interfaces
Status: CLOSED DUPLICATE of bug 196324
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-06 22:18 EDT by Marcelo Roberto Jimenez
Modified: 2014-03-16 23:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-28 19:36:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Configuration files for eth0 (230 bytes, text/plain)
2006-07-09 07:14 EDT, Marcelo Roberto Jimenez
no flags Details

  None (edit)
Description Marcelo Roberto Jimenez 2006-07-06 22:18:54 EDT
Description of problem:
When setting a network interface (e.g., eth0) using system-config-network, if 
the nickname is different from the real device name, bringing up the interface 
fails. In the following, I have set the nickname to eth0Dynamic. Setting it to 
eth0 makes everything work:

# service network start
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0Dynamic:
Determining IP information for eth0.../sbin/dhclient-script: configuration for 
eth0 not found. Continuing with defaults.
/etc/sysconfig/network-scripts/network-functions: line 51: eth0: No such file or 
directory
/sbin/dhclient-script: configuration for eth0 not found. Continuing with 
defaults.
/etc/sysconfig/network-scripts/network-functions: line 51: eth0: No such file or 
directory
 done.

# service network stop
Shutting down interface eth0Dynamic:  /sbin/dhclient-script: configuration for 
eth0 not found. Continuing with defaults.
/etc/sysconfig/network-scripts/network-functions: line 51: eth0: No such file or 
directory
                                                           [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Disabling IPv4 packet forwarding:  net.ipv4.ip_forward = 0
                                                           [  OK  ]
Comment 1 Bill Nottingham 2006-07-06 22:23:00 EDT
Can you attach your configs?
Comment 2 Marcelo Roberto Jimenez 2006-07-09 07:14:46 EDT
Created attachment 132125 [details]
Configuration files for eth0
Comment 3 Marcelo Roberto Jimenez 2006-07-09 07:46:45 EDT
The problem does not seem to be inside the configuration file, the problem is 
that when you give the interface a nick like eth0Dynamic, the file gets the name 
ifcfg-eth0Dynamic, and dhclient-script is no longer able to find the 
configuration, because it looks for ifcfg-eth0, not ifcfg-eth0Dynamic.
Comment 4 Bill Nottingham 2006-07-10 16:16:54 EDT
Hm, when was the last time this worked for you?
Comment 5 Marcelo Roberto Jimenez 2006-07-11 09:45:18 EDT
It works for me, as long as the interface does not use DHCP. A static assignment works fine with a nick e.g. 
eth0Static.
Comment 6 Marcelo Roberto Jimenez 2006-07-11 09:47:07 EDT
Sorry, that did not answer your question.

It has never worked for me before, but works if the interface does not use DHCP.
Comment 7 Miloslav Trmač 2006-07-28 19:36:28 EDT
Thank you for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 196324 ***

Note You need to log in before you can comment on or make changes to this bug.