Bug 197940 - PEAR Requires cpp and glibc-headers
Summary: PEAR Requires cpp and glibc-headers
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: php-pear (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard: bzcl34nup
Keywords:
: 213226 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-07 14:42 UTC by Leonard den Ottolander
Modified: 2008-04-09 19:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 19:24:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against /usr/share/pear/OS/Guess.php (3.08 KB, patch)
2006-11-01 07:50 UTC, Remi Collet
no flags Details | Diff
Patch against /usr/share/pear/OS/Guess.php (3.49 KB, patch)
2006-12-14 10:42 UTC, Remi Collet
no flags Details | Diff
Patch against /usr/share/pear/OS/Guess.php (for php-pear 1.4.11) (3.47 KB, patch)
2006-12-14 10:43 UTC, Remi Collet
no flags Details | Diff

Description Leonard den Ottolander 2006-07-07 14:42:14 UTC
pear upgrade will fail when /usr/bin/cpp is unavailable.
pear upgrade will fail when features.h is unavailable.

Comment 1 Remi Collet 2006-10-31 18:41:55 UTC
*** Bug 213226 has been marked as a duplicate of this bug. ***

Comment 2 Joe Orton 2006-10-31 19:05:44 UTC
This seems to come from the OS_Guess code, which is trying to find out the glibc
major/minor version.

Invoking the cpp during package installation seems like massive overkill.

Comment 3 Tim Jackson 2006-10-31 21:41:14 UTC
Eek. That does seem overkill. Would be worth talking to upstream about this.
Unless it absolutely relies on cpp (which I doubt) then it ought to fail back
gracefully to other methods...

Comment 4 Remi Collet 2006-11-01 07:50:16 UTC
Created attachment 139947 [details]
Patch against /usr/share/pear/OS/Guess.php

Seems the code is "OS/Guess.php" is quite buggy.

It test is "features.h" and "cpp" exist but try "cpp" even if "features.h" not
present.

The failsafe mode (reading the link) didn't work because of a regular
expression mistake.

This patch do : 
- use "cpp" only if features.h present.
- working failsafe mode (readlink of /lib/libc.so.6)


Here is a little patch. If you want, i can file a bug upstream.

Comment 5 Remi Collet 2006-11-01 07:59:35 UTC
If the bug is send upstream, it'll only be available for pear > 1.4.11 (actual
version)

So i think we have to upgrade to new version or to patch the 1.4.9 in fedora.

Comment 6 Fabio 2006-11-03 08:41:28 UTC
[root@knoxtest02 etc]# yum install php-pear php-pear-Console-Table 
php-pear-Console-Getargs php-pear-Mail php-pear-Mail-Mime php-pear-Net-SMTP 
php-pear-Net-Socket

<...cut...>

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 php-pear-Console-Getargs  noarch     1.3.2-1.fc6      extras             24 k
 php-pear-Console-Table  noarch     1.0.5-2.fc6      extras             11 k
 php-pear-Mail           noarch     1.1.14-1.fc6     extras             26 k
 php-pear-Mail-Mime      noarch     1.3.1-8.fc6      extras             22 k
 php-pear-Net-SMTP       noarch     1.2.8-5.fc6      extras             17 k
 php-pear-Net-Socket     noarch     1.0.6-5.fc6      extras             10 k
Installing for dependencies:
 php-pear-Auth-SASL      noarch     1.0.2-4.fc6      extras             10 k

Transaction Summary
=============================================================================
Install      7 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

Total download size: 120 k
Is this ok [y/N]: y
Downloading Packages:
(1/7): php-pear-Auth-SASL 100% |=========================|  10 kB    00:00
(2/7): php-pear-Mail-Mime 100% |=========================|  22 kB    00:00
(3/7): php-pear-Net-Socke 100% |=========================|  10 kB    00:00
(4/7): php-pear-Mail-1.1. 100% |=========================|  26 kB    00:00
(5/7): php-pear-Console-G 100% |=========================|  24 kB    00:00
(6/7): php-pear-Net-SMTP- 100% |=========================|  17 kB    00:00
(7/7): php-pear-Console-T 100% |=========================|  11 kB    00:00
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: php-pear-Net-Socket          ######################### [1/7]
/tmp/glibctesta73jbf:1:22: error: features.h: No such file or directory
  Installing: php-pear-Auth-SASL           ######################### [2/7]
/tmp/glibctestsb7w52:1:22: error: features.h: No such file or directory
  Installing: php-pear-Net-SMTP            ######################### [3/7]
/tmp/glibctestPa0EMx:1:22: error: features.h: No such file or directory
  Installing: php-pear-Mail-Mime           ######################### [4/7]
/tmp/glibctestpvQUC9:1:22: error: features.h: No such file or directory
  Installing: php-pear-Mail                ######################### [5/7]
/tmp/glibctestxoTJE7:1:22: error: features.h: No such file or directory
  Installing: php-pear-Console-Getargs     ######################### [6/7]
/tmp/glibctest3Zubr1:1:22: error: features.h: No such file or directory
  Installing: php-pear-Console-Table       ######################### [7/7]
/tmp/glibctest54rLvq:1:22: error: features.h: No such file or directory

Installed: php-pear-Console-Getargs.noarch 0:1.3.2-1.fc6 
php-pear-Console-Table.noarch 0:1.0.5-2.fc6 php-pear-Mail.noarch 
0:1.1.14-1.fc6 php-pear-Mail-Mime.noarch 0:1.3.1-8.fc6 
php-pear-Net-SMTP.noarch 0:1.2.8-5.fc6 php-pear-Net-Socket.noarch 
0:1.0.6-5.fc6
Dependency Installed: php-pear-Auth-SASL.noarch 0:1.0.2-4.fc6
Complete!

---------------
Now I Installed glibc-headers, cpp was already installed.
But does theese packages I installed works fine or have I to uninstall and 
reinstall them?
---------------

Thank you very much.

Bye
Fabio Adamo



Comment 7 Remi Collet 2006-11-03 12:39:38 UTC
The packages you've installed should works fine.
No need to uninstall and reinstall them.

Comment 8 Remi Collet 2006-11-16 17:52:09 UTC
Bug reported and Patch send upstream :
http://pear.php.net/bugs/bug.php?id=9355


Comment 9 Remi Collet 2006-12-14 10:42:47 UTC
Created attachment 143613 [details]
Patch against /usr/share/pear/OS/Guess.php

See http://pear.php.net/bugs/bug.php?id=9355

New version in now in CVS.
Patch updated (from 1.4.9 to cvs)

Comment 10 Remi Collet 2006-12-14 10:43:47 UTC
Created attachment 143614 [details]
Patch against /usr/share/pear/OS/Guess.php (for php-pear 1.4.11)

Comment 11 Bug Zapper 2008-04-03 17:33:02 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 12 Tim Jackson 2008-04-09 19:24:46 UTC
This was marked as fixed in CVS upstream as of 2006-12-14 and so, since we keep
up to date with upstream, is certainly fixed in any recent version.

Comment 13 Tim Jackson 2008-04-09 19:27:38 UTC
It was fixed in upstream 1.5.0


Note You need to log in before you can comment on or make changes to this bug.