Bug 213226 - PEAR: "/tmp/glibctesta73jbf:1:22: error: features.h: No such file or directory" while installing
PEAR: "/tmp/glibctesta73jbf:1:22: error: features.h: No such file or director...
Status: CLOSED DUPLICATE of bug 197940
Product: Fedora
Classification: Fedora
Component: php-pear (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 06:55 EST by Fabio
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 13:41:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fabio 2006-10-31 06:55:27 EST
Description of problem:
Error while installing some pear rpms:

[root@knoxtest02 etc]# yum install php-pear php-pear-Console-Table 
php-pear-Console-Getargs php-pear-Mail php-pear-Mail-Mime php-pear-Net-SMTP 
php-pear-Net-Socket
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for php-pear-Mail-Mime to pack into transaction set.
http://mirror.web-ster.com/fedora/extras/6/i386/php-pear-Mail-Mime-1.3.1-8.fc6.noarch.rpm: 
[Errno 14] HTTP Error 407: Server: squid/2.5.STABLE12
Mime-Version: 1.0
Date: Tue, 31 Oct 2006 10:50:45 GMT
Content-Type: text/html
Content-Length: 1508
Expires: Tue, 31 Oct 2006 10:50:45 GMT
X-Squid-Error: ERR_CACHE_ACCESS_DENIED 0
Proxy-Authenticate: Basic realm="Squid proxy-caching web server"
X-Cache: MISS from ProxySquid1N
X-Cache-Lookup: NONE from ProxySquid1N:8080
Proxy-Connection: close

Trying other mirror.
http://mirror.hiwaay.net/redhat/fedora/linux/extras/6/i386/php-pear-Mail-Mime-1.3.1-8.fc6.noarch.rpm: 
[Errno 14] HTTP Error 407: Server: squid/2.5.STABLE12
Mime-Version: 1.0
Date: Tue, 31 Oct 2006 10:50:45 GMT
Content-Type: text/html
Content-Length: 1541
Expires: Tue, 31 Oct 2006 10:50:45 GMT
X-Squid-Error: ERR_CACHE_ACCESS_DENIED 0
Proxy-Authenticate: Basic realm="Squid proxy-caching web server"
X-Cache: MISS from ProxySquid1N
X-Cache-Lookup: NONE from ProxySquid1N:8080
Proxy-Connection: close

Trying other mirror.
php-pear-Mail-Mime-1.3.1- 100% |=========================| 4.4 kB    00:00
---> Package php-pear-Mail-Mime.noarch 0:1.3.1-8.fc6 set to be updated
---> Downloading header for php-pear-Net-Socket to pack into transaction set.
php-pear-Net-Socket-1.0.6 100% |=========================| 4.0 kB    00:01
---> Package php-pear-Net-Socket.noarch 0:1.0.6-5.fc6 set to be updated
---> Downloading header for php-pear-Mail to pack into transaction set.
php-pear-Mail-1.1.14-1.fc 100% |=========================| 5.9 kB    00:01
---> Package php-pear-Mail.noarch 0:1.1.14-1.fc6 set to be updated
---> Downloading header for php-pear-Console-Getargs to pack into transaction 
set.
php-pear-Console-Getargs- 100% |=========================| 4.5 kB    00:01
---> Package php-pear-Console-Getargs.noarch 0:1.3.2-1.fc6 set to be updated
---> Downloading header for php-pear-Net-SMTP to pack into transaction set.
php-pear-Net-SMTP-1.2.8-5 100% |=========================| 5.1 kB    00:00
---> Package php-pear-Net-SMTP.noarch 0:1.2.8-5.fc6 set to be updated
---> Downloading header for php-pear-Console-Table to pack into transaction 
set.
php-pear-Console-Table-1. 100% |=========================| 3.8 kB    00:00
---> Package php-pear-Console-Table.noarch 0:1.0.5-2.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: php-pear(Auth_SASL) for package: php-pear-Net-SMTP
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for php-pear-Auth-SASL to pack into transaction set.
php-pear-Auth-SASL-1.0.2- 100% |=========================| 4.4 kB    00:00
---> Package php-pear-Auth-SASL.noarch 0:1.0.2-4.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 php-pear-Console-Getargs  noarch     1.3.2-1.fc6      extras             24 k
 php-pear-Console-Table  noarch     1.0.5-2.fc6      extras             11 k
 php-pear-Mail           noarch     1.1.14-1.fc6     extras             26 k
 php-pear-Mail-Mime      noarch     1.3.1-8.fc6      extras             22 k
 php-pear-Net-SMTP       noarch     1.2.8-5.fc6      extras             17 k
 php-pear-Net-Socket     noarch     1.0.6-5.fc6      extras             10 k
Installing for dependencies:
 php-pear-Auth-SASL      noarch     1.0.2-4.fc6      extras             10 k

Transaction Summary
=============================================================================
Install      7 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

Total download size: 120 k
Is this ok [y/N]: y
Downloading Packages:
(1/7): php-pear-Auth-SASL 100% |=========================|  10 kB    00:00
(2/7): php-pear-Mail-Mime 100% |=========================|  22 kB    00:00
(3/7): php-pear-Net-Socke 100% |=========================|  10 kB    00:00
(4/7): php-pear-Mail-1.1. 100% |=========================|  26 kB    00:00
(5/7): php-pear-Console-G 100% |=========================|  24 kB    00:00
(6/7): php-pear-Net-SMTP- 100% |=========================|  17 kB    00:00
(7/7): php-pear-Console-T 100% |=========================|  11 kB    00:00
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: php-pear-Net-Socket          ######################### [1/7]
/tmp/glibctesta73jbf:1:22: error: features.h: No such file or directory
  Installing: php-pear-Auth-SASL           ######################### [2/7]
/tmp/glibctestsb7w52:1:22: error: features.h: No such file or directory
  Installing: php-pear-Net-SMTP            ######################### [3/7]
/tmp/glibctestPa0EMx:1:22: error: features.h: No such file or directory
  Installing: php-pear-Mail-Mime           ######################### [4/7]
/tmp/glibctestpvQUC9:1:22: error: features.h: No such file or directory
  Installing: php-pear-Mail                ######################### [5/7]
/tmp/glibctestxoTJE7:1:22: error: features.h: No such file or directory
  Installing: php-pear-Console-Getargs     ######################### [6/7]
/tmp/glibctest3Zubr1:1:22: error: features.h: No such file or directory
  Installing: php-pear-Console-Table       ######################### [7/7]
/tmp/glibctest54rLvq:1:22: error: features.h: No such file or directory

Installed: php-pear-Console-Getargs.noarch 0:1.3.2-1.fc6 
php-pear-Console-Table.noarch 0:1.0.5-2.fc6 php-pear-Mail.noarch 
0:1.1.14-1.fc6 php-pear-Mail-Mime.noarch 0:1.3.1-8.fc6 
php-pear-Net-SMTP.noarch 0:1.2.8-5.fc6 php-pear-Net-Socket.noarch 
0:1.0.6-5.fc6
Dependency Installed: php-pear-Auth-SASL.noarch 0:1.0.2-4.fc6
Complete!


Version-Release number of selected component (if applicable):
FC6 updated to now (2006-10-31 12:45 Rome time)

How reproducible:
Always

Steps to Reproduce:
1. run yum install php-pear php-pear-Console-Table php-pear-Console-Getargs 
php-pear-Mail php-pear-Mail-Mime php-pear-Net-SMTP php-pear-Net-Socket
2.
3.
  
Actual results:
/tmp/glibctestPa0EMx:1:22: error: features.h: No such file or directory

Expected results:
No errors

Additional info:
Comment 1 Fabio 2006-10-31 11:23:40 EST
[root@knoxtest02:/etc/httpd/conf.d]# pear install calendar
/tmp/glibctestWF2PIo:1:22: error: features.h: No such file or directory
downloading Calendar-0.5.3.tgz ...
Starting to download Calendar-0.5.3.tgz (63,274 bytes)
................done: 63,274 bytes
install ok: channel://pear.php.net/Calendar-0.5.3

It seems to be an error in php-pear....

Comment 2 Remi Collet 2006-10-31 13:37:23 EST
Yes it's a "small" php-pear bug.

install glib-headers (which provide features.h) solves the error.

Comment 3 Remi Collet 2006-10-31 13:41:39 EST

*** This bug has been marked as a duplicate of 197940 ***

*** This bug has been marked as a duplicate of 197940 ***

Note You need to log in before you can comment on or make changes to this bug.