Bug 198047 - Kernel update screwed up /etc/inittab
Kernel update screwed up /etc/inittab
Status: CLOSED DUPLICATE of bug 197906
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-08 11:13 EDT by Evert Verhellen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 11:28:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Evert Verhellen 2006-07-08 11:13:21 EDT
I skipped kernel-2.6.17-1.2139_FC5 because of the many reported problems. Today,
I decided to upgrade to kernel-2.6.17-1.2145_FC5 with "yum update". However,
after a restart, I got the following error messages:

INIT: version 2.86 booting
INIT: No inittab file found

After that you're stuck. Happens with any of the remaining kernels:

kernel-2.6.16-1.2133_FC5
kernel-2.6.17-1.2145_FC5

From /var/log/yum.log:

Jul 08 13:43:57 Erased: initscripts
Jul 08 13:44:21 Installed: kernel.i686 2.6.17-1.2145_FC5
Jul 08 13:44:23 Updated: gnupg.i386 1.4.4-2.2
Jul 08 13:44:23 Updated: xorg-x11-drv-ati.i386 6.5.8.0-1
Jul 08 13:44:40 Installed: kernel-devel.i686 2.6.17-1.2145_FC5
Jul 08 13:44:42 Updated: initscripts.i386 8.31.5-1
Jul 08 13:44:43 Updated: evolution-sharp.i386 0.10.2-9.5

It appears that the upgrade of the initscripts package didn't finish properly
(just a guess) as there was a file inittab.rpmsave in /etc but no inittab
anymore. Restarting with the Fedora rescue CD and subsequently copying
/etc/inittab.rpmsave to /etc/inittab worked fine though and allowed me to
properly restart the computer.

Situations like this are fatal for non-technical people and actually very scary
as it isn't obvious what steps to perform after starting from the Fedora rescue CD.
Comment 1 Mike 2006-07-09 13:29:28 EDT
This is duplicate of:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=197906
Comment 2 Jarod Wilson 2006-07-10 11:28:56 EDT

*** This bug has been marked as a duplicate of 197906 ***

Note You need to log in before you can comment on or make changes to this bug.