Bug 197906 - initscripts testing-update delete inittab
initscripts testing-update delete inittab
Status: CLOSED DUPLICATE of bug 196590
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 185528 198047 198078 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-07 00:58 EDT by Darwin H. Webb
Modified: 2014-01-21 17:54 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 19:42:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darwin H. Webb 2006-07-07 00:58:38 EDT
Description of problem:
File inittab was missing after rebooting causing the system to be dead at
runlevel 3 (with nothing more to run) type message.
There was a .romsave file but I didn't know if it was good.
I copied the inittab from another FC5 install and it was the same so I re-booted
and the system came up. This was a Pent III up kerrnal and the one that worked
ok was a Pent 4 smp kernel.

Version-Release number of selected component (if applicable):
8.31.4-1

How reproducible:
don't know

Steps to Reproduce:
1.
2.
3.
  
Actual results:
inittab missing, system inoperatable. Used second system yo mount root and add
file from another FC5.

Expected results:
system to bot up into runlevel 5 and start the desktop.

Additional info:
Comment 1 Bill Nottingham 2006-07-07 09:51:31 EDT
Are you able to reproduce this at will? We have never been able to reproduce
this (see bug 185528.)
Comment 2 Mike 2006-07-07 20:16:07 EDT
`yum clean all` then `yum update` and:

Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core                                                                 [1/3]
core                      100% |=========================| 1.1 kB    00:00
updates                                                              [2/3]
updates                   100% |=========================|  951 B    00:00
extras                                                               [3/3]
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 767 kB    00:14
core      : ################################################## 2207/2207
Added 2207 new packages, deleted 0 old in 68.11 seconds
primary.xml.gz            100% |=========================| 474 kB    00:07
updates   : ################################################## 1405/1405
Added 1405 new packages, deleted 0 old in 59.84 seconds
primary.xml.gz            100% |=========================| 1.1 MB    00:15
extras    : ################################################## 4109/4109
Added 4109 new packages, deleted 0 old in 126.45 seconds
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for initscripts to pack into transaction set.
initscripts-8.31.5-1.i386 100% |=========================| 100 kB    00:04
---> Package initscripts.i386 0:8.31.5-1 set to be updated
---> Downloading header for kernel to pack into transaction set.
kernel-2.6.17-1.2145_FC5. 100% |=========================| 164 kB    00:04
---> Package kernel.i586 0:2.6.17-1.2145_FC5 set to be installed
--> Running transaction check
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i586 0:2.6.17-1.2139_FC5 set to be erased
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 kernel                  i586       2.6.17-1.2145_FC5  updates            14 M
Updating:
 initscripts             i386       8.31.5-1         updates           1.2 M
Removing:
 kernel                  i586       2.6.17-1.2139_FC5  installed          34 M

Transaction Summary
=============================================================================
Install      1 Package(s)
Update       1 Package(s)
Remove       1 Package(s)
Total download size: 15 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): initscripts-8.31.5 100% |=========================| 1.2 MB    00:25
(2/2): kernel-2.6.17-1.21 100% |=========================|  14 MB    03:21
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: kernel                       ######################### [1/4]
warning: /etc/sysctl.conf saved as /etc/sysctl.conf.rpmsave
warning: /etc/sysconfig/network-scripts/ifcfg-lo saved as
/etc/sysconfig/network-scripts/ifcfg-lo.rpmsave
warning: /etc/rc.d/rc.local saved as /etc/rc.d/rc.local.rpmsave
warning: /etc/adjtime saved as /etc/adjtime.rpmsave
  Removing  : initscripts                  ######################### [2/4]
  Updating  : initscripts                  ######################### [3/4]
  Cleanup   : kernel                       ######################### [4/4]

Removed: kernel.i586 0:2.6.17-1.2139_FC5
Installed: kernel.i586 0:2.6.17-1.2145_FC5
Updated: initscripts.i386 0:8.31.5-1
Complete!


WTF!? four files renamed to .rpmsave

I have one box where initscripts update is pending (8.31.1-1 -> 8.31.5-1). What
could I do to provide more information about 'before bug hit' state?
Comment 3 Bill Nottingham 2006-07-07 22:50:26 EDT
If you can reproduce that ordering (removal before install) at will, please
attach yum -d5 output.

Mike: in your case does inittab go missing?

Pushing to yum, as it looks like something fishy in the installonlyn plugin?
Comment 4 Rasmus Ory Nielsen 2006-07-08 04:33:34 EDT
This bug bit me today. See below.

Right now I don't want to reboot my box ;-)

Thanks.
Rasmus Ory Nielsen


[root@fc5 ~]$ uname -r
2.6.16-1.2133_FC5smp
[root@fc5 ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
[..cut..]
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i686 0:2.6.17-1.2145_FC5 set to be installed
---> Package gnupg.i386 0:1.4.4-2.2 set to be updated
---> Downloading header for xorg-x11-drv-ati to pack into transaction set.
xorg-x11-drv-ati-6.5.8.0- 100% |=========================| 6.0 kB    00:00
---> Package xorg-x11-drv-ati.i386 0:6.5.8.0-1 set to be updated
---> Package kernel-smp-devel.i686 0:2.6.17-1.2145_FC5 set to be installed
---> Package kernel-smp.i686 0:2.6.17-1.2145_FC5 set to be installed
---> Downloading header for initscripts to pack into transaction set.
initscripts-8.31.5-1.i386 100% |=========================| 100 kB    00:00
---> Package initscripts.i386 0:8.31.5-1 set to be updated
---> Package lftp.i386 0:3.4.7-2.FC5 set to be updated
---> Downloading header for evolution-sharp to pack into transaction set.
evolution-sharp-0.10.2-9. 100% |=========================| 5.7 kB    00:00
---> Package evolution-sharp.i386 0:0.10.2-9.5 set to be updated
--> Running transaction check
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i686 0:2.6.17-1.2139_FC5 set to be erased
---> Package kernel-smp.i686 0:2.6.17-1.2139_FC5 set to be erased
---> Package kernel-smp-devel.i686 0:2.6.17-1.2139_FC5 set to be erased
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 kernel                  i686       2.6.17-1.2145_FC5  updates            15 M
 kernel-smp              i686       2.6.17-1.2145_FC5  updates            15 M
 kernel-smp-devel        i686       2.6.17-1.2145_FC5  updates           4.5 M
Updating:
 evolution-sharp         i386       0.10.2-9.5       updates           146 k
 gnupg                   i386       1.4.4-2.2        updates           1.8 M
 initscripts             i386       8.31.5-1         updates           1.2 M
 lftp                    i386       3.4.7-2.FC5      updates           1.1 M
 xorg-x11-drv-ati        i386       6.5.8.0-1        updates           330 k
Removing:
 kernel                  i686       2.6.17-1.2139_FC5  installed          37 M
 kernel-smp              i686       2.6.17-1.2139_FC5  installed          42 M
 kernel-smp-devel        i686       2.6.17-1.2139_FC5  installed          13 M

Transaction Summary
=============================================================================
Install      3 Package(s)
Update       5 Package(s)
Remove       3 Package(s)
Total download size: 39 M
Is this ok [y/N]: y
Downloading Packages:
(1/8): kernel-2.6.17-1.21 100% |=========================|  15 MB    00:38
(2/8): gnupg-1.4.4-2.2.i3 100% |=========================| 1.8 MB    00:04
(3/8): xorg-x11-drv-ati-6 100% |=========================| 330 kB    00:01
(4/8): kernel-smp-devel-2 100% |=========================| 4.5 MB    00:10
(5/8): kernel-smp-2.6.17- 100% |=========================|  15 MB    00:36
(6/8): initscripts-8.31.5 100% |=========================| 1.2 MB    00:03
(7/8): lftp-3.4.7-2.FC5.i 100% |=========================| 1.1 MB    00:02
(8/8): evolution-sharp-0. 100% |=========================| 146 kB    00:00
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating  : lftp                         ####################### [ 1/16]
  Installing: kernel                       ####################### [ 2/16]
  Updating  : gnupg                        ####################### [ 3/16]
warning: /etc/inittab saved as /etc/inittab.rpmsave
warning: /etc/adjtime saved as /etc/adjtime.rpmsave
  Removing  : initscripts                  ####################### [ 4/16]
  Updating  : xorg-x11-drv-ati             ####################### [ 5/16]
  Installing: kernel-smp-devel             ####################### [ 6/16]
  Installing: kernel-smp                   ####################### [ 7/16]
/sbin/mkinitrd: line 35: /etc/rc.d/init.d/functions: No such file or directory
  Updating  : initscripts                  ####################### [ 8/16]
fgrep: /etc/inittab: No such file or directory
  Updating  : evolution-sharp              ####################### [ 9/16]
  Cleanup   : gnupg                        ####################### [10/16]
  Cleanup   : kernel                       ####################### [11/16]
  Cleanup   : kernel-smp                   ####################### [12/16]
  Cleanup   : xorg-x11-drv-ati             ####################### [13/16]
  Cleanup   : kernel-smp-devel             ####################### [14/16]
  Cleanup   : lftp                         ####################### [15/16]
  Cleanup   : evolution-sharp              ####################### [16/16]

Removed: kernel.i686 0:2.6.17-1.2139_FC5 kernel-smp.i686 0:2.6.17-1.2139_FC5
kernel-smp-devel.i686 0:2.6.17-1.2139_FC5
Installed: kernel.i686 0:2.6.17-1.2145_FC5 kernel-smp.i686 0:2.6.17-1.2145_FC5
kernel-smp-devel.i686 0:2.6.17-1.2145_FC5
Updated: evolution-sharp.i386 0:0.10.2-9.5 gnupg.i386 0:1.4.4-2.2
initscripts.i386 0:8.31.5-1 lftp.i386 0:3.4.7-2.FC5 xorg-x11-drv-ati.i386
0:6.5.8.0-1
Complete!
[root@fc5 ~]$ ll /etc/inittab*
-rw-r--r-- 1 root root 1663 Aug 23  2005 /etc/inittab.rpmsave
[root@fc5 ~]$ ll /etc/adjtime*
-rw-r--r-- 1 root root 47 Jun 29 19:04 /etc/adjtime.rpmsave
[root@fc5 ~]$ ll /etc/rc.d/init.d/functions*
-rwxr-xr-x 1 root root 11730 Feb 14 19:41 /etc/rc.d/init.d/functions

Comment 5 Mike 2006-07-08 18:01:41 EDT
> Mike: in your case does inittab go missing?

Missing might be a bad description. Files are renamed, .rpmsave suffix is added.
Yum is telling about that:

warning: /etc/sysctl.conf saved as /etc/sysctl.conf.rpmsave
warning: /etc/sysconfig/network-scripts/ifcfg-lo saved as
warning: /etc/rc.d/rc.local saved as /etc/rc.d/rc.local.rpmsave
warning: /etc/adjtime saved as /etc/adjtime.rpmsave

"/etc/inittab" file is fine.

> I have one box where initscripts update is pending (8.31.1-1 -> 8.31.5-1).

Strange, but update went there just fine.
Comment 6 Mike 2006-07-08 18:33:04 EDT
> If you can reproduce that ordering (removal before install) at will,
> please attach yum -d5 output.

# yum -d5 update
Loading "installonlyn" plugin
Running "config" handler for "installonlyn" plugin
Yum Version: 2.6.1
COMMAND: yum -d5
Installroot: /
Setting up Update Process
Setting up repositories
core                                                                 [1/3]
Baseurl(s) for repo:
['http://redhat.download.fedoraproject.org/pub/fedora/linux/core/5/i386/os/',
'http://ftp.fi.muni.cz/pub/linux/fedora-core/5/i386/os/',
'ftp://ftp.tu-chemnitz.de/pub/linux/fedora-core/5/i386/os/',
'ftp://ftp.wsisiz.edu.pl/pub/linux/fedora/linux/core/5/i386/os/',
'http://ftp.ale.org/mirrors/fedora/linux/core/5/i386/os/',
'http://ftp.uninett.no/pub/linux/Fedora/core/5/i386/os/',
'http://ftp.tu-chemnitz.de/pub/linux/fedora-core/5/i386/os/',
'http://sunsite.informatik.rwth-aachen.de/ftp/pub/linux/fedora-core/5/i386/os/',
'ftp://ftp.tecnoera.com/pub/fedora/linux/core/5/i386/os/',
'ftp://redhat.taygeta.com/pub/RedHat/fedora/core/5/i386/os/',
'http://fr2.rpmfind.net/linux/fedora/core/5/i386/os/',
'http://ftp.riken.jp/Linux/fedora/core/5/i386/os/',
'http://zeniv.linux.org.uk/pub/distributions/fedora/linux/core/5/i386/os/',
'http://zeniiia.linux.org.uk/pub/distributions/fedora/linux/core/5/i386/os/',
'ftp://ftp.wicks.co.nz/pub/linux/dist/fedora/5/i386/os/',
'ftp://ftp.rhd.ru/pub/fedora/linux/core/5/i386/os/',
'http://ftp.rhd.ru/pub/fedora/linux/core/5/i386/os/',
'ftp://ftp.ipex.cz/pub/linux/fedora/core/5/i386/os/',
'http://fedora.cat.pdx.edu/linux/core/5/i386/os/',
'http://fedora.ngi.it/5/i386/os/',
'ftp://falkor.skane.se/pub/mirrors/fedora/core/5/i386/os/',
'ftp://ftp.cica.es/fedora/linux/core/5/i386/os/',
'ftp://ftp.free.fr/mirrors/fedora.redhat.com/fedora/linux/core/5/i386/os/',
'http://ftp.ussg.iu.edu/linux/fedora/linux/core/5/i386/os/',
'http://ftp.surfnet.nl/ftp/pub/os/Linux/distr/fedora/5/i386/os/',
'http://ftp.nluug.nl/ftp/pub/os/Linux/distr/fedora/5/i386/os/',
'ftp://ftp.net.usf.edu/pub/fedora/linux/core/5/i386/os/',
'http://www.muug.mb.ca/pub/fedora/linux/core/5/i386/os/',
'http://mirror.eas.muohio.edu/fedora/linux/core/5/i386/os/',
'http://sunsite.mff.cuni.cz/pub/fedora/5/i386/os/',
'http://mirror.linux.duke.edu/pub/fedora/linux/core/5/i386/os/',
'http://distro.ibiblio.org/pub/linux/distributions/fedora/linux/core/5/i386/os/',
'http://mirror.hiwaay.net/redhat/fedora/linux/core/5/i386/os/',
'ftp://mirrors.hpcf.upr.edu/pub/Mirrors/redhat/download.fedora.redhat.com/5/i386/os/',
'http://redhat.secsup.org/fedora/core/5/i386/os/',
'ftp://ftp.dc.aleron.net/pub/linux/fedora/linux/core/5/i386/os/',
'ftp://mirror.newnanutilities.org/pub/fedora/linux/core/5/i386/os/',
'ftp://ftp.software.umn.edu/pub/linux/fedora/core/5/i386/os/',
'http://www.gtlib.cc.gatech.edu/pub/fedora.redhat/linux/core/5/i386/os/',
'ftp://fedora.mirrors.tds.net/pub/fedora-core/5/i386/os/',
'http://mirror.cs.wisc.edu/pub/mirrors/linux/download.fedora.redhat.com/pub/fedora/linux/core/5/i386/os/',
'http://ftp.ndlug.nd.edu/pub/fedora/linux/core/5/i386/os/',
'http://fedora.server4you.net/fedora/core/5/i386/os/',
'ftp://mirrors.ptd.net/fedora/core/5/i386/os/',
'ftp://fedora.bu.edu/fedora/core/5/i386/os/',
'http://mirror.pacific.net.au/linux/fedora/linux/core/5/i386/os/']
core                      100% |=========================| 1.1 kB    00:00
updates                                                              [2/3]
Baseurl(s) for repo:
['http://redhat.download.fedoraproject.org/pub/fedora/linux/core/updates/5/i386/',
'http://less.cogeco.net/pub/fedora/linux/core/updates/5/i386/',
'http://ftp.kddilabs.jp/Linux/packages/fedora/core/updates/5/i386/',
'http://fedora.inode.at/updates/5/i386/',
'http://mirrors.csumb.edu/fedora/updates/5/i386/',
'http://ftp.upjs.sk/pub/fedora/linux/core/updates/5/i386/',
'http://mirror.netglobalis.net/pub/fedora/updates/5/i386/',
'http://ftp1.skynet.cz/pub/linux/fedora/updates/5/i386/',
'http://ftp.iij.ad.jp/pub/linux/fedora/core/updates/5/i386/',
'http://mirrors.kernel.org/fedora/core/updates/5/i386/',
'ftp://falkor.skane.se/pub/mirrors/fedora/updates/5/i386/',
'ftp://ftp.quicknet.nl/pub/Linux/download.fedora.redhat.com/updates/5/i386/',
'ftp://ftp.wsisiz.edu.pl/pub/linux/fedora/linux/core/updates/5/i386/',
'http://fedora.mirrors.lug.ro/fedora/linux/core/updates/5/i386/',
'http://ftp.nara.wide.ad.jp/pub/Linux/fedora/core/updates/5/i386/',
'http://ftp.chg.ru/pub/Linux/fedora/linux/core/updates/5/i386/',
'ftp://ftp.wicks.co.nz/pub/linux/dist/fedora/updates/5/i386/',
'http://gulus.USherbrooke.ca/pub/distro/fedora/linux/core/updates/5/i386/',
'ftp://ftp.rdsor.ro/pub/Linux/Distributions/Fedora/updates/5/i386/',
'http://fedora.mirrors.tds.net/pub/fedora-core/updates/5/i386/',
'http://ftp.stw-bonn.de/pub/fedora/linux/core/updates/5/i386/',
'http://www.las.ic.unicamp.br/pub/fedora/linux/core/updates/5/i386/',
'http://www.mirrorservice.org/sites/download.fedora.redhat.com/pub/fedora/linux/core/updates/5/i386/',
'ftp://ftp.ciril.fr/pub//linux/fedora/linux/core/updates/5/i386/',
'http://ftp.crihan.fr/mirrors/fedora.redhat.com/fedora/linux/core/updates/5/i386/',
'ftp://ftp.fu-berlin.de/linux/fedora/core/updates/5/i386/',
'http://www.muug.mb.ca/pub/fedora/linux/core/updates/5/i386/',
'http://sunsite.mff.cuni.cz/pub/fedora/updates/5/i386/',
'http://mirror.hiwaay.net/pub/fedora/linux/core/updates/5/i386/',
'ftp://ftp.dc.aleron.net/pub/linux/fedora/linux/core/updates/5/i386/',
'http://fedora.colorado.edu/linux/core/updates/5/i386/',
'http://ftp.surfnet.nl/ftp/pub/os/Linux/distr/fedora/updates/5/i386/',
'http://ftp.nluug.nl/ftp/pub/os/Linux/distr/fedora/updates/5/i386/',
'http://fr.rpmfind.net/linux/fedora/core/updates/5/i386/',
'http://ftp.esat.net/pub/linux/fedora/updates/5/i386/',
'http://ftp.informatik.uni-frankfurt.de/fedora/core/updates/5/i386/',
'http://fr2.rpmfind.net/linux/fedora/core/updates/5/i386/',
'http://ftp.ale.org/mirrors/fedora/linux/core/updates/5/i386/',
'ftp://ftp.tecnoera.com/pub/fedora/linux/updates/5/i386/',
'http://mirror.optus.net/fedora/core/updates/5/i386/',
'http://ftp.rhd.ru/pub/fedora/linux/core/updates/5/i386/',
'http://mirror.linux.duke.edu/pub/fedora/linux/core/updates/5/i386/',
'http://distro.ibiblio.org/pub/linux/distributions/fedora/linux/core/updates/5/i386/',
'http://mirror.eas.muohio.edu/fedora/linux/core/updates/5/i386/',
'ftp://mirrors.hpcf.upr.edu/pub/Mirrors/redhat/download.fedora.redhat.com/updates/5/i386/',
'http://redhat.secsup.org/fedora/core/updates/5/i386/',
'ftp://mirror.newnanutilities.org/pub/fedora/linux/core/updates/5/i386/',
'ftp://ftp.software.umn.edu/pub/linux/fedora/core/updates/5/i386/',
'http://www.gtlib.cc.gatech.edu/pub/fedora.redhat/linux/core/updates/5/i386/',
'http://mirror.cs.wisc.edu/pub/mirrors/linux/download.fedora.redhat.com/pub/fedora/linux/core/updates/5/i386/',
'http://ftp.ndlug.nd.edu/pub/fedora/linux/core/updates/5/i386/',
'http://fedora.server4you.net/fedora/core/updates/5/i386/',
'ftp://mirrors.ptd.net/fedora/core/updates/5/i386/',
'ftp://fedora.bu.edu/fedora/core/updates/5/i386/',
'http://mirror.pacific.net.au/linux/fedora/linux/core/updates/5/i386/']
updates                   100% |=========================| 1.2 kB    00:00
extras                                                               [3/3]
Baseurl(s) for repo:
['http://download.fedora.redhat.com/pub/fedora/linux/extras/5/i386/',
'http://mirror.linux.duke.edu/pub/fedora/linux/extras/5/i386/',
'http://mirror.hiwaay.net/redhat/fedora/linux/extras/5/i386/',
'ftp://mirror.newnanutilities.org/pub/fedora/linux/extras/5/i386/',
'http://www.gtlib.cc.gatech.edu/pub/fedora.redhat/linux/extras/5/i386/',
'http://mirror.clarkson.edu/pub/distributions/fedora/linux/extras/5/i386/',
'ftp://fedora.mirrors.tds.net/pub/fedora-core-extras/5/i386/',
'ftp://fedora.bu.edu/fedora/extras/5/i386/',
'http://mirror.pacific.net.au/linux/fedora/linux/extras/5/i386/']
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Setting up Package Sacks
primary.xml.gz            100% |=========================| 767 kB    00:07
primary sqlite cache needs updating, reading in metadata
core      : ################################################## 2207/2207
Added 2207 new packages, deleted 0 old in 71.32 seconds
primary.xml.gz            100% |=========================| 469 kB    00:04
primary sqlite cache needs updating, reading in metadata
updates   : ################################################## 1392/1392
Added 1392 new packages, deleted 0 old in 56.32 seconds
primary.xml.gz            100% |=========================| 787 kB    00:08
primary sqlite cache needs updating, reading in metadata
extras    : ################################################## 2235/2235
Added 2235 new packages, deleted 0 old in 67.12 seconds
Reading Local RPMDB
Building updates object
Resolving Dependencies
1152398099.47
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for initscripts to pack into transaction set.
initscripts-8.31.5-1.i386 100% |=========================| 100 kB    00:01
Adding Package initscripts - 8.31.5-1.i386 in mode u
---> Package initscripts.i386 0:8.31.5-1 set to be updated
---> Downloading header for kernel to pack into transaction set.
kernel-2.6.17-1.2145_FC5. 100% |=========================| 164 kB    00:01
kernel - 2.6.17-1.2145_FC5.i586 converted to install
Adding Package kernel - 2.6.17-1.2145_FC5.i586 in mode i
---> Package kernel.i586 0:2.6.17-1.2145_FC5 set to be installed
--> Running transaction check
Running "postresolve" handler for "installonlyn" plugin
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i586 0:2.6.17-1.2139_FC5 set to be erased
Removing Package kernel - 2.6.17-1.2139_FC5.i586
--> Running transaction check

Dependencies Resolved
1152398105.82

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 kernel                  i586       2.6.17-1.2145_FC5  updates            14 M
Updating:
 initscripts             i386       8.31.5-1         updates           1.2 M
Removing:
 kernel                  i586       2.6.17-1.2139_FC5  installed          34 M

Transaction Summary
=============================================================================
Install      1 Package(s)
Update       1 Package(s)
Remove       1 Package(s)
Total download size: 15 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): initscripts-8.31.5 100% |=========================| 1.2 MB    00:12
(2/2): kernel-2.6.17-1.21 100% |=========================|  14 MB    02:24     ^[[D
Running Transaction Test
Removing Package kernel - 2.6.17-1.2139_FC5.i586
Adding Package initscripts - 8.31.5-1.i386 in mode u
Adding Package kernel - 2.6.17-1.2145_FC5.i586 in mode i
Finished Transaction Test
Transaction Test Succeeded
Removing Package kernel - 2.6.17-1.2139_FC5.i586
Adding Package initscripts - 8.31.5-1.i386 in mode u
Adding Package kernel - 2.6.17-1.2145_FC5.i586 in mode i
Running Transaction
  Installing: kernel                       ######################### [1/4]
warning: /etc/sysctl.conf saved as /etc/sysctl.conf.rpmsave
warning: /etc/sysconfig/network-scripts/ifcfg-lo saved as
/etc/sysconfig/network-scripts/ifcfg-lo.rpmsave
warning: /etc/rc.d/rc.local saved as /etc/rc.d/rc.local.rpmsave
warning: /etc/adjtime saved as /etc/adjtime.rpmsave
  Removing  : initscripts                  ######################### [2/4]
  Updating  : initscripts                  ######################### [3/4]
  Cleanup   : kernel                       ######################### [4/4]

Removed: kernel.i586 0:2.6.17-1.2139_FC5
Installed: kernel.i586 0:2.6.17-1.2145_FC5
Updated: initscripts.i386 0:8.31.5-1
Complete!
Comment 7 Seth Vidal 2006-07-09 23:58:38 EDT
*** Bug 198078 has been marked as a duplicate of this bug. ***
Comment 8 Jarod Wilson 2006-07-10 11:29:31 EDT
*** Bug 198047 has been marked as a duplicate of this bug. ***
Comment 9 Steve Tyler 2006-07-10 14:07:29 EDT
I had these four files renamed from foo to foo.rpmsave and not replaced:
/etc/adjtime
/etc/inittab
/etc/rc.d/rc.local
/etc/sysctl.conf

The problem occurred on only one of my two systems.
The system having the problem was updated from initscripts-8.31.1-1.i386.rpm.
The system not having the problem was updated from initscripts-8.31.4-1.i386.rpm
which was taken from the fedora updates-testing repo.

I recovered by booting off the rescue CD and renaming inittab.rpmsave to inittab.

== snippet from /var/log/messages.1 ==
Jul  8 09:20:25 cedar kernel: i2c_adapter i2c-0: Transaction error!
Jul  8 09:58:45 cedar named[1597]: listening on IPv4 interface eth0,
192.168.0.100#53
Jul  8 09:59:08 cedar kernel: loop: loaded (max 8 devices)
Jul  8 09:59:38 cedar yum: Installed: kernel.i686 2.6.17-1.2145_FC5
Jul  8 09:59:40 cedar yum: Erased: initscripts
Jul  8 09:59:44 cedar yum: Updated: xorg-x11-drv-ati.i386 6.5.8.0-1
Jul  8 10:02:03 cedar yum: Installed: kernel-devel.i686 2.6.17-1.2145_FC5
Jul  8 10:02:08 cedar yum: Updated: initscripts.i386 8.31.5-1
Jul  8 10:02:14 cedar yum: Updated: kernel-doc.noarch 2.6.17-1.2145_FC5
Jul  8 10:02:16 cedar yum: Installed: kmod-nvidia.i686 1.0.8762-2.2.6.17_1.2145_FC5
Jul  8 10:18:20 cedar gpm[1784]: *** info [mice.c(1766)]:
Jul  8 10:18:20 cedar gpm[1784]: imps2: Auto-detected intellimouse PS/2
Jul  8 10:18:21 cedar kernel: agpgart: Found an AGP 2.0 compliant device at
0000:00:00.0.
Jul  8 10:18:21 cedar kernel: agpgart: Putting AGP V2 device at 0000:00:00.0
into 4x mode
Jul  8 10:18:21 cedar kernel: agpgart: Putting AGP V2 device at 0000:01:00.0
into 4x mode
Jul  8 10:18:29 cedar gdm[1952]: Restarting computer...
Jul  8 10:18:29 cedar shutdown[1952]: shutting down for system reboot
Jul  8 10:18:30 cedar gpm[1784]: *** info [mice.c(1766)]:
Jul  8 10:18:30 cedar gpm[1784]: imps2: Auto-detected intellimouse PS/2
Jul  8 10:18:30 cedar init: Switching to runlevel: 6
Jul  8 10:18:30 cedar init: No inittab file found
Jul  8 10:18:31 cedar init: no more processes left in this runlevel
Jul  8 10:18:45 cedar gconfd (stephent-21195): GConf server is not in use,
shutting down.
Jul  8 10:18:45 cedar gconfd (stephent-21195): Exiting
Jul  8 10:30:42 cedar syslogd 1.4.1: restart.

== snippet from /var/log/yum.log ==
Jul 07 14:06:44 Updated: qt-designer.i386 1:3.3.6-0.3.fc5
Jul 08 09:59:38 Installed: kernel.i686 2.6.17-1.2145_FC5
Jul 08 09:59:40 Erased: initscripts
Jul 08 09:59:44 Updated: xorg-x11-drv-ati.i386 6.5.8.0-1
Jul 08 10:02:03 Installed: kernel-devel.i686 2.6.17-1.2145_FC5
Jul 08 10:02:08 Updated: initscripts.i386 8.31.5-1
Jul 08 10:02:14 Updated: kernel-doc.noarch 2.6.17-1.2145_FC5
Jul 08 10:02:16 Installed: kmod-nvidia.i686 1.0.8762-2.2.6.17_1.2145_FC5

==
[root@cedar stephent]# ls -lF /etc/adjtime /etc/rc.d/rc.local /etc/inittab
/etc/sysctl.conf
-rw-r--r-- 1 root root   47 Jul 10 02:58 /etc/adjtime
-rw-r--r-- 1 root root 1663 Jul  8 10:55 /etc/inittab
-rwxr-xr-x 1 root root  257 Jun 11 09:05 /etc/rc.d/rc.local*
-rw-r--r-- 1 root root  828 Dec  8  2005 /etc/sysctl.conf

[root@cedar stephent]# rpm -V initscripts
..5....T  c /etc/inittab
S.5....T  c /etc/rc.d/rc.local
S.5....T  c /etc/sysctl.conf

==
Comment 10 Seth Vidal 2006-07-10 14:58:51 EDT
why is this assigned to yum? The code which puts files into place is inside rpm.
Comment 11 Peter Gordon 2006-07-10 15:09:37 EDT
I also sent in this as a bug to yum This is the second time in two weeks that
yum has deleted a package and then reinstalled a package leaving files out. The
other package was xorg which left the system without a config file. So maybe it
is a yum bug or maybe we are just trying to say that it is common to both, There
doesn't seem to be any other way on bugzilla to bring these types of system
problem together.
Comment 12 Bill Nottingham 2006-07-10 15:43:43 EDT
*** Bug 185528 has been marked as a duplicate of this bug. ***
Comment 13 Bill Nottingham 2006-07-10 15:49:52 EDT
It's assigned to yum because something really odd is happening in the
transaction; you get initscripts selected for update, yet it gets updated as:

 <some packages here>
 Removing: initscripts
 <some packages here>
 Updating: initscripts
 <some packages here>

This is what's causing the breakage. (see the yum logs above.) If it's selected
for update, it should be
updated as:

  Updating: initscripts
  <some packages here>
  Cleanup: initscripts

I have no idea *how* it's getting in the transaction like this. My guess, since
it seems to always happen when there's a kernel also in the transaction set, is
some bug in the installonlyn plugin. But that's just a guess.
Comment 14 Steve Tyler 2006-07-10 16:44:38 EDT
(In reply to comment #9)

> The problem occurred on only one of my two systems.
> The system having the problem was updated from initscripts-8.31.1-1.i386.rpm.

Third party packages from livna.org:
kmod-nvidia-1.0.8762-2.2.6.17_1.2145_FC5
xorg-x11-drv-nvidia-1.0.8762-3.lvn5

SELINUX=disabled

> The system not having the problem was updated from initscripts-8.31.4-1.i386.rpm

There are no "Erased:" entries in yum.log on the system NOT having the problem.
SELINUX=disabled

Both systems have the installonlyn plugin enabled.
I think both systems had the "tokeep" value increased from 2 to 3 or 4.

== snippet from /var/log/yum.log on system NOT having problem ==
Jul 03 13:17:45 Updated: gnupg.i386 1.4.4-2
Jul 03 13:17:47 Updated: nfs-utils.i386 1:1.0.8-2.fc5
Jul 03 13:24:58 Updated: xorg-x11-server-Xorg.i386 1.0.1-9.fc5.5
Jul 05 14:00:14 Updated: initscripts.i386 8.31.4-1
Jul 05 14:18:49 Installed: NetworkManager-gnome.i386 0.6.3-1.fc5
Jul 07 13:58:56 Updated: wxGTK.i386 2.6.3-2.6.3.2.2.fc5
Jul 07 13:58:59 Updated: qt.i386 1:3.3.6-0.3.fc5
Jul 07 13:59:02 Updated: lftp.i386 3.4.7-2.FC5
Jul 07 13:59:05 Updated: gnupg.i386 1.4.4-2.2
Jul 08 10:09:38 Updated: kernel-doc.noarch 2.6.17-1.2145_FC5
Jul 08 10:09:40 Updated: xorg-x11-drv-ati.i386 6.5.8.0-1
Jul 08 10:10:05 Installed: kernel.i686 2.6.17-1.2145_FC5
Jul 08 10:11:32 Installed: kernel-devel.i686 2.6.17-1.2145_FC5
Jul 08 10:11:37 Updated: initscripts.i386 8.31.5-1

==
Comment 15 Jeremy Katz 2006-07-10 19:42:35 EDT

*** This bug has been marked as a duplicate of 196590 ***

Note You need to log in before you can comment on or make changes to this bug.