Bug 198054 - sysfsutils doesn't obsolete sysfsutils-devel
sysfsutils doesn't obsolete sysfsutils-devel
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: sysfsutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
:
: 198091 (view as bug list)
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-07-08 15:50 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 09:40:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-07-08 15:50:15 EDT
Description of problem:
# rpm -Uvh /usr/src/rpm/RPMS/i386/sysfsutils-2.0.0-3.i386.rpm \
           /usr/src/rpm/RPMS/i386/libsysfs-2.0.0-3.i386.rpm \
           /usr/src/rpm/RPMS/i386/libsysfs-devel-2.0.0-3.i386.rpm
error: Failed dependencies:
      libsysfs.so.1 is needed by (installed) lm_sensors-2.10.0-2.i386
      sysfsutils = 1.3.0 is needed by (installed) sysfsutils-devel-1.3.0-2.i386
#

Version-Release number of selected component (if applicable):
sysfsutils-2.0.0-3

How reproducible:
Everytime, see above.

Actual results:
sysfsutils doesn't obsolete sysfsutils-devel

Expected results:
The issue can be resolved for example by something like this (I'm putting
the obsoletes of sysfsutils-devel into the libsysfs-devel package, because the 
libsysfs-devel package is the replacement of the older sysfsutils-devel):

--- sysfsutils.spec       2006-07-08 01:33:14.000000000 +0200
+++ sysfsutils.spec.rsc   2006-07-08 21:54:52.000000000 +0200
@@ -24,6 +24,7 @@
 Summary: Static library and headers for libsysfs
 Group: Development/Libraries
 Requires: libsysfs = %{version}
+Obsoletes: sysfsutils-devel

 %description -n libsysfs-devel
 libsysfs-devel provides the header files and static libraries required
Comment 1 Neil Horman 2006-07-10 09:09:41 EDT
checked in and built.  Thanks!
Comment 2 Neil Horman 2006-07-10 10:26:31 EDT
*** Bug 198091 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.