Bug 198071 - BCM4318 sometimes work, sometimes not, sometime crash
BCM4318 sometimes work, sometimes not, sometime crash
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
: 213880 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-08 22:25 EDT by Ricardo Ariel Gorosito
Modified: 2007-12-13 17:18 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-13 17:18:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from third boot (86.85 KB, text/plain)
2006-07-08 22:25 EDT, Ricardo Ariel Gorosito
no flags Details
output of dmesg (26.98 KB, text/plain)
2007-02-10 17:25 EST, Matěj Cepl
no flags Details
appropriate part of /var/log/messages (226.10 KB, text/plain)
2007-02-10 17:29 EST, Matěj Cepl
no flags Details
output of dmesg (76.81 KB, text/plain)
2007-03-26 17:00 EDT, Matěj Cepl
no flags Details
/var/log/messages (94.63 KB, text/plain)
2007-03-26 17:05 EDT, Matěj Cepl
no flags Details
The relevant part of dmesg (2.30 KB, text/plain)
2007-06-01 11:49 EDT, Matěj Cepl
no flags Details
output of dmesg.txt (10.59 KB, text/plain)
2007-09-22 17:35 EDT, Matěj Cepl
no flags Details
/var/log/messages (236.04 KB, text/plain)
2007-09-22 17:48 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Ricardo Ariel Gorosito 2006-07-08 22:25:19 EDT
Description of problem:

I don't know how to reproduce this. I was installed FC5, updated to rawhide,
reboot, and bcm4318 was worked fine. In another boot, the machine hang (~
seconds after boot) in third boot, dont hang, but dont work.

dmesg is attached
Comment 1 Ricardo Ariel Gorosito 2006-07-08 22:25:19 EDT
Created attachment 132120 [details]
dmesg from third boot
Comment 2 Ricardo Ariel Gorosito 2006-07-08 23:03:13 EDT
FC5 was used ndiswrapper. Because I has a dual boot, I was booted into Centos
4.3 + ndiswrapper (kernel with 8k stack). wlan0 worked fine. Booted into FC5.90
(rawhide) and wlan0 worked fine! son logs from dmesg:
...
bcm43xx: Chip ID 0x4318, rev 0x2
bcm43xx: Number of cores: 4
bcm43xx: Core 0: ID 0x800, rev 0xd, vendor 0x4243, enabled
bcm43xx: Core 1: ID 0x812, rev 0x9, vendor 0x4243, disabled
bcm43xx: Core 2: ID 0x804, rev 0xc, vendor 0x4243, enabled
bcm43xx: Core 3: ID 0x80d, rev 0x7, vendor 0x4243, enabled
bcm43xx: PHY connected
bcm43xx: Detected PHY: Version: 3, Type 2, Revision 7
bcm43xx: Detected Radio: ID: 8205017f (Manuf: 17f Ver: 2050 Rev: 8)
bcm43xx: Radio turned off
bcm43xx: Radio turned off
...
SoftMAC: ASSERTION FAILED (0) at:
net/ieee80211/softmac/ieee80211softmac_wx.c:306:ieee80211softmac_wx_get_rate()
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Associate: failed to initiate scan. Is device up?
bcm43xx: PHY connected
bcm43xx: Radio turned on
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at:
drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1490:bcm43xx_find_lopair()
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at:
drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1490:bcm43xx_find_lopair()
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at:
drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1490:bcm43xx_find_lopair()
bcm43xx: Chip initialized
bcm43xx: DMA initialized
bcm43xx: 80211 cores initialized
bcm43xx: Keys cleared
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at:
drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1490:bcm43xx_find_lopair()
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Queueing Authentication Request to 00:14:bf:31:2b:a2
SoftMAC: Cannot associate without being authenticated, requested authentication
SoftMAC: Already requested authentication, waiting...
SoftMAC: Sent Authentication Request to 00:14:bf:31:2b:a2.
SoftMAC: Open Authentication completed with 00:14:bf:31:2b:a2
SoftMAC: sent association request!
SoftMAC: associated!
...
Comment 4 John W. Linville 2006-11-06 14:15:22 EST
*** Bug 213880 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Layton 2006-11-06 14:26:47 EST
...actually 213880 has a bit more useful info in it, and I'm having the same
problem as in there. Here's the info I was posting there:

I have the same chip in my new laptop and the same problem. I seem to get very
spotty connectivity.

I see the same stack traces occasionally as were posted to 213880 in the logs
too. Note that those are not actually oopses -- those are just stack traces from
the sanity check in bcm43xx_lo_write.

I'll also mention that I've tried the latest kernel on linville's people page
(kernel-2.6.18-1.2831.2.1.fc6.jwltest.12). And have also tried a couple of
different firmware revisions:

3.100.46.0
3.120.27.0

...anyone who has successfully gotten this chip working, please post the
firmware rev you're using.

Still looking at the cause.
Comment 9 John W. Linville 2007-02-09 11:12:49 EST
FC6 test kernels w/ late bcm43xx updates (including some for 4311/4312/4318) 
are available here:

   http://people.redhat.com/linville/kernels/fc6/

Please give them a try and post the results here...thanks!
Comment 10 Matěj Cepl 2007-02-10 17:23:27 EST
Hi, John,

thanks for this attempt, but unfortunately I have to report
failure -- BCM43xx driver in your kernel is good enough to make
iwlist eth1 scan working, I can also switch ESSID and enc of the
eth1, but I cannot switch mode to Ad-Hoc and I cannot switch
bitrate, so of of course ifup eth1 fails miserably:

$ ifup eth1
Error for wireless request "Set Mode" (8B06) :
    SET failed on device eth1 ; Device or resource busy.
Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device eth1 ; Operation not supported.

Zjišťuji IP informace pro eth1...
(Ctrl-C)
$

After finishing these tests, I managed to build RPM of
ndiswrapper-kmod on your kernel (I know, you don't like it, but I
really need some functional wi-fi now) and to my surprise
iwconfig fails in the absolutely same  way as bcm43xx does (yes,
I checked that bcm43xx kernel module is really gone). Does your
kernel breaks ndiswrapper? If yes, and it is against your
religion to make it work, could you please at least not conflict
standard Fedora Updates kernel (kernel-2.6.19-1.2895.fc6 as of
now), so that I could reboot to working network system, when not
testing your kernel?

Thanks,

Matej
Comment 11 Matěj Cepl 2007-02-10 17:25:13 EST
Created attachment 147843 [details]
output of dmesg

Notice that I was trying to load bcm43xx driver couple of times (fighting with
firmware, etc.), so there are more sections with reports.
Comment 12 Matěj Cepl 2007-02-10 17:29:22 EST
Created attachment 147844 [details]
appropriate part of /var/log/messages
Comment 13 John W. Linville 2007-02-12 09:51:04 EST
Matej,

I have not intentionally broken ndiswrapper with my test kernels.  And I have 
never used ndiswrapper, so I don't have any idea what might have broken it for 
you.  I apologize for the inconvenience, but then the point of the test kernel 
was for testing the in-kernel driver anyway. :-)

I don't really understand your request about not conflicted with Fedora update 
kernels.  How have I done that?  My kernels have "jwltest.<number>" appended 
to the version string.
Comment 14 John W. Linville 2007-02-13 10:12:04 EST
It turns-out that the last round of patches only helps the bcm4311 and 
bcm4312.  Since those have some genetic relations with the bcm4318 I thought 
it would help here too, but alas...  I'll keep watching for relevant patches.
Comment 15 Jeff Layton 2007-03-22 15:53:56 EDT
I've had success with the latest jwltest kernel and my bcm4318 card:

kernel: 2.6.20-1.2925.4.1.fc6.jwltest.28

firmware:
  filename   :  bcmwl5.sys
  version    :  4.40.19.0
  MD5        :  114234fafec7060392195170e1c4d45e
  microcodes :  4 5 11 
  pcms       :  4 5 

lspci info:

06:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g]
802.11g Wireless LAN Controller (rev 02)
06:02.0 0280: 14e4:4318 (rev 02)

I also tested with the latest stock fc6 kernel, but it didn't seem to accept
version 4 firmware, so I think that may be what did it.

John, thanks for all the hard work! Let me know if you need any more info.
Canceling the needinfo since it seems like this should answer it...
Comment 16 Jeff Layton 2007-03-22 16:10:45 EDT
The only issue I see is that I seem to get a lot of kernel ring buffer spam that
looks something like this:

wmaster0: TX to low-level driver (len=168) FC=0x0108 DUR=0x00d5 A1=00:04:5a:0f:2
1:e2 A2=00:14:a5:e8:82:52 A3=00:40:63:ca:c8:50

...and NetworkManger is complaining:

Mar 22 16:05:58 tupile NetworkManager: <WARNING>        
nm_device_802_11_wireless_set_mode (): error setting card eth1 to Infrastructure
mode: Device or resource busy



...seems to work fine though.
Comment 17 Matěj Cepl 2007-03-24 02:38:22 EDT
John, before I can even test your new kernel, one comment -- it would be better
if FC6 kernel doesn't depend on packages in Rawhide (mkinitrd-6.0.8-4 in this case).
Comment 18 John W. Linville 2007-03-25 20:47:46 EDT
Matej, check again?

[savage]:> rpm -qRp kernel-2.6.20-1.2925.6.1.fc6.jwltest.29.i686.rpm
rpmlib(VersionedDependencies) <= 3.0.3-1
fileutils
module-init-tools
initscripts >= 8.11.1-1
mkinitrd >= 5.1.19.0.2-1
/bin/sh
/bin/sh
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
Comment 19 Matěj Cepl 2007-03-26 17:00:19 EDT
Created attachment 150958 [details]
output of dmesg

I have no idea what was that mkinitrd issue -- I am quite sure, that I haven't
invented that version number, but now on the second attempt the kernel
downloaded from your site, just works.

Anyway, I am afraid that not much has changed in the support of my card. It is
more or less successfully loaded, but mode and ESSID cannot be set. See this
output of dmesg and following copy of /var/log/messages
Comment 20 Matěj Cepl 2007-03-26 17:05:12 EDT
Created attachment 150960 [details]
/var/log/messages
Comment 21 John W. Linville 2007-04-10 16:47:37 EDT
AFAIK, the bcm4318 actually works better with the older "bcm43xx" driver (i.e. 
not "bcm43xx-mac80211".  If you install version 3 firmware then the bcm43xx 
should be able to load and run instead of bcm43xx-mac80211 (which may still 
load, but won't be able to run).  Could you give that a try and post the 
results here?  Thanks!
Comment 22 Matěj Cepl 2007-05-08 18:48:19 EDT
meaning to use 3 firmware with bcm43xx from the mainline Fedora Core 6 kernel?
Comment 23 Matěj Cepl 2007-06-01 11:49:17 EDT
Created attachment 155899 [details]
The relevant part of dmesg

John, following your advice on IRC, after upgrade to FC7 (Fedora kernel 
2.6.21-1.3194.fc7; do you have anything better?) I have installed the firmware
you pointed me to. The results are attached and they are not that great. When
doing ifup eth1 I got these on stderr:

sh-3.2# ifup eth1
Error for wireless request "Set Mode" (8B06) :
    SET failed on device eth1 ; Invalid argument.
Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device eth1 ; Operation not supported.

Zjišťuji IP informace pro eth1... selhalo.
sh-3.2#
Comment 24 John W. Linville 2007-08-21 14:40:39 EDT
Have you tried the latest rawhide kernel?  There have been a lot of b43 (new 
name for bcm43xx-mac80211) updates recently, including some claiming 
improvements for the bcm4318.
Comment 25 Matěj Cepl 2007-08-27 05:29:26 EDT
(In reply to comment #7)
> Matej (or anyone), would you be willing to loan your 4318 device to someone in 
> Germany?

John, is this still relevant? I have bought new laptop (with Intel PRO 3945ABG,
of course; burnt twice ...) so I won't need this wi-fi card anymore.
Comment 26 Matěj Cepl 2007-09-22 17:35:17 EDT
Created attachment 203231 [details]
output of dmesg.txt
Comment 27 Matěj Cepl 2007-09-22 17:48:51 EDT
Created attachment 203241 [details]
/var/log/messages

John,

I have tried again with b34 driver with the latest kernel available for
F7-updates-testing (2.6.22.6-81.fc7) and the results are interesting (BTW, PCI
ID of the card is 14e4:4318). First of all, I tried to use b43-cutter, but b43
driver was not able to recognize the files in /lib/firmware. Only when I used
old bcm43xx-fwcutter, b43 was satisfied and started as if everything was all
right. I haven't found any error messages neither in dmesg nor in
/var/log/messages, but when I set up everything necessary with iwconfig (ESSID,
and enc) again without any error messages, so it looked like everything was all
right, and when I tried dhclient it never got IP address. Of course,
NetworkManager was not able to connect to the wireless network. Couple of
seconds later when I switched back to ndiswrapper, and when I have repeated the
same steps (iwconfig, dhclient) I got IP connection without any problems.

Could you think about something I could do wrong in configuration of b43
driver, or we are just not there yet?
http://www.linuxwireless.org/en/users/Devices/PCI seems to claim, that this
card (Dell TrueMobile) is supported by b43.
Comment 28 John W. Linville 2007-10-22 10:04:35 EDT
Would you mind testing these F8-based kernels?

   http://koji.fedoraproject.org/koji/taskinfo?taskID=203296

Do they improve the situation for you?
Comment 29 John W. Linville 2007-12-13 17:18:24 EST
Closed due to lack of response...please re-open if/when the requested 
information becomes available...

Note You need to log in before you can comment on or make changes to this bug.