Bug 213880 - BCM4318 wifi card doesn't work with bcm43xx driver
BCM4318 wifi card doesn't work with bcm43xx driver
Status: CLOSED DUPLICATE of bug 198071
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-03 11:29 EST by Matěj Cepl
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 14:15:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
identification information for firmware (621 bytes, text/plain)
2006-11-03 15:07 EST, Matěj Cepl
no flags Details
Output of dmesg with some nice oopses (26.67 KB, text/plain)
2006-11-03 15:11 EST, Matěj Cepl
no flags Details
part of /var/log/messages corresponding to the attachment 140309 (12.88 KB, text/plain)
2006-11-03 15:15 EST, Matěj Cepl
no flags Details
Another attempt to get bcm43xx working, another oopses (56.46 KB, text/plain)
2006-11-03 15:27 EST, Matěj Cepl
no flags Details
/var/log/messages corresponding to the attachment 140311 (9.08 KB, text/plain)
2006-11-03 15:50 EST, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2006-11-03 11:29:41 EST
Description of problem:
Using bcm43xx driver I am not able to connect to the wireless network even in
the situation when the same computer is easily able to connect with ndiswrapper.
See attached logs for more details.

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2798.fc6

How reproducible:
100%

Steps to Reproduce:
1.install bcm43xx drivers by copying
/usr/share/doc/bcm43xx-fwcutter-005/modprobe.bcm43xx to /etc/modprobe.d
2.run modprobe -v bcm43xx
3.
  
Actual results:
Device eth1 is created, iwscan eth1 scan gives some results, but ifup eth1
doesn't get any results (even when with ndiswrapper, computer can connect)

Expected results:
Computer is able to connect to wifi network.

Additional info:
I have been discussing this issue with upstream developers for more than a year,
and their opinion is that bcm43xx driver doesn't support well my BCM4318 chipset
(when searching
http://search.gmane.org/?query=bcm4318&group=gmane.linux.drivers.bcm54xx.devel
you can see that there more reports with this card not working without any
proper resolution).
The type of firmware used is indicated, I am not sure about particular URL where
I got it from, but it was widely recommended on the above mentioned list as
working (I can attach it to this bug of course, if needed).
Comment 1 Matěj Cepl 2006-11-03 15:07:58 EST
Created attachment 140308 [details]
identification information for firmware
Comment 2 Matěj Cepl 2006-11-03 15:11:14 EST
Created attachment 140309 [details]
Output of dmesg with some nice oopses
Comment 3 Matěj Cepl 2006-11-03 15:15:21 EST
Created attachment 140310 [details]
part of /var/log/messages corresponding to the attachment 140309 [details]
Comment 4 Matěj Cepl 2006-11-03 15:27:35 EST
Created attachment 140311 [details]
Another attempt to get bcm43xx working, another oopses
Comment 5 Matěj Cepl 2006-11-03 15:50:59 EST
Created attachment 140317 [details]
/var/log/messages corresponding to the attachment 140311 [details]
Comment 6 John W. Linville 2006-11-06 14:15:06 EST

*** This bug has been marked as a duplicate of 198071 ***

Note You need to log in before you can comment on or make changes to this bug.