Bug 198083 - xfce4 menu "quit" does nothing.
xfce4 menu "quit" does nothing.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xfdesktop (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-09 07:10 EDT by James Hunt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 16:04:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Hunt 2006-07-09 07:10:10 EDT
Description of problem:

Right-clicking background and then selecting "Quit" from menu does not exit
XFCE4: nothing happens except that it is no longer possible to right-click to
bring up the menu. It is almost as though "Quit" on the menu just causes the
menu part of XFCE4 to quit.

Version-Release number of selected component (if applicable):
# rpm -qa|egrep -i "^xf"|sort
xfce4-cpugraph-plugin-0.2.2-6.fc5
xfce4-datetime-plugin-0.3.1-7.fc5
xfce4-diskperf-plugin-1.5-6.fc5
xfce4-iconbox-4.2.3-3.fc5
xfce4-mixer-4.2.3-2.fc5
xfce4-netload-plugin-0.3.3-6.fc5
xfce4-panel-4.2.3-4.fc5
xfce4-systemload-plugin-0.3.6-6.fc5
xfce4-systray-4.2.3-2.fc5
xfce4-xmms-plugin-0.3.1-6.fc5
xfce-mcs-manager-4.2.3-2.fc5
xfce-mcs-plugins-4.2.3-3.fc5
xfce-utils-4.2.3-4.fc5
xfdesktop-4.2.3-4.fc5
xffm-4.2.3-4.fc5
xffm-icons-4.0.6-2
xfig-3.2.4-17.3.fc5
xforms-1.0.90-6.fc5.2
xfprint-4.2.3-3.fc5
xfwm4-4.2.3.2-5.fc5
xfwm4-themes-4.2.3-2.fc5
# 

How reproducible:

Every time.

Steps to Reproduce:
1. Right-click on background
2. Select "Quit" from menu
  
Actual results:

XFCE4 does not quit.

Expected results:

To be logged out!

Additional info:

Clicking the "Exit" button on the panel works as expected, and logs me out.
Comment 1 James Hunt 2006-07-09 07:13:18 EDT
Here's the contents of my session file (from /tmp):

/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/bin/sessreg -a -w /var/log/wtmp -u
/var/run/utmp -x "/var/gdm/:0.Xservers" -h "" -l ":0" "james"
/usr/bin/startxfce4: X server already running on display :0
which: no xfce4-session in
(/usr/lib/qt-3.3/bin:/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/james/bin)
/etc/xdg/xfce4/xinitrc: line 120: xfcalendar: command not found
** Message: Cannot connect to session manager

** (xfdesktop:5934): CRITICAL **: Unable to get keyboard/mouse grab.  Unable to
popup desktop menu

** (xfdesktop:5934): CRITICAL **: Unable to get keyboard/mouse grab.  Unable to
popup desktop menu

** (xfdesktop:5934): CRITICAL **: Unable to get keyboard/mouse grab.  Unable to
popup desktop menu

** (xfdesktop:5934): CRITICAL **: Unable to get keyboard/mouse grab.  Unable to
popup desktop menu

I am aware that xfce4-session is not installed - that causes me other problems
(see the next bug I'm about to create). If this is the reason for the strange
"quit" behavious, I would suggest that the dependencies for XFCE4 are broken
since I can install/uninstall xfce4-session "stand-alone" (ie no other
dependencies are affected).


Comment 2 James Hunt 2006-07-09 07:23:22 EDT
See bug 198085 - it may be related (?)
Comment 3 Kevin Fenzi 2006-07-10 12:25:54 EDT
Thanks for the bug report. 

xfce4-session not installed shouldn't be a problem. You just then don't have 
the ability to save your session. 

Is the session file output in comment #1 from after or before you tried to use 
the 'quit' option? If before, can you provide one after and see if any 
additional output it displayed? 

Are you using nautilus? is it running at any point? 
Comment 4 James Hunt 2006-07-10 14:00:40 EDT
Right, before I attempt to "Quit" via the menu, here's the contents of my gdm
session file:

$ cat `ls -alt /tmp/xses-james.*|head -1|awk '{print $NF}'`
/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/bin/sessreg -a -w /var/log/wtmp -u
/var/run/utmp -x "/var/gdm/:0.Xservers" -h "" -l ":0" "james"
/usr/bin/startxfce4: X server already running on display :0
which: no xfce4-session in
(/usr/lib/qt-3.3/bin:/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/james/bin)

(xfce-mcs-manager:3637): libxfce4mcs-CRITICAL **:
mcs_manager_add_channel_from_file: assertion `filename != NULL && strlen
(filename) > 0' failed
/etc/xdg/xfce4/xinitrc: line 120: xfcalendar: command not found
** Message: Cannot connect to session manager
$ 

NB: Note the juicy assert failure this time!

I copied this file to another name, and then did a right-click and "Quit". I
then compared the copied file to the original - no difference.

Here's what's running:

$ ps -efwww|grep james|grep -v grep
james     3572  2311  0 19:01 ?        00:00:00 /bin/sh /etc/xdg/xfce4/xinitrc
james     3623  3572  0 19:01 ?        00:00:00 /usr/bin/ssh-agent
/usr/bin/dbus-launch --exit-with-session startxfce4
james     3626     1  0 19:01 ?        00:00:00 /usr/bin/dbus-launch
--exit-with-session startxfce4
james     3627     1  0 19:01 ?        00:00:00 dbus-daemon --fork --print-pid 8
--print-address 6 --session
james     3632  3572  0 19:01 ?        00:00:00 /bin/sh /etc/xdg/xfce4/xinitrc
james     3633  3632  0 19:01 ?        00:00:00 xscreensaver -no-splash
james     3639     1  0 19:01 ?        00:00:00 xfce-mcs-manager
james     3641     1  0 19:01 ?        00:00:00 xfwm4 --daemon
james     3642  3572  0 19:01 ?        00:00:00 xftaskbar4
james     3646  3572  0 19:01 ?        00:00:01 /usr/bin/xfce4-panel
james     3649     1  0 19:01 ?        00:00:00 xterm -title Terminal
james     3651  3649  0 19:01 pts/1    00:00:00 bash
james     3711     1  0 19:03 ?        00:00:00 xterm -title Terminal
james     3713  3711  0 19:03 pts/2    00:00:00 bash
james     3741  3713  0 19:03 pts/2    00:00:00 /bin/sh
/usr/lib/firefox-1.5.0.4/firefox
james     3750  3741  0 19:03 pts/2    00:00:00 /bin/sh
/usr/lib/firefox-1.5.0.4/run-mozilla.sh /usr/lib/firefox-1.5.0.4/firefox-bin
james     3755  3750  6 19:03 pts/2    00:00:14 /usr/lib/firefox-1.5.0.4/firefox-bin
james     3759     1  0 19:03 pts/2    00:00:00 /usr/libexec/gconfd-2 10
james     3796  3651  0 19:06 pts/1    00:00:00 ps -efwww
$ 

Note: I don't use nautilus.

As usual, once I've attempted to "Quit" once, that's it - game over. You can
never get the menu to appear again.
Comment 5 Kevin Fenzi 2006-07-10 16:28:23 EDT
Did you follow rawhide/devel with this machine before fc5 release and use yum 
to update to fc5 when it was released? Or was this machine installed only with 
release versions?

If you make a new user and login as them, do you see the same behavior?
Comment 6 James Hunt 2006-07-11 15:35:13 EDT
No - I'm not using rawhide/devel and never have.
The box I'm using has always been updated using the official FC release CD's - I
haven't upgraded using only yum ever. I think my machine started out as a FC3 box.

I tried adding a new user, and logging in to xfce4 - same problem: right-click
-> Quit does nothing. Also, the /tmp/xses-* file contained _exactly_ the same as
my user, assert failure and all.

Weird, eh?
Comment 7 Kevin Fenzi 2006-07-11 17:54:20 EDT
ok. I am able to duplicate this here... 

If xfce4-session is not running/installed, and you use Quit from the xfdesktop 
menu, it causes xfdesktop to quit, it doesn't cause you to logout. 

This almost looks like upstream bug #192, but it was fixed years ago. 
Will see about reporting it upstream. 
Comment 8 Kevin Fenzi 2006-07-11 23:15:09 EDT
Upstream bug filed at: 
http://bugzilla.xfce.org/show_bug.cgi?id=2018

Note that this doesn't seem to happen with xfce4-session installed. 
Also, my 4.4b1 testing packages don't show this bug either. 

Comment 9 Kevin Fenzi 2006-09-25 16:04:34 EDT
The upstream bug here has been closed WONTFIX, because no minor fixes are being 
done to the 4.3.2 branch anymore. 

I have confirmed that the problem is fixed in the new 4.4rc1 packages. 

I am going to go ahead and close this bug now. 
Thanks for the report. 

Note You need to log in before you can comment on or make changes to this bug.