Bug 198085 - xfce4 session causes session to exit!
xfce4 session causes session to exit!
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xfdesktop (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-09 07:22 EDT by James Hunt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 13:17:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gzip compressed output of "exec /usr/bin/strace -f -o /tmp/trace.out /usr/bin/startxfce4" (109.40 KB, application/octet-stream)
2006-07-14 06:22 EDT, James Hunt
no flags Details

  None (edit)
Description James Hunt 2006-07-09 07:22:27 EDT
Description of problem:

If I attempt to login using an XFCE4 session when the xfce4-session package is
installed, I get that gnome/gtk box popping up which says,

  Your session lasted less than 10 seconds...

  Click to view your ~/.xsession-errors file

The contents of this file is:

/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/bin/sessreg -a -w /var/log/wtmp -u
/var/run/utmp -x "/var/gdm/:0.Xservers" -h "" -l ":0" "james"
/usr/bin/startxfce4: X server already running on display :0
xfce4-session: Unable to load failsafe session, exiting. Please check
               the value of the environment variable XDG_CONFIG_DIRS
               and make sure that it includes the following path:

                /etc/xdg

Indeed, I have no XD* variables set in my environment.

Version-Release number of selected component (if applicable):

# rpm -qa|egrep -i "^xf"|sort
xfce4-cpugraph-plugin-0.2.2-6.fc5
xfce4-datetime-plugin-0.3.1-7.fc5
xfce4-diskperf-plugin-1.5-6.fc5
xfce4-iconbox-4.2.3-3.fc5
xfce4-mixer-4.2.3-2.fc5
xfce4-netload-plugin-0.3.3-6.fc5
xfce4-panel-4.2.3-4.fc5
xfce4-session-4.2.3-3.fc5
xfce4-systemload-plugin-0.3.6-6.fc5
xfce4-systray-4.2.3-2.fc5
xfce4-xmms-plugin-0.3.1-6.fc5
xfce-mcs-manager-4.2.3-2.fc5
xfce-mcs-plugins-4.2.3-3.fc5
xfce-utils-4.2.3-4.fc5
xfdesktop-4.2.3-4.fc5
xffm-4.2.3-4.fc5
xffm-icons-4.0.6-2
xfig-3.2.4-17.3.fc5
xforms-1.0.90-6.fc5.2
xfprint-4.2.3-3.fc5
xfwm4-4.2.3.2-5.fc5
xfwm4-themes-4.2.3-2.fc5
# 

How reproducible:

Always.

Steps to Reproduce:
1. yum -y install xfce4-session
2. Login using XFCE4 session
  
Actual results:

The gtk/gnome error box pops up.

Expected results:

I'd expect to get logged into XFCE4!

Additional info:

"yum -y remove xfce4-session" solves the problem (I can then login to XFCE4 OK
(except that the "Quit" menu option doesn't work (see bug 198083)).
Comment 1 Kevin Fenzi 2006-07-10 12:33:11 EDT
Thanks for the bug report. 

Can you attach the contents of your
~/.config/xfce4-session/xfce4-session.rc file?

Comment 2 James Hunt 2006-07-10 13:47:06 EDT
Hmm. I don't appear to have one:

$ cat ~/.config/xfce4-session/xfce4-session.rc
cat: /home/james/.config/xfce4-session/xfce4-session.rc: No such file or directory
$ find .config/
.config/
.config/xfce4
.config/xfce4/mcs_settings
.config/xfce4/mcs_settings/panel.xml
.config/xfce4/mcs_settings/mouse.xml
.config/xfce4/mcs_settings/ls-iconbox.xml
.config/xfce4/mcs_settings/display.xml
.config/xfce4/mcs_settings/xfprint.xml
.config/xfce4/mcs_settings/keyboard.xml
.config/xfce4/mcs_settings/margins.xml
.config/xfce4/mcs_settings/gtk.xml
.config/xfce4/mcs_settings/xfwm4.xml
.config/xfce4/mcs_settings/taskbar.xml
.config/xfce4/mcs_settings/xfwm4_keys.xml
.config/xfce4/mcs_settings/workspaces.xml
$ 

I've tried logging out of xfce4 and back in again, but it doesn't appear to get
created.

However, I have got a system-wide one:

# ls -l /etc/xdg/xfce4-session/xfce4-session.rc
-rw-r--r-- 1 root root 1637 Feb 17 01:25 /etc/xdg/xfce4-session/xfce4-session.rc

... but it hasn't been changed:

# rpm -qV xfce4-session
# echo $?
# 0
Comment 3 Kevin Fenzi 2006-07-10 14:17:43 EDT
Can you attach a list of files under ~/.cache as well? In particular are 
there any ~/.cache/sessions/ files?

Also, do you have the gtk-qt-engine package installed? 
Comment 4 James Hunt 2006-07-10 15:27:22 EDT
Hi Kevin,

$ find .cache/
.cache/
.cache/sessions
.cache/xfce4
.cache/xfce4/desktop
.cache/xfce4/desktop/menu-cache--etc-xdg-xfce4-desktop-menu.xml.xml
.cache/xfce4/desktop/menu-cache--etc-xdg-xfce4-desktop-menu.xml.rc
$ rpm -q gtk-qt-engine
package gtk-qt-engine is not installed
$ 
Comment 5 Kevin Fenzi 2006-07-11 17:39:17 EDT
Very strange. The failsafe session should be the one it runs the first time you 
run xfce4-session, and it should create a .rc file for you on that first run. 

Can you try this: 

install the strace package. 'yum -y install strace'

Edit or create a ~/.Xclients file with: 

exec /usr/bin/strace -f -o /tmp/trace.out /usr/bin/startxfce4

This will generate a very large trace file in /tmp/trace.out. 
If you could put that up somewhere where I can download it, or if it's small 
enough to allow add it as an attachement here, that would be great. 

Somehow xfce4-session isn't finding your xfce4-session.rc file or one of the 
failsafe programs in it. 
Comment 6 James Hunt 2006-07-14 06:22:02 EDT
Created attachment 132423 [details]
gzip compressed output of "exec /usr/bin/strace -f -o /tmp/trace.out /usr/bin/startxfce4"

gzip compressed output of "exec /usr/bin/strace -f -o /tmp/trace.out
/usr/bin/startxfce4" attached.

Unfortunately, xfce4 never loaded when I ran it using strace. I got a blue
screen and a cursor, but nothing else.
Comment 7 Kevin Fenzi 2006-07-14 18:27:02 EDT
Excellent. Thanks for the trace. Still looking it over. 

One thing I see that would be good to know: 

Can you past in the output of 'ls -la ~/.ICE*'

I will look over the trace some more and see if I can find anything that points 
to the problem. 
Comment 8 Kevin Fenzi 2006-07-17 16:43:14 EDT
Thanks for getting me that trace. I see one thing that really stands out: 

4426  stat64("/etc/xdg/xfce4-session/xfce4-session.rc", 0xbfc034fc) = -1 EACCES 
(Permission denied)

That should be a file in the xfce4-session package. (Which you verified above 
was verified in the rpm database). 

Does this file exist?
Can you read it as your regular user? 
Are there incorrect permissions on /etc or /etc/xdg/ or /etc/xdg/xfce4-session?
Are you using selinux? 

I see one bug in the xfce4-session package here in that it doesn't appear to 
own the /etc/xdg/xfce4-session directory...
Comment 9 Kevin Fenzi 2006-07-25 17:30:37 EDT
Hey James: Any chance to answer the questions from comments #7 and #8 ?
That might track down the solution. Thanks.
Comment 10 Kevin Fenzi 2006-08-14 22:00:07 EDT
Hey James. You still seeing this issue? 
Any further news?
Comment 11 Kevin Fenzi 2006-09-25 16:02:04 EDT
Hey James. I haven't heard anything back from you on this bug in a while...
If I don't hear anything in the next few days, I will go ahead and close up 
this bug.
Comment 12 Kevin Fenzi 2006-09-27 13:17:58 EDT
ok. I am going to close this bug now. If you get a chance to provide the info 
above or can otherwise duplicate it, please feel free to re-open this bug, or 
create a new one and we can try and get things solved. 

Thanks. 

Note You need to log in before you can comment on or make changes to this bug.