Bug 198109 - initialcclist in owners.list not propagating to Bugzilla
Summary: initialcclist in owners.list not propagating to Bugzilla
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora Infrastructure
Classification: Retired
Component: cvs   
(Show other bugs)
Version: unspecified
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: Jeremy Katz
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-09 19:08 UTC by Ville Skyttä
Modified: 2007-09-01 20:29 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-01 20:29:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Possible fix (691 bytes, patch)
2006-12-17 17:59 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2006-07-09 19:08:17 UTC
Several people have reported on the Extras list that updating the initialcclist
field in owners.list does not propagate to Bugzilla.  I've not used that feature
for a while but have placed a call on the Extras list for those who have to fill
in the specifics here.

Comment 1 Hans de Goede 2006-07-09 20:10:42 UTC
For me it didn't work when bug 196616 got filed, I co maintain this with
Jindrich Novy and I'm in the initial-CC field of allegro (and have been for a
long time). So when this new bug got opened I would have exected to be put in
the CC-list which didn't happen.


Comment 2 Peter Gordon 2006-07-09 20:13:54 UTC
Same here. I was on the initalcclist in owners.list for glabels (which I've
since taken primary maintainership of in Extras); but at the time that bug
#197633 was filed, the reported had to add me to the CC: list as Bugzilla
wouldn't do it automatically as it should have.

Comment 3 Jeremy Katz 2006-07-11 01:30:53 UTC
dkl -- I'm not sure how the magic for this happens.  If I should point somewhere
else, just let me know where.

Comment 4 David Lawrence 2006-07-11 02:00:54 UTC
This is something that Elliot should look at. I do not handle that side of things.

Comment 5 Warren Togami 2006-08-24 19:17:58 UTC
Has initialcc from owners.list to Bugzilla ever worked before?

Comment 6 Ville Skyttä 2006-08-24 21:43:16 UTC
I suppose it has, at least upstream is auto-Cc'd on FE pcsc-lite bugs and I
believe fedora-perl-devel on the vast majority of FE perl-* packages, and there
are plenty of other examples around.  Hopefully no poor soul has been tortured
with the task of manually entering those to Bugzilla.

Comment 7 Ville Skyttä 2006-11-11 10:39:05 UTC
Any progress here?  I think this is pretty much a showstopper for package
co-maintainership in Extras.

Comment 8 Thorsten Leemhuis 2006-11-11 12:29:06 UTC
(In reply to comment #7 from scop)
> Any progress here?  

Lost track on this one. Sorry.

(In reply to comment #4)
> This is something that Elliot should look at. 

Has he time, interest and access to the machines to fix this shit these days? I
don't think so. Warren, Jeremy, how do we get this solved? It's lingering around
far to long (I in fact thought this was fixed in between as I heard no complains
for quite some time)

Comment 9 Ville Skyttä 2006-12-17 17:59:07 UTC
Created attachment 143872 [details]
Possible fix

For the record, here's a potential (untested) fix sent to Warren and Jeremy in
PM last Thursday: off-by-one error, resulting in the script trying to use
initialqacontact from owners.list to populate initialcclist.

Comment 10 Jeremy Katz 2006-12-19 18:49:00 UTC
Ville's fix looks good; I've committed it and put it on the running copy so the
next run of the script should pick it up

Comment 11 Ville Skyttä 2007-09-01 20:29:18 UTC
I think this was fixed and we're using the pkgdb now anyway, so closing.


Note You need to log in before you can comment on or make changes to this bug.