Bug 198208 - Benq X805 wireless mouse behaves erratically.
Benq X805 wireless mouse behaves erratically.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-10 10:25 EDT by Philippe A
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 19:22:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe A 2006-07-10 10:25:04 EDT
Description of problem:

The Benq X805 mouse cursor frequently starts jumping wildly around the screen
and registering mouse clicks events, causing a big mess on the desktop.

Version-Release number of selected component (if applicable):


How reproducible:

Very frequently and recurrent, though not precisely predictable. 

Steps to Reproduce:

1.Plug the wireless receptor, register the keyboard and mouse with it, review
your configs, etc.
2.Reboot and login on your desktop. 
3.Work normally and see the problem occur unexpectedly.

Actual results:

The cursor will start jumping around unexpectedly and cause a mess on the
desktop. The mouse works normally maybe 60-70% of the time. 

It reminds the behavior with the Microsoft wheel mice back in RH9 days, except
the MS mice didn't work at all.

Expected results:

I would tolerate occasional small jumps here and there (I do experience some
with optical usb mouse on WinXP), but the cursor should never warp from one side
of the screen to the other nor register clicks if I don't click.

Additional info:

Reproduced in a text console, kde, gdm and even in an independant display (xinit
-- :1).

Tried various boot options. None helped.
acpi=off
psmouse.proto=bare|imps|exp (tried all)

Tried various X protocols. None helped. Not a big surprise since the problem
seems independant of X.
PS/2, IMPS/2, ExplorerPS/2, auto (mouse detected as explorerps/2)

Tried using the wireless mouse in combination with my previous usb keyboard.
Problem occured anyway.

The mouse and keyboard worked together flawlessly on a Win2000 system. 

CPU usage jumps to 100% when problem occurs. I have to wait for the CPU slow
down before I move the cursor again, else it will continue its masquerade.

Both the mouse and keyboard cables of the receptor are PS/2.
Comment 1 Philippe A 2006-07-26 19:15:52 EDT
The Benq x805 receptor cable is split in two: one side is PS/2 and the other
USB. You can either plug both in PS/2 ports (using an USB->PS/2 converter), or
use the USB connector only. I have found the problem does not happen when using
the USB connector. 
Comment 2 Dave Jones 2006-09-16 21:56:38 EDT
[This comment added as part of a mass-update to all open FC4 kernel bugs]

FC4 has now transitioned to the Fedora legacy project, which will continue to
release security related updates for the kernel.  As this bug is not security
related, it is unlikely to be fixed in an update for FC4, and has been migrated
to FC5.

Please retest with Fedora Core 5.

Thank you.
Comment 3 Dave Jones 2006-10-16 16:48:02 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 4 Philippe A 2006-10-31 20:54:26 EST
I have upgraded to Fedora Core 6 since I have reported this bug. I am no longer
capable of reproducing that problem.
Comment 5 Philippe A 2006-11-01 21:18:49 EST
I have close this bug by accident. Sorry for reopening it. I did upgrade to FC6
and I'm currently running 2.6.18-1.2798.fc6. My Benq wireless mouse still has a
wacky behavior when connected on the PS/2 port. It works like a charm when
connected on the USB port.
Comment 6 Jon Stanley 2007-12-30 20:15:21 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!
Comment 7 Philippe A 2008-01-08 19:22:30 EST
I have completely lost track of this problem since my mouse has been working
flawlessly for a while now. I can't even remember if the problem disappeared
during a kernel upgrade in FC6, or if it disappeared in FC7, but that certainly
got fixed before I upgraded to FC8.

Best regards!

Note You need to log in before you can comment on or make changes to this bug.