Bug 198236 - ldd -r reports undefined symbols
Summary: ldd -r reports undefined symbols
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: poppler   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Keywords:
: 202326 (view as bug list)
Depends On:
Blocks: ldd-r-kh
TreeView+ depends on / blocked
 
Reported: 2006-07-10 15:18 UTC by Karsten Hopp
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 18:16:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karsten Hopp 2006-07-10 15:18:34 UTC
Note: ldd can't handle dlopen'ed dependent libraries and these unresolved symbols
might be resolved by those. But this needs to be checked.
Reproducer: rpm -ql <packagename>| grep lib.*so | xargs ldd -r


poppler-0.5.3-1
undefined symbol: FcConfigGetCurrent    (/usr/lib/libpoppler.so)
undefined symbol: FcPatternGetString    (/usr/lib/libpoppler.so)
undefined symbol: FcInit        (/usr/lib/libpoppler.so)
undefined symbol: FcPatternGetInteger   (/usr/lib/libpoppler.so)
undefined symbol: FcFontSort    (/usr/lib/libpoppler.so)
undefined symbol: FcConfigSubstitute    (/usr/lib/libpoppler.so)
undefined symbol: FcPatternDestroy      (/usr/lib/libpoppler.so)
undefined symbol: FcPatternBuild        (/usr/lib/libpoppler.so)
undefined symbol: FcFontSetDestroy      (/usr/lib/libpoppler.so)
undefined symbol: FcDefaultSubstitute   (/usr/lib/libpoppler.so)

Comment 1 Kristian Høgsberg 2006-09-13 21:34:21 UTC
*** Bug 202326 has been marked as a duplicate of this bug. ***

Comment 2 Kristian Høgsberg 2006-09-22 18:16:48 UTC
Fixed in 0.5.4-1.fc6.


Note You need to log in before you can comment on or make changes to this bug.