Bug 202326 - poppler libraries cause "undefined symbol" complaints
poppler libraries cause "undefined symbol" complaints
Status: CLOSED DUPLICATE of bug 198236
Product: Fedora
Classification: Fedora
Component: poppler (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-12 17:23 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-13 17:34:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-08-12 17:23:35 EDT
Description of problem:

Running 'ldd -r -d libpoppler.so.1.0.0' uncoverss ten undefined symbols:
FcConfigGetCurrent
FcPatternGetString
FcInit
FcPatternGetInteger
FcFontSort
FcConfigSubstitute
FcPatternDestroy
FcPatternBuild
FcFontSetDestroy
FcDefaultSubstitute

These are provided by libfontconfig which apparently is not linked.
Quoting
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=202256#c1
"The libraries work, but less efficiently than they could if they
were linked properly".

Version-Release number of selected component (if applicable):
poppler-0.5.3-1.1
Comment 1 Michal Jaegermann 2006-08-22 15:45:22 EDT
Changelog for poppler package says:

* Mon Aug 14 2006 Matthias Clasen <mclasen@redhat.com> - 0.5.3-2.fc6
- link against fontconfig (see bug 202256)

but 'ldd -d -r /usr/lib64/libpoppler.so.1.0.0' shows the same 
undefined symbols from fontconfig as before.  Do I miss something here?
Comment 2 Matthias Clasen 2006-08-22 22:31:56 EDT
It certainly fixed the issue on i386.

Does your ldd output include a line for libfontconfig.so ?
Comment 3 Michal Jaegermann 2006-08-23 12:13:37 EDT
> Does your ldd output include a line for libfontconfig.so ?

No, it does not.  I would not expect to see "undefined symbol"
messages if that would be the case.

Here is a full output which I am seeing here with
poppler-0.5.3-2.fc6 and fontconfig-2.3.95-11.fc6:

# ldd -d -r /usr/lib64/libpoppler.so.1.0.0
undefined symbol: FcPatternDestroy      (/usr/lib64/libpoppler.so.1.0.0)
undefined symbol: FcConfigGetCurrent    (/usr/lib64/libpoppler.so.1.0.0)
undefined symbol: FcPatternGetString    (/usr/lib64/libpoppler.so.1.0.0)
undefined symbol: FcFontSetDestroy      (/usr/lib64/libpoppler.so.1.0.0)
undefined symbol: FcPatternGetInteger   (/usr/lib64/libpoppler.so.1.0.0)
undefined symbol: FcFontSort    (/usr/lib64/libpoppler.so.1.0.0)
undefined symbol: FcConfigSubstitute    (/usr/lib64/libpoppler.so.1.0.0)
undefined symbol: FcDefaultSubstitute   (/usr/lib64/libpoppler.so.1.0.0)
undefined symbol: FcPatternBuild        (/usr/lib64/libpoppler.so.1.0.0)
undefined symbol: FcInit        (/usr/lib64/libpoppler.so.1.0.0)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00000039c7600000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00000039cd000000)
        libm.so.6 => /lib64/libm.so.6 (0x00000039c3e00000)
        libc.so.6 => /lib64/libc.so.6 (0x00000039c3a00000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00000039cc400000)
        /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)
Comment 4 Kristian Høgsberg 2006-09-13 17:34:07 EDT

*** This bug has been marked as a duplicate of 198236 ***

Note You need to log in before you can comment on or make changes to this bug.