Bug 198334 - Error in squirrelmail making it unusable.
Error in squirrelmail making it unusable.
Status: CLOSED DUPLICATE of bug 198306
Product: Fedora
Classification: Fedora
Component: squirrelmail (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-11 02:59 EDT by Steven Haigh
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-11 12:00:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Haigh 2006-07-11 02:59:32 EDT
Description of problem:
Since installing 1.4.7-2.fc6 via a 'yum update' using the devel repo,
squirrelmail is broken. It logs in ok, however every page (including the initial
frame set) comes up with the following:
$default_folder_prefix		= '';

This breaks the initial frameset and renders it unusable.

# rpm -qa | grep squirrel
squirrelmail-1.4.7-2.fc6
Comment 1 Chris Chabot 2006-07-11 03:17:00 EDT
Guys try looking in:
  /etc/squirrelmail/config_local.php

It has:
<?php                                                                          
                         
                                                                               
                         
/**                                                                            
                         
 * Local config overrides.                                                     
                         
 *                                                                             
                         
 * You can override the config.php settings here.                              
                         
 * Don't do it unless you know what you're doing.                              
                         
 * Use standard PHP syntax, see config.php for examples.                       
                         
 *                                                                             
                         
 * @copyright &copy; 2002-2006 The SquirrelMail Project Team                   
                         
 * @license http://opensource.org/licenses/gpl-license.php GNU Public License  
                         
 * @version $Id: config_local.php,v 1.2.2.3 2006/04/14 22:27:07 jervfors Exp $ 
                         
 * @package squirrelmail                                                       
                         
 * @subpackage config                                                          
                         
 */                                                                            
                         
                                                                               
                         
?>                                                                             
                         
$default_folder_prefix          = '';

Which should read:

<?php                                                                          
                         
                                                                               
                         
/**                                                                            
                         
 * Local config overrides.                                                     
                         
 *                                                                             
                         
 * You can override the config.php settings here.                              
                         
 * Don't do it unless you know what you're doing.                              
                         
 * Use standard PHP syntax, see config.php for examples.                       
                         
 *                                                                             
                         
 * @copyright &copy; 2002-2006 The SquirrelMail Project Team                   
                         
 * @license http://opensource.org/licenses/gpl-license.php GNU Public License  
                         
 * @version $Id: config_local.php,v 1.2.2.3 2006/04/14 22:27:07 jervfors Exp $ 
                         
 * @package squirrelmail                                                       
                         
 * @subpackage config                                                          
                         
 */                                                                            
                         
                                                                               
                        
                                                                               
                     $default_folder_prefix          = '';
?>  

* notice the end-php-tag (aka ?>) before the php code in the current file, it
should be after the $default_folder_prefix stuff obviously :-)
Comment 2 Steven Haigh 2006-07-11 03:23:51 EDT
Ahhh this makes sense. I looked at that file too - but it didn't click about the
?> being in the wrong spot :) I can confirm this fixes the issue, however it
should be fixed in the RPM and repo as well.
Comment 3 Aleksander Adamowski 2006-07-11 11:13:43 EDT
I can confirm this on Fedora Core 4. The official updates
(squirrelmail-1.4.7-2.fc4) introduced this breakage.

Strange that this bug got past QA. It renders the Squirrelmail installation
instantly unusable.

Putting the "$default_folder_prefix" line into place fixes the problem.

Comment 4 Warren Togami 2006-07-11 12:00:19 EDT

*** This bug has been marked as a duplicate of 198306 ***

Note You need to log in before you can comment on or make changes to this bug.