Bug 198306 - squirrelmail - typo in a config file creates problems
squirrelmail - typo in a config file creates problems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: squirrelmail (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
: 198334 198340 198521 198559 198792 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-10 19:26 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version: squirrelmail-1.4.7-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-11 11:59:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-07-10 19:26:00 EDT
Description of problem:

An update to 1.4.7-2 brings a new file /etc/squirrelmail/config_local.php
Only that file looks like follows:

<?php
.....
?>
$default_folder_prefix          = '';

Logging to squirrelmail with such configuration immediately produces:

Warning: session_start(): Cannot send session cache limiter - headers already
sent (output started at /etc/squirrelmail/config_local.php:19) in
/usr/share/squirrelmail/functions/global.php on line 374

Warning: Cannot modify header information - headers already sent by (output
started at /etc/squirrelmail/config_local.php:19) in
/usr/share/squirrelmail/functions/i18n.php on line 335

Warning: Cannot modify header information - headers already sent by (output
started at /etc/squirrelmail/config_local.php:19) in
/usr/share/squirrelmail/functions/global.php on line 346

Warning: Cannot modify header information - headers already sent by (output
started at /etc/squirrelmail/config_local.php:19) in
/usr/share/squirrelmail/src/login.php on line 53

and much more of the same if you will try to continue, making the whole
thing really unusable.

With a configuration which is not sending warning to a screen
this is a bit better but not much.  "$default_folder_prefix = '';"
gets printed on a screen and this is enough to kill a mail display.

Switching the last two lines in /etc/squirrelmail/config_local.php
fixes that immediately.

Users can obviously edit that file, if they figure out what is
going on, and this is config so  maybe even it will not clobbered
on subsequent updates.  OTOH if this file ends gets included this
makes web server quite unhappy.

Version-Release number of selected component (if applicable):
squirrelmail-1.4.7-2.fc5.noarch.rpm
Comment 1 Jon Ciesla 2006-07-11 08:02:23 EDT
Downgrading to 1.4.6-7.fc5 is currently the fastest fix.
Comment 2 Michal Jaegermann 2006-07-11 10:29:23 EDT
> Downgrading to 1.4.6-7.fc5 is currently the fastest fix.

Don't overdo it. :-)  Changing an order of two lines in
/etc/squirrelmail/config_local.php is surely faster; especially
when you were told which two lines.
Comment 3 Warren Togami 2006-07-11 11:59:24 EDT
squirrelmail-1.4.7-4* has been pushed to updates solving this issue.  The
trouble with this is that my testing didn't show any problem because my
config_local.php was modified, and %config(noreplace) hid the problem. 
Meanwhile I wanted to get the security update out.

I screwed up and take responsibility for this mistake.
Comment 4 Warren Togami 2006-07-11 12:00:11 EDT
*** Bug 198340 has been marked as a duplicate of this bug. ***
Comment 5 Warren Togami 2006-07-11 12:00:22 EDT
*** Bug 198334 has been marked as a duplicate of this bug. ***
Comment 6 James Wilson 2006-07-11 19:17:04 EDT
*** Bug 198521 has been marked as a duplicate of this bug. ***
Comment 7 Warren Togami 2006-07-11 22:15:47 EDT
*** Bug 198559 has been marked as a duplicate of this bug. ***
Comment 8 Warren Togami 2006-07-13 12:25:24 EDT
*** Bug 198792 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.