Bug 198377 - Package hplip lacks IPv6 support
Package hplip lacks IPv6 support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 212385 (view as bug list)
Depends On:
Blocks: IPv6Blocker FC6Update 212948
  Show dependency treegraph
 
Reported: 2006-07-11 06:20 EDT by Peter Vrabec
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.6.10-1.fc6.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 05:10:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2006-07-11 06:20:26 EDT
This bug was reported automaticaly in connection with IPv6 project.
Our aim is to support IPv6 in all Fedora Core packages so FC6 and RHEL5 will be ready for IPv6.
			
This package seems to lack IPv6 support as is illustrated in attached log.
	
Here follows part of scanning log (grep -r F_INET *)/up to 30 lines:
Comment 1 Kevin Kofler 2006-10-29 04:04:53 EST
Unfortunately, this also means that HPLIP doesn't work with the 
default /etc/hosts file generated by the FC6 Anaconda (hpssd can't connect 
to ::1, thus connecting to hpiod on localhost fails). This breaks everything 
requiring HPLIP's features beyond HPIJS (scanning on OfficeJets, hp-toolbox 
etc.). If completely fixing HPLIP for IPv6 is going to take some time, at the 
very least some hack to resolve localhost to 127.0.0.1 instead of ::1 is 
needed. (If I change /etc/hosts to use 127.0.0.1 as the IP for localhost, it 
works again.)
Comment 2 Tim Waugh 2006-10-30 06:25:56 EST
*** Bug 212385 has been marked as a duplicate of this bug. ***
Comment 3 Tim Waugh 2006-10-31 06:26:26 EST
Please try this test update:

  https://www.redhat.com/archives/fedora-test-list/2006-October/msg01025.html

You should be able to do this using:

  yum --enablerepo=updates-testing update hpijs hplip libsane-hpaio
Comment 4 Kevin Kofler 2006-10-31 13:52:12 EST
This fixes it.
Comment 5 Fedora Update System 2006-11-01 14:27:13 EST
Errata pushed: hplip-1.6.10-1.fc6.4

Note You need to log in before you can comment on or make changes to this bug.