Bug 212385 - HP PSC 1410 - Unable to connect to HPLIP
HP PSC 1410 - Unable to connect to HPLIP
Status: CLOSED DUPLICATE of bug 198377
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-10-26 12:21 EDT by Adrian Malina
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 06:25:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Malina 2006-10-26 12:21:13 EDT
I have a HP PSC1410 printer(scanner + printer in one). I have configured my
printer with system-config printer and printing work fine, but i can't use
scanner and additional driver tool (eg. hp-toolbox). I think that my problem is
associated with hplip package because HP driver tool can't connect with hplip
daemon :-( In FC5 and rawhide (FC6T3) all was ok.

Ok, now some facts:

Turn on the printer.
# dmesg
[...]
ohci_hcd 0000:00:02.0: wakeup
usb 1-1: new full speed USB device using ohci_hcd and address 7
usb 1-1: configuration #1 chosen from 1 choice
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 7 if 1 alt 0
proto 2 vid 0x03F0 pid 0x4D11
audit(1161807323.597:21): avc:  denied  { connectto } for  pid=4795
comm="python" name="cups.sock" scontext=system_u:system_r:cupsd_config_t:s0
tcontext=system_u:system_r:initrc_t:s0-s0:c0.c1023 tclass=unix_stream_socket
[...]

#rpm -qa |grep hp
libsane-hpaio-1.6.7-4
hplip-1.6.7-4
hpijs-1.6.7-4

# service hplip start
Uruchamianie hpiod:                                        [  OK  ]
Uruchamianie hpssd:                                        [  OK  ]


# service hplip status
hpiod (pid 2159) jest uruchomiony...
hpssd (pid 2164) jest uruchomiony...

# dmesg
[...]
audit(1161808149.997:22): avc:  denied  { write } for  pid=4909 comm="hpiod"
name="hpiod.port" dev=hda9 ino=1377547 scontext=user_u:system_r:hplip_t:s0
tcontext=system_u:object_r:initrc_var_run_t:s0 tclass=file
audit(1161808150.161:23): avc:  denied  { read } for  pid=4912 comm="python"
name="hpiod.port" dev=hda9 ino=1377547 scontext=user_u:system_r:hplip_t:s0
tcontext=system_u:object_r:initrc_var_run_t:s0 tclass=file
[...]

# sane-find-scanner
[...]
found USB scanner (vendor=0x03f0 [HP], product=0x4d11 [PSC 1400 series]) at
libusb:001:007
[...]

# scaneimage -L
[...]
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[...]

# hp-setup
HP Linux Imaging and Printing System (ver. 1.6.7)
Printer/Fax Setup Utility ver. 2.1

Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: Unable to connect to hpiod.

# hp-toolbox
HP Linux Imaging and Printing System (ver. 1.6.7)
HP Device Manager ver. 6.2

Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: Unable to connect to HPLIP I/O. Check and make sure HPLIP is running.
error: Unable to create client object.

 # tail -f /var/log/cups/error_log
I [25/Oct/2006:21:47:27 +0200] Allowing up to 100 client connections per host.
I [25/Oct/2006:21:47:27 +0200] Using policy "default" as the default!
I [25/Oct/2006:21:47:27 +0200] Full reload is required.
I [25/Oct/2006:21:47:27 +0200] Loaded MIME database from '/etc/cups': 34 types,
38 filters...
I [25/Oct/2006:21:47:28 +0200] Loading job cache file "/var/cache/cups/job.cache"...
I [25/Oct/2006:21:47:28 +0200] Full reload complete.
I [25/Oct/2006:21:47:28 +0200] Listening to ::1:631 on fd 3...
I [25/Oct/2006:21:47:28 +0200] Listening to /var/run/cups/cups.sock on fd 4...
I [25/Oct/2006:21:48:18 +0200] cupsdAcceptClient: skipping getpeercon()
I [25/Oct/2006:21:48:18 +0200] cupsdAcceptClient: skipping getpeercon()

HP tools doesn't see HPLIP daemon although hplip is enable.

Sorry for my English. It isn't my primary language, but I think that you
understand me ;-)
Comment 1 Tim Waugh 2006-10-26 12:35:45 EDT
I don't see this on a fresh install.  Seems like the labels on /var/run/hp* are
incorrect.  Please run this command as root:

  restorecon -v /var/run/hp*

Was this a fresh install or an upgrade?
Comment 2 Adrian Malina 2006-10-26 13:32:15 EDT
This is a fresh system installation(24 oct 2006) on formatted partition, not
upgrade from previous FC.

If i disabe SELinux problem still exist.
Comment 3 Tim Waugh 2006-10-27 12:33:20 EDT
May well be the same cause as bug #211072.
Comment 4 Adrian Malina 2006-10-28 14:47:40 EDT
It hasn't solved problem ...
Comment 5 Tim Waugh 2006-10-29 03:49:47 EST
With the updates-testing package?  Please try this:

service hplip stop
rm -f /var/run/hp*.port
service hplip start

Does it work now?  What does 'cat /var/run/hp*.port' say?
Comment 6 Adrian Malina 2006-10-29 08:03:48 EST
Yes, I'm using updates-testing packages.

#  rpm -qa | grep hp
hplip-1.6.10-1.fc6.1
libsane-hpaio-1.6.10-1.fc6.1
hpijs-1.6.10-1.fc6.1

# cat /var/run/hp*.port
2208
2207

My friend Dawid Gajownik tell me that this problem can be connected with /etc/hosts.

 # rm /etc/hosts
rm: usunąć zwykły plik `/etc/hosts'? y

 # setup (network configuration...)

 # cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
::1     localhost.localdomain   localhost

If I add new line "127.0.0.1 localhost.localdomain localhost" all is ok ;-)

 # cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
::1        localhost.localdomain        localhost
127.0.0.1  localhost.localdomain        localhost

 # hp-setup

HP Linux Imaging and Printing System (ver. 1.6.10)
Printer/Fax Setup Utility ver. 3.1

Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

0
Done.

 # scanimage -L
device `hpaio:/usb/PSC_1400_series?serial=MY55V2C1D404BM' is a hp
PSC_1400_series multi-function peripheral

What is more HPLIP shutdown clearly. 

 # service hplip restart
Zatrzymywanie hpiod:                                       [  OK  ]
Zatrzymywanie hpssd:                                       [  OK  ]
Uruchamianie hpiod:                                        [  OK  ]
Uruchamianie hpssd:                                        [  OK  ]

I think this is a solution for bug 211072.

Comment 7 Tim Waugh 2006-10-30 06:25:54 EST

*** This bug has been marked as a duplicate of 198377 ***

Note You need to log in before you can comment on or make changes to this bug.