Bug 198521 - Squirrelmail 1.4.7-2.fc4 update supplies broken config_local.php
Squirrelmail 1.4.7-2.fc4 update supplies broken config_local.php
Status: CLOSED DUPLICATE of bug 198306
Product: Fedora
Classification: Fedora
Component: squirrelmail (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-11 12:24 EDT by James Wilson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-11 19:17:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Wilson 2006-07-11 12:24:02 EDT
Description of problem:

Upon installing the update Squirrelmail 1.4.7-2.fc4,
"/etc/squirrelmail/config_local.php" is created.  The php tags are incorrectly
set resulting in "$default_folder_prefix = ''; being displayed on the login
page.  After trying to login, a blank page is rendered with only
"$default_folder_prefix = '';" being displayed.

The closing php tag  "?>" is outside of the default_folder_prefix configuration
variable.  See below:

<?php

/**
 * Local config overrides.
 *
 * You can override the config.php settings here.
 * Don't do it unless you know what you're doing.
 * Use standard PHP syntax, see config.php for examples.
 *
 * @copyright &copy; 2002-2006 The SquirrelMail Project Team
 * @license http://opensource.org/licenses/gpl-license.php GNU Public License
 * @version $Id: config_local.php,v 1.2.2.3 2006/04/14 22:27:07 jervfors Exp $
 * @package squirrelmail
 * @subpackage config
 */

?>
$default_folder_prefix          = '';

Version-Release number of selected component (if applicable):

Squirrelmail 1.4.7-2.fc4

How reproducible:

Install above package and go to the Squirrelmail URL for your installation in a
browser.

Steps to Reproduce:
1. Install Squirrelmail 1.4.7-2.fc4
2. Goto http://yourdomain.com/webmail/
3.
  
Actual results:

$default_folder_prefix = ''; is displayed above the Webmail logo on the login
screen.  After authenticationg you are presented with a blank page containing
just the phrase "$default_folder_prefix = '';" 

Expected results:

Configuration variables are not displayed on the page - and logging in presents
with the users inbox.

Additional info:
Comment 1 James Wilson 2006-07-11 12:25:15 EDT
I forgot to mention; even if $default_folder_prefix = ''; is inside the tag,
this needlesly overrides the user's correct settings.
Comment 2 Warren Togami 2006-07-11 14:02:54 EDT
$default_folder_prefix = '';

This is the default for Fedora with dovecot.  You may change it to match your
specific deployment.  NOTABUG.
Comment 3 James Wilson 2006-07-11 16:10:10 EDT
This isn't the problem!  The defaylt installation file is broken.  The variable
is declared outside of the PHP tag.  A default install of Squirrelmail
1.4.7-2.fc4 will result in a broken config.  You cannot login!
Comment 4 James Wilson 2006-07-11 19:17:01 EDT

*** This bug has been marked as a duplicate of 198306 ***

Note You need to log in before you can comment on or make changes to this bug.