Bug 198721 - cursoring on the left during input with scim-bridge, on the right with scim
cursoring on the left during input with scim-bridge, on the right with scim
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-hangul (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Akira TAGOH
: i18n
Depends On:
Blocks: SCIM
  Show dependency treegraph
 
Reported: 2006-07-13 00:53 EDT by Lawrence Lim
Modified: 2014-03-25 20:53 EDT (History)
6 users (show)

See Also:
Fixed In Version: scim-hangul-0.2.2-7.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 10:38:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cursor position with GTK_IM_MODULE=scim (83.79 KB, image/png)
2006-07-14 01:16 EDT, Lawrence Lim
no flags Details
cursor position with GTK_IM_MODULE=scim-bridge (82.75 KB, image/png)
2006-07-14 01:17 EDT, Lawrence Lim
no flags Details

  None (edit)
Description Lawrence Lim 2006-07-13 00:53:05 EDT
Description of problem:
Was wondering if the blinking cursor should be on the right hand side of the
pre-edit buffer during input in oowriter. At the moment, its on the left, looks
a bit strange. On gedit, there's no blinking cursor.

Version-Release number of selected component (if applicable):
scim-hangul-0.2.2-5.fc6

How reproducible:
Always

Steps to Reproduce:
1.start oowriter and activate scim
2.choose hangul and start input
3.
  
Actual results:
blinking cursor on the left of pre-edit buffer

Expected results:
should be on the right or no blink?

Additional info:
Comment 1 Akira TAGOH 2006-07-13 01:19:13 EDT
Not really - There are no APIs to manage the application cursor. probably I
should reassign this to OOo because preedit handling on the application really
depends on that application. FWIW you can see a similar behavior with scim-anthy
on during the conversion, though.
Comment 2 Caolan McNamara 2006-07-13 05:47:53 EDT
If I activate scim, choose hangul and then

in writer press q I get a hangul symbol, highlighted in blue and a black cursor
blinking to the right of the symbol

in gedit press q I get a hangul symbol, highlighted in black and a black cursor
blinking to the right of the symbol

So both seem to behave the same for me except for the highlighting colour, which
in gtk is the same as the cursor colour making it not so obvious.

Perhaps there's a required locale setting ?
Comment 3 Akira TAGOH 2006-07-13 23:40:47 EDT
same behavior for me. this may be not a bug. Lawrence?
Comment 4 Lawrence Lim 2006-07-14 01:14:49 EDT
RE: Comment #1:
Tagoh-san, yes you are right, the cursoring has similair behaviour to Anthy when
the conversion is on. However, I find something very interesting today.

The blinking cursor is determine by the GTK_IM_MODULE, ie. the behaviour differs
between scim and scim-bridge. What was reported was default scim-bridge. Hence,
I think it shuold be assign to scim-bridge for further investigation?

Please see screenshot.
Comment 5 Lawrence Lim 2006-07-14 01:16:21 EDT
Created attachment 132407 [details]
cursor position with GTK_IM_MODULE=scim

GTK_IM_MODULE=scim oowriter
Comment 6 Lawrence Lim 2006-07-14 01:17:26 EDT
Created attachment 132408 [details]
cursor position with GTK_IM_MODULE=scim-bridge

GTK_IM_MODULE=scim-bridge oowriter
Comment 7 Caolan McNamara 2006-07-14 04:43:50 EDT
Ok, if I change the font color of gedit to be 0xFF0000 (bright red), and repeat
the above tests under scim-bridge I find that oowriter and gedit also both
behave the same under scim-bridge, it's just harder to see the cursor in gedit
with the default colours. So we're consistent here in oowriter with the rest of
the the gtk apps in relation to cursor positioning, both on the left with
scim-bridge, and both on the right with scim.

I presume that this is a "scim-bridge-gtkimm" issue.
Comment 8 Ryo Dairiki 2006-07-14 07:46:04 EDT
I've been fixed this issue, but I cannot login cvs server for some reason.
I'll notice you as soon as I upload it.
Comment 9 Ryo Dairiki 2006-07-15 02:19:32 EDT
Fixed on the CVS latest.
Comment 10 Ryo Dairiki 2006-07-20 21:58:14 EDT
I've found this causes an annoying cursor movements for Japanese. :(
To fix both problems, we need to apply patches on scim, scim-gtkimm, and scim-hangl.
(Don't worry, all of the patches are already written)

now I'm discussing at scim-dev-list if it's correct way to fix this problem.
Comment 11 Jens Petersen 2006-07-26 02:05:47 EDT
Fixed in current scim-bridge according to my testing.
Comment 12 Jens Petersen 2006-07-26 07:33:40 EDT
Sorry I take back the last comment - seems as Dairiki-san also said
in comment 10 this is not changed yet.  However this only seems to
affect scim-hangul and I don't see that the new behaviour is really
worse than the old one.
Comment 14 Jens Petersen 2006-08-28 04:59:33 EDT
Actually Krisna applied the following patch for this to scim-hangul in cvs,
probably worth testing.


* update preedit caret when updating preedit string

Index: scim_hangul_imengine.cpp
===================================================================
RCS file: /cvsroot/scim/scim-hangul/src/scim_hangul_imengine.cpp,v
retrieving revision 1.10
retrieving revision 1.11
diff -C2 -d -r1.10 -r1.11
*** scim_hangul_imengine.cpp	24 Jul 2006 13:42:15 -0000	1.10
--- scim_hangul_imengine.cpp	24 Jul 2006 15:03:57 -0000	1.11
***************
*** 638,641 ****
--- 638,642 ----
          show_preedit_string ();
          update_preedit_string (wstr, attrs);
+         update_preedit_caret (wstr.length());
      } else {
          hide_preedit_string ();


Comment 15 Jens Petersen 2006-08-29 04:51:29 EDT
Above patch does not seem to fix the problem for me with scim-bridge-0.4.1.

Dairiki-san, is some patch also needed on scim itself (other than scim-gtkimm)?
Comment 16 Ryo Dairiki 2006-08-29 06:23:34 EDT
Sounds strange.
I'm now using the same patch on scim-hangul-0.2.2, with scim-bridge-0.4.2-rc1.
It works fine; The cursor always shows on the right of the preedit string.
I've rollback on 0.4.1 but nothing changed.

Did you really patch on it?
Please confirm that again.
Comment 17 Jens Petersen 2006-08-29 06:37:03 EDT
Hmm, sorry after rebooting my test machine it works for me too.  Strange.

Thanks for the patch. :)
Comment 18 Akira TAGOH 2006-08-29 08:33:39 EDT
Ok, should be fixed in 0.2.2-7.fc6.
Comment 19 Satyabrata Maitra 2006-08-31 10:38:35 EDT
this problem is now fixed.

Component Version tested :

scim-hangul-0.2.2-7.fc6
scim-1.4.4-32.fc6

Arch : i386 - rawhide

Note You need to log in before you can comment on or make changes to this bug.