Bug 1987295 - Setting host to 'maintenance' will be blocked when there are image transfers with status different then 'paused'
Summary: Setting host to 'maintenance' will be blocked when there are image transfers ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.4.7
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: ovirt-4.4.8
: ---
Assignee: Eyal Shenitzky
QA Contact: Amit Sharir
URL:
Whiteboard:
: 1989718 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-07-29 12:51 UTC by Eyal Shenitzky
Modified: 2021-09-30 07:00 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: A host will not be able to set to maintenance if there are image finished transfers (finished/failed status). Fix: A host can now be set to maintenance if the image transfers ended.
Clone Of:
Environment:
Last Closed: 2021-08-19 06:23:08 UTC
oVirt Team: Storage
pm-rhel: ovirt-4.4+
pm-rhel: blocker?


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 115840 0 master MERGED core: allow set host to maintenance if image transfer is not active 2021-08-05 08:58:25 UTC

Description Eyal Shenitzky 2021-07-29 12:51:55 UTC
Description of problem:

When trying to set a host to maintenance and the system contains image transfer entities that weren't clear yet, it fails even if the image transfer is already done (successfully or with failure).


The host managed to set to maintenance when the image transfer cleared from the DB.

Version-Release number of selected component (if applicable):
4.4.7

How reproducible:
100%

Steps to Reproduce:
1. Create a VM with a disk
2. Start a full backup for the VM and download the disk
3. After backup ended and the disk is downloaded, try to set the host that was used for the transfer to maintenance.

Actual results:
Setting host to maintenance is not allowed.

Expected results:
The host should be able to set to maintenance if all transfers are done or idle.

Additional info:

Comment 1 Avihai 2021-08-01 08:51:43 UTC
(In reply to Eyal Shenitzky from comment #0)
> Description of problem:
> 
> When trying to set a host to maintenance and the system contains image
> transfer entities that weren't clear yet, it fails even if the image
> transfer is already done (successfully or with failure).
> 
> 
> The host managed to set to maintenance when the image transfer cleared from
> the DB.
> 
> Version-Release number of selected component (if applicable):
> 4.4.7
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. Create a VM with a disk
> 2. Start a full backup for the VM and download the disk
> 3. After backup ended and the disk is downloaded, try to set the host that
> was used for the transfer to maintenance.
> 
> Actual results:
> Setting host to maintenance is not allowed.

this is just for the 15minutes until DB entree is cleared, right?
After that(15 min), you can move the host to maintenance?

> 
> Expected results:
> The host should be able to set to maintenance if all transfers are done or
> idle.
> 
> Additional info:

Comment 2 Eyal Shenitzky 2021-08-01 08:55:25 UTC
(In reply to Avihai from comment #1)

> this is just for the 15minutes until DB entree is cleared, right?
> After that(15 min), you can move the host to maintenance?

Right

Comment 3 RHEL Program Management 2021-08-02 11:36:34 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 6 Nir Soffer 2021-08-03 19:41:34 UTC
*** Bug 1989718 has been marked as a duplicate of this bug. ***

Comment 7 Amit Sharir 2021-08-08 11:56:44 UTC
Version: 
vdsm-4.40.80.4-1.el8ev.x86_64
ovirt-engine-4.4.8.3-0.10.el8ev.noarch


Verification conclusions:
The total flow mentioned was done with no errors/unexpected logs.
After the full backup for the VM and the download of the disk, I was able to put the host that was used for the transfer into maintenance via the UI (in less than 15 min).


Bug verified.

Comment 8 Sandro Bonazzola 2021-08-19 06:23:08 UTC
This bugzilla is included in oVirt 4.4.8 release, published on August 19th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.8 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Comment 9 Eyal Shenitzky 2021-09-30 07:00:03 UTC
*** Bug 2008898 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.