Bug 1989718 - Cannot switch Host host3 to Maintenance mode. Image transfer is in progress
Summary: Cannot switch Host host3 to Maintenance mode. Image transfer is in progress
Keywords:
Status: CLOSED DUPLICATE of bug 1987295
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.4.8.2
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: ---
: ---
Assignee: Eyal Shenitzky
QA Contact: Avihai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-03 19:19 UTC by Nir Soffer
Modified: 2021-09-21 11:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-03 19:41:34 UTC
oVirt Team: Storage


Attachments (Terms of Use)

Description Nir Soffer 2021-08-03 19:19:56 UTC
Description of problem:

Trying to switch host to maintenance fails if there are finished transfers.

Error from engine UI:

    Error while executing action: Cannot switch Host host3 to Maintenance mode.
    Image transfer is in progress for the following (1) disks:

    3649d84b-6f35-4314-900a-5e8024e3905c

    Please wait for the operations to complete and try again.

Database state:

engine=# select command_id,phase,disk_id from image_transfers;
              command_id              | phase |               disk_id                
--------------------------------------+-------+--------------------------------------
 ac4f6304-bec1-45eb-8d20-aaa82d077236 |     9 | 3649d84b-6f35-4314-900a-5e8024e3905c
 fa495abf-6c0f-4846-b316-f0b37c1d2606 |     9 | 3649d84b-6f35-4314-900a-5e8024e3905c
 f2fc212b-b557-42f6-bcdc-ddce7f8d63cb |     9 | 3649d84b-6f35-4314-900a-5e8024e3905c
 619e1e15-adbb-46e0-9b1e-c5c42f2887aa |     9 | 3649d84b-6f35-4314-900a-5e8024e3905c
(4 rows)


Version-Release number of selected component (if applicable):
Software Version:4.4.8.3-0.0.master.20210801143636.git475a2e196e0.el8

How reproducible:
Always

Steps to Reproduce:
1. Perform image transfer (upload or download, from UI or from API)
2. Try to move host to maintenance
Expected:Host move to mainatainance
Actual:
User needs to wait about 15 minutes until all image transfers are deletedfrom the database.

Actual results:
Validation fails, host does not move to maintenance

Expected results:
Host move to maintenance

Additional info:
This is another regression introduced in 4.4.7.

Comment 1 Nir Soffer 2021-08-03 19:41:34 UTC

*** This bug has been marked as a duplicate of bug 1987295 ***


Note You need to log in before you can comment on or make changes to this bug.