Bug 19873 - rexec broken on RH7.0
rexec broken on RH7.0
Status: CLOSED DUPLICATE of bug 18886
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
noarch Linux
high Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-26 14:12 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-26 14:12:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-26 14:12:27 EDT
Rexec client does not work in RH 7.0.  I localized the problem to the call
to getservbyname in the rexec source.  This call returns the wrong port
number for establishing the remote connection.  The port number returned by
the following code fragment is port 2 instead of port 512 as listed in
/etc/services

	  service = getservbyname("exec","tcp");
	  port_exec = service->s_port;

as revealed by gdb "print port_exec" after breaking on the appropriate line
in rexec.c (132). Setting the value of port_exec to 512 corrects the
problem and allows the rexec command to function correctly and terminate
normally.
Comment 1 Jakub Jelinek 2000-10-27 12:08:18 EDT

*** This bug has been marked as a duplicate of 18886 ***

Note You need to log in before you can comment on or make changes to this bug.