Bug 18886 - rexec(3) bug in inet/rexec.c
rexec(3) bug in inet/rexec.c
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
: 19379 19602 19873 20441 25363 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-11 09:42 EDT by Nalin Dahyabhai
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-20 18:35:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2000-10-11 09:42:40 EDT
The rexec() function in rexec.c is supposed to receive the second argument
(rport) in network-byte order, but it doesn't swap it back to host order
before passing it to snprintf() for formatting the strings.
Comment 1 Jakub Jelinek 2000-10-13 02:08:35 EDT
Do you have some testcase, like e.g. rsh does not work or something like that?
I've submitted a patch to fix this to Ulrich, but would like to verify it.
Comment 2 Nalin Dahyabhai 2000-10-19 10:14:55 EDT
*** Bug 19379 has been marked as a duplicate of this bug. ***
Comment 3 Nalin Dahyabhai 2000-10-19 10:15:47 EDT
Sorry for the delay.  The test case is to run rexec to any host from a
little-endian machine.  If you strace it, it'll try to connect to port 2 instead
of 512.
Comment 4 Jakub Jelinek 2000-10-19 10:50:59 EDT
Please check glibc-2.1.95-1, it should be fixed there.
Comment 5 Jakub Jelinek 2000-10-20 17:32:42 EDT
*** Bug 19379 has been marked as a duplicate of this bug. ***
Comment 6 Nalin Dahyabhai 2000-10-24 14:56:02 EDT
*** Bug 19602 has been marked as a duplicate of this bug. ***
Comment 7 Jakub Jelinek 2000-10-27 12:08:15 EDT
*** Bug 19873 has been marked as a duplicate of this bug. ***
Comment 8 Nalin Dahyabhai 2000-11-20 18:34:47 EST
Jakub, this is fixed in the latest errata candidate.
Comment 9 Nalin Dahyabhai 2000-11-20 18:35:36 EST
*** Bug 20441 has been marked as a duplicate of this bug. ***
Comment 10 Nalin Dahyabhai 2001-02-05 01:47:54 EST
*** Bug 25363 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.