Bug 198731 - scim-panel-gtk gets SIGPIPE after applying setup changes
scim-panel-gtk gets SIGPIPE after applying setup changes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jens Petersen
: i18n, Reopened
Depends On:
Blocks: SCIM
  Show dependency treegraph
 
Reported: 2006-07-13 02:25 EDT by Lawrence Lim
Modified: 2014-03-25 20:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-26 00:08:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
new trace for the bug (1.29 KB, text/plain)
2006-09-19 03:28 EDT, Lawrence Lim
no flags Details

  None (edit)
Description Lawrence Lim 2006-07-13 02:25:42 EDT
Description of problem:
This bug is quite hard to catch. I did it quite a few times to get it to crash. 

Version-Release number of selected component (if applicable):
scim-1.4.4-23.fc6

How reproducible:
Always

Steps to Reproduce:
1.goto SCIM Setup
2.goto Global Setup
3.click on '...' to modify Trigger key
4.Add the desired combination and apply changes

There is one more way...
1. right click scim icon
2. select 'Reload Configuration'
  
Actual results:
scim panel crash

Expected results:
should not crash

Additional info:
/usr/lib/scim-1.0/scim-panel-gtk
Program received signal SIGPIPE, Broken pipe.
[Switching to Thread -1211085920 (LWP 2491)]
0xb7f6c402 in ?? ()
(gdb) bt
#0  0xb7f6c402 in ?? ()
#1  0x00d9ccab in __write_nocancel () from /lib/libpthread.so.0
#2  0x0029696d in scim::Socket::write (this=0xb7d040cc, buf=0x95ceb28, size=26)
    at scim_socket.cpp:376
#3  0x0029e6d5 in scim::Transaction::write_to_socket (this=0x95ce7e0,
    socket=@0xb7d040cc, signature=Variable "signature" is not available.
) at scim_transaction.cpp:136
#4  0x0028e589 in scim::PanelAgent::PanelAgentImpl::socket_receive_callback (
    this=0x95ce7c0, server=0x95ce7d8, client=@0xb7d04344)
    at scim_panel_agent.cpp:575
#5  0x00283de5 in scim::MethodSlot2<scim::PanelAgent::PanelAgentImpl, void,
scim::SocketServer*, scim::Socket const&>::call
(this=0x95cf380, p1=0x95ce7d8,
    p2=@0xb7d04344) at ./scim_slot.h:420
#6  0x0029bce5 in scim::SocketServer::run (this=0x95ce7d8)
    at ./scim_signals.h:482
#7  0x00281737 in scim::PanelAgent::run (this=0x95ce710)
    at scim_panel_agent.cpp:238
#8  0x0804fd77 in panel_agent_thread_func (data=0x0) at scim_panel_gtk.cpp:2380
#9  0x06c0e64f in g_thread_create_full () from /lib/libglib-2.0.so.0
#10 0x00d973fc in start_thread () from /lib/libpthread.so.0
#11 0x00bd38ae in clone () from /lib/libc.so.6
(gdb)


/usr/bin/scim-bridge-agent
Program received signal SIGUSR1, User defined signal 1.
[Switching to Thread -1344017504 (LWP 2710)]
0xb7fae402 in ?? ()
(gdb) bt
#0  0xb7fae402 in ?? ()
#1  0x00d9c1ee in sem_wait@GLIBC_2.0 () from /lib/libpthread.so.0
#2  0x08057645 in ScimBridgeAgentEventClient::poll_event (this=0x92e9740)
    at scim-bridge-agent-event-client.cpp:111
#3  0x08058a7c in ScimBridgeAgentClientListenerImpl::process_event (
    this=0x92e9740) at scim-bridge-agent-client-listener.cpp:375
#4  0x08058bdb in run_socket_writer (arg=0x92e9740)
    at scim-bridge-agent-client-listener.cpp:153
#5  0x00d973fc in start_thread () from /lib/libpthread.so.0
#6  0x00bd38ae in clone () from /lib/libc.so.6
(gdb)
Comment 1 Jens Petersen 2006-08-01 08:05:13 EDT
I haven't seen this.  Is it still happening with latest rawhide?
Comment 2 Lawrence Lim 2006-08-01 19:36:21 EDT
There were a couple of instance where after upgrading to rawhide scim completely
stop working. Not 100%, thus, a bit harder to reproduce. If you can give me a
couple of days, once Test2 is ready, I will be able to confirm for you.
Comment 3 Jens Petersen 2006-08-01 21:16:10 EDT
Perhaps it is related to upgrades of scim-bridge?
Can you try testing scim-bridge-0.2.{5,6} to 0.2.7 for example.
Comment 4 Jens Petersen 2006-08-25 04:17:20 EDT
Closing this for now since I haven't been able to reproduce it.
Please reopen if you see it again.
Comment 5 Lawrence Lim 2006-09-19 03:25:10 EDT
This bug is still around. :(
Comment 6 Lawrence Lim 2006-09-19 03:28:40 EDT
Created attachment 136610 [details]
new trace for the bug

Step to reproduce is the same. Apply some changes in the scim-setup and click
ok.
Comment 7 Jens Petersen 2006-09-19 03:50:56 EDT
I can't reproduce on x86_64 at least.
Comment 8 Lawrence Lim 2006-09-19 21:24:01 EDT
Package Info
=============
scim-1.4.4-34.fc6
scim-tables-0.5.6-7
scim-chewing-0.3.1-4.fc6
scim-bridge-gtk-0.4.5-1.fc6
scim-qtimm-0.9.4-5
scim-bridge-0.4.5-1.fc6
scim-pinyin-0.5.91-12.fc6
scim-tables-chinese-0.5.6-7
scim-libs-1.4.4-34.fc6
scim-hangul-0.2.2-7.fc6
Comment 9 Leon Ho 2006-09-25 04:43:11 EDT
How frenqent is this issue?
Comment 10 Jens Petersen 2006-09-25 04:54:30 EDT
Lawrence, did you have a chance to test on x86_64?  Or should I test on i386?
Comment 12 Jens Petersen 2006-09-26 00:08:38 EDT
Ok, I have seen how to reproduce this now.

But looking at the SocketImpl::write method implementation in scim_socket.cpp
suggests this is probably the intended behaviour.

Note You need to log in before you can comment on or make changes to this bug.