Bug 1988427 - [4.6] drop-icmp pod blocks direct SSH access to cluster nodes
Summary: [4.6] drop-icmp pod blocks direct SSH access to cluster nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6.z
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
: 4.6.z
Assignee: mcambria@redhat.com
QA Contact: zhaozhanqi
URL:
Whiteboard:
: 2022703 (view as bug list)
Depends On: 1988426
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-07-30 14:06 UTC by mcambria@redhat.com
Modified: 2021-12-15 20:01 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1984449
Environment:
Last Closed: 2021-12-15 20:01:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 1171 0 None None None 2021-08-24 18:26:49 UTC
Red Hat Product Errata RHBA-2021:5010 0 None None None 2021-12-15 20:01:37 UTC

Comment 4 Chen 2021-10-22 10:13:14 UTC
Hi team,

One of my customers is also hitting this bug but they could update their cluster in a short time frame. Do we have any workaround for this issue ? Thanks a lot!

Best Regards,
Chen

Comment 6 mcambria@redhat.com 2021-11-15 15:51:15 UTC
*** Bug 2022703 has been marked as a duplicate of this bug. ***

Comment 13 zhaozhanqi 2021-12-02 03:26:51 UTC
Verified this bug on 4.6.0-0.nightly-2021-12-01-180138

Comment 14 zhaozhanqi 2021-12-02 03:27:14 UTC
sh-4.4# iptables-save | grep -i ICMP
:AZURE_CHECK_ICMP_SOURCE - [0:0]
:AZURE_ICMP_ACTION - [0:0]
-A INPUT -p icmp -m icmp --icmp-type 3/4 -j AZURE_CHECK_ICMP_SOURCE
-A OPENSHIFT-BLOCK-OUTPUT -p tcp -m tcp --dport 22623 --tcp-flags FIN,SYN,RST,ACK SYN -j REJECT --reject-with icmp-port-unreachable
-A OPENSHIFT-BLOCK-OUTPUT -p tcp -m tcp --dport 22624 --tcp-flags FIN,SYN,RST,ACK SYN -j REJECT --reject-with icmp-port-unreachable
-A AZURE_CHECK_ICMP_SOURCE -s 10.0.0.8/32 -p icmp -j AZURE_ICMP_ACTION
-A AZURE_CHECK_ICMP_SOURCE -s 10.0.0.6/32 -p icmp -j AZURE_ICMP_ACTION
-A AZURE_CHECK_ICMP_SOURCE -s 10.0.32.6/32 -p icmp -j AZURE_ICMP_ACTION
-A AZURE_CHECK_ICMP_SOURCE -s 10.0.0.5/32 -p icmp -j AZURE_ICMP_ACTION
-A AZURE_CHECK_ICMP_SOURCE -s 10.0.32.4/32 -p icmp -j AZURE_ICMP_ACTION
-A AZURE_CHECK_ICMP_SOURCE -s 10.0.32.5/32 -p icmp -j AZURE_ICMP_ACTION
-A AZURE_ICMP_ACTION -j LOG
-A AZURE_ICMP_ACTION -j DROP

Comment 17 errata-xmlrpc 2021-12-15 20:01:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.52 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:5010


Note You need to log in before you can comment on or make changes to this bug.