Bug 198865 - smart chokes on autofs5's +map syntax
smart chokes on autofs5's +map syntax
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: smart (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
: Reopened
: 208647 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-14 05:44 EDT by Jurgen Kramer
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.42-39
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-30 05:31:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2006-07-14 05:44:28 EDT
Description of problem:
smart crashes when trying a smart update / upgrde

Version-Release number of selected component (if applicable):
0.41-31.fc6

How reproducible:
allways

Steps to Reproduce:
1. smart upgrade or update
2.
3.
  
Actual results:
[root@macbook ~]# smart update
Traceback (most recent call last):
  File "/usr/bin/smart", line 194, in ?
    main(sys.argv[1:])
  File "/usr/bin/smart", line 161, in main
    forcelocks=opts.ignore_locks, loglevel=opts.log_level)
  File "/usr/lib/python2.4/site-packages/smart/__init__.py", line 115, in init
    ctrl = Control(configfile, forcelocks)
  File "/usr/lib/python2.4/site-packages/smart/control.py", line 53, in __init__
    self._fetcher = Fetcher()
  File "/usr/lib/python2.4/site-packages/smart/fetcher.py", line 53, in __init__
    self._mediaset = MediaSet()
  File "/usr/lib/python2.4/site-packages/smart/media.py", line 34, in __init__
    self.discover()
  File "/usr/lib/python2.4/site-packages/smart/media.py", line 41, in discover
    for lst in hooks.call("discover-medias"):
  File "/usr/lib/python2.4/site-packages/smart/hook.py", line 64, in call
    val = hook[0](*hookparam, **hookkwparam)
  File "/usr/lib/python2.4/site-packages/smart/media.py", line 329, in
discoverAutoMountMedias
    prefix, mapfile = line.split()[:2]
ValueError: need more than 1 value to unpack


Expected results:
working smart ;)

Additional info:
this is on a fully updated FC6 devel
Comment 1 Axel Thimm 2006-07-14 06:11:06 EDT
smart needs a rebuild on rawhide, but currently it breaks:

smart/util/celementtree/expat/xmlparse.c:75:2: error: #error memmove does not
exist on this platform, nor is a substitute available
Comment 2 Axel Thimm 2006-08-20 10:25:46 EDT
When I opened bug #201435 I didn't realize that it was a duoplicate of this one,
sorry. Since the resolution is in the other bug I'm closing this as a duplicate
of the other.

In case it's not the same issue please reopen, thanks!

*** This bug has been marked as a duplicate of 201435 ***
Comment 3 Axel Thimm 2006-08-20 19:16:05 EDT
I should better read the description not my own comment. While smart didn't
build until now for FC6, it doesn't really explain the error you see.

Can you please try again with the latest smart package? If it still fails (I
assume it will), please post the contents of auto.master. Thanks!
Comment 4 Deji Akingunola 2006-08-20 22:52:14 EDT
I've just updated to the latest smart package (smart-0.42-35.fc6), and it failed
to start giving the same traceback as in the initial bug report. If it matters,
this is a x86_64 system.
Comment 5 Axel Thimm 2006-08-21 07:38:59 EDT
That was expected, what about the contents of /etc/auto.master?
Comment 6 Deji Akingunola 2006-08-21 09:08:02 EDT
Sorry, it seems I didn't read comment #3 ver well earlier. Below is the entire
content of /etc/auto.master
>>>
#
# $Id: auto.master,v 1.4 2005/01/04 14:36:54 raven Exp $
#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).
#
/misc	/etc/auto.misc
/net	/etc/auto.net
#
# Include central master map if it can be found using
# nsswitch sources.
#
# Note that if there are entries for /net or /misc (as
# above) in the included master map any keys that are the
# same will not be seen as the first read key seen takes
# precedence.
#
+auto.master
<<<<
Comment 7 Axel Thimm 2006-08-21 09:19:24 EDT
The last line is what causes the breakage. smart assumes that all non-commented
entries in this file have at least two words.

If you comment that line smart will work again. See als bug #193831.
Comment 8 Deji Akingunola 2006-08-21 09:28:49 EDT
(In reply to comment #7)
> The last line is what causes the breakage. smart assumes that all non-commented
> entries in this file have at least two words.
> 
> If you comment that line smart will work again. See als bug #193831.
Yes you're right, it did work with the last line commented.
Comment 9 Jurgen Kramer 2006-08-21 13:48:25 EDT
I can confirm that commenting the last line of /etc/auto.master makes smart work
again.
Comment 10 Axel Thimm 2006-09-01 18:27:37 EDT
Upcoming package (-37) will have a check to skip +<map> entries in auto.master.
This is a short term fix, long term smart should query autofs directly instead
of replicating its parsing. Upstream has been notified and will fix it in a next
release.
Comment 11 Axel Thimm 2006-09-30 04:15:06 EDT
The patch is bogus: it applies the fix a couple lines too high. :(
Comment 12 Axel Thimm 2006-09-30 04:16:12 EDT
*** Bug 208647 has been marked as a duplicate of this bug. ***
Comment 13 Axel Thimm 2006-09-30 05:31:59 EDT
Fixed the fixing patch.

Note You need to log in before you can comment on or make changes to this bug.