Bug 201435 - smart does not build on FC6's python
smart does not build on FC6's python
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: smart (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On: 201434
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-05 05:38 EDT by Axel Thimm
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-18 18:55:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2006-08-05 05:38:51 EDT
Description of problem:
smart's detection on python build parameters, most notably HAVE_MEMMOVE, is
broken on FC6 (see bug #201434).

Version-Release number of selected component (if applicable):
smart-0.42-xxx

How reproducible:
always

Steps to Reproduce:
1.Try to build the package
2.
3.
  
Actual results:
gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -D_GNU
_SOURCE -fPIC -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -fPIC -DXML_STATIC -DXML_NS=1 -DXML
_DTD=1 -DXML_CONTEXT_BYTES=1024 -DBYTEORDER=1234 -Ismart/util/celementtree/expat
-I/usr/include/python2.4 -c smart/util/celementtree/expat/xmlparse.c -o
build/temp.linux-i686-2.4/smart/util/celementtree/expat/x
mlparse.o
smart/util/celementtree/expat/xmlparse.c:75:2: error: #error memmove does not
exist on this platform, nor is a substitute available


Expected results:
Should contain -DHAVE_MEMMOVE

Additional info:
Self-submitting to keep a tracking bug and a dependency to bug #201434. Also for
having a reference point when it comes to failed rebuild in new chroots or for
mass-rebuilds for FC6.
Comment 1 Axel Thimm 2006-08-18 18:55:49 EDT
Bug #201434 was fixed and smart builds now on FC6.
Comment 2 Axel Thimm 2006-08-20 10:26:03 EDT
*** Bug 198865 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.