Bug 198943 - rpmbuild shows Error's in Scanning objects
rpmbuild shows Error's in Scanning objects
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
low Severity low
: ---
: ---
Assigned To: Prarit Bhargava
Brian Brock
:
: 198945 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-14 16:40 EDT by Stuart Xu
Modified: 2008-05-12 08:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-12 08:36:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this file was collected with "rpmbuild -ba --target i686 kernel-2.9.spec &> log" (21.74 KB, application/octet-stream)
2006-07-14 16:40 EDT, Stuart Xu
no flags Details

  None (edit)
Description Stuart Xu 2006-07-14 16:40:04 EDT
Description of problem:

I am trying to build a kernel rpm as a test before custimizing the kernel.  I 
installed the kernel src.rpm:
-rw-r--r--  307 root root 41491422 Sep 26  2005 kernel-2.6.9-22.EL.src.rpm
then run "rpmbuild -ba --target i686 kernel-2.6.spec" (I modified the %release 
field in the spec file).  I got a lot of "Error:..." lines in "Scanning 
objects" section as well as some lines of "No such file or directory" (see 
attached file).  The rpm build was sucessful and the system can boot up with 
the new kernel.  But the "Error"s could be a problem in future operation 
without knowing the root cause.  I found Bugzilla Bug 143270 contains the same 
error string.  But I don't know the fix.

I also use "rpmbuild -bp" to get the source tree and build the kernel through 
the ordinary steps (make oldconfig, make bzImage,..., make install).  I did 
not see those errors.
 

Version-Release number of selected component (if applicable):

RHEL4-U2

How reproducible:
see the description section.

Steps to Reproduce:
1. rpm -ivh kernel-2.6.9-22.EL.src.rpm
2. /usr/src/redhar/SPECs/rpmbuild -ba --target i686 kernel-2.6.spec
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Stuart Xu 2006-07-14 16:40:04 EDT
Created attachment 132462 [details]
this file was collected with "rpmbuild -ba --target i686 kernel-2.9.spec &> log"
Comment 2 Jason Baron 2006-07-17 14:42:35 EDT
*** Bug 198945 has been marked as a duplicate of this bug. ***
Comment 3 Jason Baron 2006-09-20 13:11:51 EDT
unless there are any 'real' errors that this is causing we are treating this as
low priority. thanks.
Comment 4 Prarit Bhargava 2008-05-12 08:36:04 EDT
Since 4.8 is the "last" release, I'm not sure fixing these is important anymore
-- we've made it this far without any unusual issues ....

Closing as WONTFIX.

P.

Note You need to log in before you can comment on or make changes to this bug.