Bug 198945 - rpmbuild shows Error's in Scanning objects
rpmbuild shows Error's in Scanning objects
Status: CLOSED DUPLICATE of bug 198943
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-07-14 16:42 EDT by Stuart Xu
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-17 14:41:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
this file was collected with "rpmbuild -ba --target i686 kernel-2.9.spec &> log" (21.74 KB, application/octet-stream)
2006-07-14 16:42 EDT, Stuart Xu
no flags Details

  None (edit)
Description Stuart Xu 2006-07-14 16:42:08 EDT
Description of problem:

I am trying to build a kernel rpm as a test before custimizing the kernel.  I 
installed the kernel src.rpm:
-rw-r--r--  307 root root 41491422 Sep 26  2005 kernel-2.6.9-22.EL.src.rpm
then run "rpmbuild -ba --target i686 kernel-2.6.spec" (I modified the %release 
field in the spec file).  I got a lot of "Error:..." lines in "Scanning 
objects" section as well as some lines of "No such file or directory" (see 
attached file).  The rpm build was sucessful and the system can boot up with 
the new kernel.  But the "Error"s could be a problem in future operation 
without knowing the root cause.  I found Bugzilla Bug 143270 contains the same 
error string.  But I don't know the fix.

I also use "rpmbuild -bp" to get the source tree and build the kernel through 
the ordinary steps (make oldconfig, make bzImage,..., make install).  I did 
not see those errors.

Version-Release number of selected component (if applicable):


How reproducible:
see the description section.

Steps to Reproduce:
1. rpm -ivh kernel-2.6.9-22.EL.src.rpm
2. /usr/src/redhar/SPECs/rpmbuild -ba --target i686 kernel-2.6.spec
Actual results:

Expected results:

Additional info:
Comment 1 Stuart Xu 2006-07-14 16:42:08 EDT
Created attachment 132463 [details]
this file was collected with "rpmbuild -ba --target i686 kernel-2.9.spec &> log"
Comment 2 Stuart Xu 2006-07-14 16:51:12 EDT
Sorr, this is a duplicate submmit.  After clicked commit, the web page showed 
me "Invalid productname, click Back to try again". 
Comment 3 Jason Baron 2006-07-17 14:41:59 EDT

*** This bug has been marked as a duplicate of 198943 ***

Note You need to log in before you can comment on or make changes to this bug.