Bug 199015 - Installer crashes after network configuration
Installer crashes after network configuration
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2006-07-15 13:40 EDT by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-21 10:35:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2006-07-15 13:40:30 EDT
Description of problem:
For the latest versions of "anaconda", network installs exit after
establishing a download network connection. Affected systems are an
"IBM ThinkPad T23" (network driver "e100") and a "DELL GX260N".
An "HTTP" install exits after entering server name and download

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot from "boot.iso" w/options "linux [text]".
2. Choose language and keyboard layout "English/US".
3. Choose "HTTP" install and enter download server info.
Actual results:
Installer crashes.

Expected results:
Installer proceeds to downloading "stage2.img"

Additional info:
This bug looks exactly as my initial report for bug 195766
except that now, the "DHCP" errors are gone. The screen
looks like the first screenshot in that report:


The situation currently goes from bad to worse. It seems that
the "DHCP" fixes were not the very root of this issue.
Booting the current installer under "QEMU" also crashes reporting

  "Kernel panic - not syncing: Attempted to kill init"

Maybe a problem with "mkinitrd"?
Comment 1 Joachim Frieben 2006-07-16 06:42:07 EDT
The installer also crashes after setting up a static network connection.
This appears to rule out "DHCP" problems, too. As a matter of fact, the
current issue now looks very similar to bug 196701 which had reported
identical problems on "IA64" hardware.
Comment 2 G.Wolfe Woodbury 2006-07-17 15:29:28 EDT
Also noted on the work1.private testbed here (Celeron-Coppermine@600MHz)

Using either DHCP or static setup, AND using any of NFS, FTP or HTTP install
methods, the installer crashes afterloading stage two with only a simple
"Installer Terminated Abnormally"

No dump to floppy offered, all network access is definitely operational and
allowed.  No AVC messages or any strange indications on VT3 or VT4 screens.

Inserting a floppy does NOT offer a solution at this point. :-(

Comment 3 G.Wolfe Woodbury 2006-07-17 15:35:36 EDT
After reading bug 196701, I see no indications of a crash of any kind except the
noted test message on VT1.  This is a i686 machine so It may not be showing the
full crash information.

I suspect turning on the "dump to floppy" option for any "abnormal termination"
error would yeild a plethora of reports quickly.

Comment 4 David Cantrell 2006-07-17 16:09:16 EDT
The crash you're seeing is due to lack of libdhcp* libraries in the stage2
image, which is why anaconda won't load correctly.  We're seeing that here on
the latest trees.  The stage2 creation script has been modified to include those

Thanks for the report.
Comment 5 Joachim Frieben 2006-07-18 15:38:26 EDT
It doesn't help anyway -> reopening the bug.
Comment 6 Joachim Frieben 2006-07-18 15:40:44 EDT
Right, I forgot: still broken in "anaconda-".
Comment 7 G.Wolfe Woodbury 2006-07-19 01:49:26 EDT
Second the re-opening of the bug.
Several attempts were made to make the install work:
1: straight install -> "installer terminated abnormally [1/1]" (symptom A)
2: straight install w/static configurations -> symptom A
3: linux askmethod text -> symptom A
4: linux askmethod text  w/static IP  -> symptom A
(1-4 using NFS from local mirror)
5: HTTP install -> symptom A
6: HTTP w/static IP -> symptom A
7: linux askmethod selinux=0  -> symptom A

Symptom A leaves no traces of error on an i686 system following the start of
/usr/bin/anaconda (having loaded stage2 via any of the methods).

a very frustrating bug.
Comment 8 Paul Nasrat 2006-07-19 06:53:42 EDT
This is an import error from a new library not in the roots which should be
fixed in todays rawhide.  anaconda-  The same error can be
caused by different symptoms.
Comment 9 Joachim Frieben 2006-07-19 09:51:03 EDT
Still broken in "anaconda-". The affected system is the "IBM
ThinkPad T23". After booting w/o any boot options, "IPv6" support gets
unchecked. After entering the download server data referring to
"download.fedora.redhat.com", the already mentioned blue screen appears
and some memory map is dumped to the terminal.

[PS: On a "DELL GX280SF", the installer terminates w/o blue screen and
 reporting "SIGSEGV!" at "vt8". For a "DELL GX260N", the installer
 actually proceeds to downloading "stage2.img" which is  an improvement
 with respect to my original report.]
Comment 10 David Cantrell 2006-07-19 11:33:56 EDT
I absolutely cannot reproduce what you are describing here.  Network
configuration is working in stage1 on all systems I can have access to.  I need
more information.

It doesn't matter if you do DHCP or static IP configuration in stage1 (the
text-mode part of the installer), but after it configures the network interface
and then prompts you for the HTTP location (or FTP or NFS), *do not* enter
anything.  Instead, go to tty3 (Alt+F3) and gather the information displayed
there.  I need that information.

Now, it is possible that you are continuing to see stage2 problems because for
the past week almost, the stage2 image has been completely hosed.  Missing
libraries, missing Python modules, X.org is somewhat working.  My main concern
is whether or not you're network configuration in stage1 is crashing.
Comment 11 G.Wolfe Woodbury 2006-07-19 12:25:11 EDT
In my case it is *definitely* in stage two

I am reporting that network config *is working* fine and the installation fails
after loading stage2.
Comment 12 Joachim Frieben 2006-07-19 13:19:57 EDT
I had written '"DHCP" errors are gone' in my original post. This still
seems to hold, as the last 7 lines from the "vt3" output indicate:

  INFO: DHCPv4 eth0 - obtained lease
  INFO: DHCPv4 eth0 - option subnet-mask
  INFO: DHCPv4 eth0 - option subnet-mask - prefix_len : 16
  INFO: broadcast
  INFO: DHCPv4 eth0 - options routers :
  INFO: reverse name lookup worked
  INFO: starting to STEP_URL
Comment 13 Joachim Frieben 2006-07-19 13:28:25 EDT
I have to stress that the bug reported here is different from that
reported in comment #2. In my case, the installer aborts immediately
after entering the download server info and hitting "Ok". (The situation
is different for the "DELL GX260N" from comment #9 for which the
"stage2.img" download actually works. I haven't investigated if it crashes
after completing the download. However, this report is primarily about my
"IBM ThinkPad T23" and for that the installer crashes earlier.)
Comment 14 G.Wolfe Woodbury 2006-07-19 19:40:17 EDT
Note that today's anaconda (2007-07-19) is working for me!  I'm doing an install
right now on the testbed work1 machine.  I'll report if there are bugs in the
late install phases.
Comment 15 Joachim Frieben 2006-07-20 12:51:09 EDT
Still broken in "anaconda-". As an additional info to comment #13,
the graphical installer boots correctly after downloading "stage2.img".
However, still no success neither for "IBM ThinkPad T23" nor "DELL GX280SF".
Comment 16 Joachim Frieben 2006-07-20 12:54:45 EDT
Sorry, I meant: the graphical installer boots correctly after downloading
"stage2.img" on the "DELL GX260N"! Bluescreen as before on my "IBM ThinkPad
T23", termination message on "DELL GX280SF", in both cases after confirming
the download server info.
Comment 17 David Cantrell 2006-07-21 10:35:26 EDT
It seems as though we are seeing some forward progress.  I do appreciate your
bug reports and patience with regard to testing each day.

I've got to close this bug now because it's far too much information now.  The
original problem was in loader (stage1) and that's resolved.  There are numerous
problems in stage2 at this point, but keeping things listed under this bug is

Please file new bug reports with specific details, log file output, and any
tracebacks you get from anaconda.

Note You need to log in before you can comment on or make changes to this bug.