Bug 199019 - wireless-tools needs to be updated because of new kernel
wireless-tools needs to be updated because of new kernel
Status: CLOSED DUPLICATE of bug 196536
Product: Fedora
Classification: Fedora
Component: wireless-tools (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-15 14:14 EDT by Stuart Jansen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-18 20:07:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart Jansen 2006-07-15 14:14:25 EDT
Description of problem:

For a while now, FC5 has been pushing out kernels with a newer version of the
wireless extensions than what wireless-tools supports.


Version-Release number of selected component (if applicable):
[root@vision ~]# uname -a
Linux vision.buscaluz.org 2.6.17-1.2157_FC5 #1 Tue Jul 11 22:55:46 EDT 2006 i686
athlon i386 GNU/Linux

[root@vision ~]# iwlist eth1 scan
Warning: Driver for device eth1 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...


How reproducible:

always
Comment 1 Oisin C. Feeley 2006-08-02 21:01:25 EDT
That's apparently still the case (Aug 1st 2006), but it's also apparently the
case that the scans work anyway!

[root@larry ush]# uname -a
Linux larry 2.6.17-1.2145_FC5 #1 Sat Jul 1 13:03:45 EDT 2006 i686 i686 i386
GNU/Linux

[root@larry ush]# /sbin/iwlist scan lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

Warning: Driver for device wifi0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

wifi0     Scan completed :
          Cell 01 - Address: 00:0F:66:00:93:A2
                    ESSID:"nutmeat"
                    Mode:Master
                    Frequency:2.437 GHz (Channel 6)
                    Signal level=-36 dBm  Noise level=-72 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:resp_rate=10

wlan0     Scan completed :
          Cell 01 - Address: 00:0F:66:00:93:A2
                    ESSID:"nutmeat"
                    Mode:Master
                    Frequency:2.437 GHz (Channel 6)
                    Signal level=-37 dBm  Noise level=-72 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:resp_rate=10
Comment 2 Radek Bíba 2006-08-18 20:07:54 EDT
This is a known problem. Thanks for your report anyway.

*** This bug has been marked as a duplicate of 196536 ***

Note You need to log in before you can comment on or make changes to this bug.