Bug 196536 - iwconfig produces warning message when using kernel 2.6.17.xx
iwconfig produces warning message when using kernel 2.6.17.xx
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: wireless-tools (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Aillon
:
: 199019 201223 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-24 00:23 EDT by Albert Graham
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-07 13:50:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Graham 2006-06-24 00:23:36 EDT
Description of problem:

Since kernel 2.6.17.x uses WE-20 and the current version of Wireless Tools with
FC5 uses WE-19, you get a "Warning" message when using iwconfig as follows:

Warning: Driver for device wmaster0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...


Version-Release number of selected component (if applicable):

wireless-tools-28-0.pre13.5.1

How reproducible:

see below.

Steps to Reproduce:
1. Load your wireless drivers as normal
2. type iwconfig
  
Actual results:

Warning: Driver for device wmaster0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

Expected results:

Normal output, without the above message.

Additional info:
Comment 1 Jack Spaar 2006-06-27 19:52:07 EDT
In addition to the warning reported above when using kernel-2.6.17-1.2139_FC5,
wireless fails to function for me -- no APs are discovered by NetworkManager or
iwlist scan.   

But I'm using ndiswrapper.  It loads normally but reports:
kernel: ndiswrapper (wrap_ndis_worker:1147): wlan0 is being reset


I rebuilt the wireless-tools srpm using the stable version 28 release tarball
(wireless_tools.28.tar.gz).

This does fix the warning about WEXT versions, but still won't function for me
on kernel-2.6.17-1.2139_FC5 (same errors).  28-stable does work fine on
kernel-2.6.16-1.2133_FC5, as did 28-pre13.
Comment 2 Radek Bíba 2006-06-28 16:17:32 EDT
Similar here with ipw2200: the warning is printed with the new FC5 kernel, though
I can't tell if anything stopped working or not because I'm not near any usable
AP at the moment.

Rebuilding wireless-tools with version 28 also helps me. Please update
wireless-tools in Fedora, 28 is now stable upstream version anyway.
Comment 3 Christian Krause 2006-07-02 11:13:51 EDT
(In reply to comment #2)
> Similar here with ipw2200: the warning is printed with the new FC5 kernel, though
> I can't tell if anything stopped working or not because I'm not near any usable
> AP at the moment.

I can confirm that despite the warning the ipw2200 is still working.
Nevertheless please rebuild the wireless tools because such warnings shouldn't
be in a stable version of a distribution. 
Comment 4 Jose Plans 2006-07-08 14:13:46 EDT
Same here, the new stable version includes wireless.20.h among other fixes.
Rebuilding the package did solve my ipw2200 problems. Please rebuild.
Comment 5 Marcin Garski 2006-07-11 20:00:14 EDT
You can also update devel tree from version 28-pre16 to 29-pre10 which add
support for WE-21 and many other new features and bug fixes.
Comment 6 Radek Bíba 2006-08-18 20:08:18 EDT
*** Bug 199019 has been marked as a duplicate of this bug. ***
Comment 7 Radek Bíba 2006-08-18 20:09:43 EDT
*** Bug 201223 has been marked as a duplicate of this bug. ***
Comment 8 Radek Bíba 2006-11-07 13:50:20 EST
Not seeing this anymore in FC6, which contains wireless-tools-28-1.fc6.

Note You need to log in before you can comment on or make changes to this bug.