Bug 199078 - scim-bridge crashed upon IME activation
scim-bridge crashed upon IME activation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: SCIM
  Show dependency treegraph
 
Reported: 2006-07-17 00:25 EDT by Lawrence Lim
Modified: 2014-03-25 20:53 EDT (History)
3 users (show)

See Also:
Fixed In Version: scim-bridge-0.2.6-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 08:34:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2006-07-17 00:25:27 EDT
Description of problem:
Tried with "nonshared-imengine" mode, scim-bridge crashed when attepmted to 
activate IME in gedit application. The "factory" is also NULL, as it didn't 
get the chance to activate.

Version-Release number of selected component (if applicable):
scim-bridge-debuginfo-0.2.4-1.1.fc6
scim-bridge-gtkimm-0.2.4-1.1.fc6
scim-bridge-0.2.4-1.1.fc6
gedit-2.15.3-1

How reproducible:
Always

Steps to Reproduce:
1.from gnome-terminal, start gedit
2.activate scim
3.
  
Actual results:
scim-bridge crashed and Gtk apps hanged

Expected results:
should be able to input

Additional info:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1281737824 (LWP 3573)]
0x0805d7bf in ScimBridgeAgentIMContextImpl::set_enabled (this=0x85ccf30,
    new_state=true) at scim-bridge-agent-imcontext.cpp:452
452             PanelFactoryInfo info = PanelFactoryInfo (factory->get_uuid 
(), utf8_wcstombs (factory->get_name ()), factory->get_language (), 
factory->get_icon_file ());
(gdb) bt
#0  0x0805d7bf in ScimBridgeAgentIMContextImpl::set_enabled (this=0x85ccf30,
    new_state=true) at scim-bridge-agent-imcontext.cpp:452
#1  0x080541f5 in ScimBridgeAgentImpl::filter_hotkeys (this=0x836ccf0,
    imcontext=0x85ccf30, key_event=@0x85c9824) at scim-bridge-agent.cpp:614
#2  0x08054990 in ScimBridgeAgentImpl::filter_key_event (this=0x836ccf0,
    event=0x85c9818) at scim-bridge-agent.cpp:760
#3  0x08054b01 in ScimBridgeAgentImpl::read_and_dispatch (this=0x836ccf0)
    at scim-bridge-agent.cpp:305
#4  0x08054b58 in run_event_dispatcher (arg=0x836ccf0)
    at scim-bridge-agent.cpp:184
#5  0x00439fbc in start_thread () from /lib/libpthread.so.0
#6  0x008d830e in clone () from /lib/libc.so.6
(gdb)
Comment 1 Ryo Dairiki 2006-07-18 00:01:04 EDT
I cannot reproduce this at all, but I think it might have something to do with
the "fallback IMEngine".
It does have the "factory", but it is not registered in scim-backend as it is
not a loadable module but a part of scim core library.
I think scim-backend cannot find the "factory" for the fallback IMEngine then
returns NULL.

Now I've made some fixes on the CVS to handle such a situation.
You can get it from: http://sourceforge.net/cvs/?group_id=108454
I hope this work for you.
Comment 2 Ryo Dairiki 2006-07-22 23:14:14 EDT
Scim-bridge-0.2.5 has been released.
This release also contains this bug fixes.
(Although I haven't confirmed if it's really okay) 
Comment 3 Jens Petersen 2006-07-24 06:32:18 EDT
scim-bridge package was updated to 0.2.5.
Comment 4 Satyabrata Maitra 2006-07-27 08:34:14 EDT
I did not able to reproduce this bug. Closing it. If bug found again, please
reopen this bug.


Version-Release number of selected component

scim-libs-1.4.4-9.2.fc5
scim-qtimm-0.9.4-5
scim-pinyin-0.5.91-11.3.fc6
scim-bridge-gtkimm-0.2.6-1.fc6
scim-fcitx-3.1.1-5.fc6
scim-bridge-0.2.6-1.fc6
scim-input-pad-0.1.1-4.fc6
scim-libs-1.4.4-25.fc6
scim-devel-1.4.4-25.fc6
scim-fcitx-tools-3.1.1-5.fc6
scim-m17n-0.2.0-5.fc6
gedit-2.15.4-1

Note You need to log in before you can comment on or make changes to this bug.