Bug 199080 - scim-chewing crashes when enter two pinyin words
scim-chewing crashes when enter two pinyin words
Status: CLOSED DUPLICATE of bug 197556
Product: Fedora
Classification: Fedora
Component: scim-chewing (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: SCIM
  Show dependency treegraph
 
Reported: 2006-07-17 02:32 EDT by Leon Ho
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 23:32:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leon Ho 2006-07-17 02:32:02 EDT
Description of problem:
When typing two pinyin words in romanized pinyin mode, the IME will be crashed.

Version-Release number of selected component (if applicable):
scim-chewing-0.3.1-2.1

How reproducible:
everytime

Steps to Reproduce:
1. Change to romanize pinyin
2. type "hongmao""
3. press space
  
Actual results:
crash

Expected results:
not crashing

Additional info:
Comment 1 Qian Shen 2006-07-24 05:00:50 EDT
I have filed a bug in chewing upstream bugzilla. see: 
http://rt.openfoundry.org/Foundry/Project/Tracker/Display.html?Queue=271&id=22723
Comment 2 Qian Shen 2006-07-24 05:45:15 EDT
found scim-bridge error when chewing crashed.
remove scim-bridge and scim-bridge-gtkimm, chewing does not creash!
Guess this should be scim-bridge bug.
Comment 4 Jens Petersen 2006-07-26 02:20:35 EDT
This still seems to happen with scim-bridge-0.2.6.
Comment 5 Jens Petersen 2006-07-26 10:10:40 EDT
BTW even with the scim gtkimm I don't seem able to input "hongmao"
in one go, but I can input "hong" and then "mao".  Is that a scim-chewing bug? 
I wonder if it might be related to this.
Comment 6 Ryo Dairiki 2006-07-27 02:19:13 EDT
I couldn't reproduce that.

"hong" and "mao" shows something in the preedit, but they'll be destroied as
soon as I type space.
That time, I've got no error at all.
The preedit is removed by proper order from the IME.

I've tried that at "nihao" and "xiexie", just to get the same results.
(Is my spell wrong?)

The worst thing to say is that I've got the same result on scim-gtkimm. :(
Maybe, there are more than one bugs around this problem.


Btw,
I've found that scim-bridge-0.2.6 causes segfaults on reloading configuration of
scim-chewing.
This bug has been fixed on the cvs latest.
Comment 7 Leon Ho 2006-07-27 02:25:16 EDT
Dairiki-san, sounds like you need to change to romaize pinyin first:
SCIM Setup -> IMEngine -> Chewing -> Keyboard -> Use keyboard type: "Han-Yu
PinYin Keyboard"
Comment 8 Ryo Dairiki 2006-07-27 07:23:29 EDT
Thanks, I've confirmed.
I think it's a bug of scim-chewing, but I can tell exactly.
(I've got no error that time)

The possibility is that scim-chewing blocks communication between scim-agent and
scim configuration server.
I'll check that later, but it needs much more time I think.
Comment 9 Jens Petersen 2006-07-27 23:32:42 EDT
I agree with Dairiki comments since I can reproduce this too with scim-gtkimm.

*** This bug has been marked as a duplicate of 197556 ***

Note You need to log in before you can comment on or make changes to this bug.