Bug 1991471 - F35FailsToInstall: gnuradio
Summary: F35FailsToInstall: gnuradio
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gnuradio
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2002142 (view as bug list)
Depends On:
Blocks: F35FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2021-08-09 08:39 UTC by Miro Hrončok
Modified: 2021-09-28 20:14 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-28 20:14:35 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2021-08-09 08:39:28 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

Your package (gnuradio) Fails To Install in Fedora 35:

can't install gnuradio:
  - nothing provides libcodec2.so.0.9()(64bit) needed by gnuradio-3.9.2.0-4.fc35.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Marcus Müller 2021-08-09 08:58:02 UTC
The repository situation is confusing; this might be a bug in the codec2 packaging?

Short version: `dnf repoquery` and `dnf info` agree that there's a package that ships the lib in FC35; somehow, however, repoquery only "sees" the i686 version.

$ dnf repoquery --releasever=35 --forcearch=x86_64 --whatprovides libcodec2.so.0.9
codec2-0:0.9.2-8.fc35.i686

Note that this seems to be an i686 package, disregarding the forcearch.

So, I tried running

$ dnf info --releasever=35 codec2-0:0.9.2-8.fc35 

Available Packages
Name         : codec2
Version      : 0.9.2
Release      : 8.fc35
Architecture : i686
Size         : 346 k
Source       : codec2-0.9.2-8.fc35.src.rpm
Repository   : fedora
Summary      : Next-Generation Digital Voice for Two-Way Radio
URL          : http://rowetel.com/codec2.html
License      : LGPLv2
Description  : Codec 2 is an open source (LGPL licensed) speech codec for 2400 bit/s
             : and below. This is the runtime library package.

Name         : codec2
Version      : 0.9.2
Release      : 8.fc35
Architecture : x86_64
Size         : 338 k
Source       : codec2-0.9.2-8.fc35.src.rpm
Repository   : fedora
Summary      : Next-Generation Digital Voice for Two-Way Radio
URL          : http://rowetel.com/codec2.html
License      : LGPLv2
Description  : Codec 2 is an open source (LGPL licensed) speech codec for 2400 bit/s
             : and below. This is the runtime library package.

Comment 2 Miro Hrončok 2021-08-09 09:09:00 UTC
codec2 was updated in Koji:

$ repoquery --repo=koji --provides codec2
codec2 = 1.0.0-1.fc35
codec2(x86-64) = 1.0.0-1.fc35
libcodec2.so.1.0()(64bit)

The update has not yet reached rawhide:

$ repoquery --repo=rawhide --provides codec2
codec2 = 0.9.2-8.fc35
codec2(x86-32) = 0.9.2-8.fc35
codec2(x86-64) = 0.9.2-8.fc35
libcodec2.so.0.9
libcodec2.so.0.9()(64bit)



> Note that this seems to be an i686 package, disregarding the forcearch.

Only the i686 package provided "libcodec2.so.0.9", the x86_64 one provided "libcodec2.so.0.9()(64bit)".
Nevertheless, that is irrelevant: in a while, the updated codec2 will hit rawhide.

Comment 3 Marcus Müller 2021-08-09 09:17:42 UTC
Ah great, thanks! (That was *amazingly* fast)

 I don't think I can change state to RELEASE_PENDING, but I'll try.

Comment 4 Ben Cotton 2021-08-10 13:36:39 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 5 Miro Hrončok 2021-08-25 22:54:16 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 36.

Thanks for taking care of it!

Comment 6 Daniel Rusek 2021-09-26 09:52:46 UTC
It looks like that there is still the same problem with codec2 and other gnuradio parts when trying to upgrade from F34 to F35 Beta:

Error: 
 Problem 1: problem with installed package gnuradio-3.9.0.0-5.fc34.x86_64
  - package gnuradio-3.9.2.0-5.fc35.x86_64 requires libcodec2.so.0.9()(64bit), but none of the providers can be installed
  - gnuradio-3.9.0.0-5.fc34.x86_64 does not belong to a distupgrade repository
  - codec2-0.9.2-7.fc34.x86_64 does not belong to a distupgrade repository
 Problem 2: problem with installed package gqrx-2.14.4-1.fc34.x86_64
  - package gqrx-2.14.4-5.fc35.x86_64 requires libboost_thread.so.1.75.0()(64bit), but none of the providers can be installed
  - gqrx-2.14.4-1.fc34.x86_64 does not belong to a distupgrade repository
  - boost-thread-1.75.0-4.fc34.x86_64 does not belong to a distupgrade repository
 Problem 3: cannot install both codec2-1.0.0-1.fc35.2.x86_64 and codec2-0.9.2-7.fc34.x86_64
  - package gnuradio-3.9.2.0-5.fc35.x86_64 requires libcodec2.so.0.9()(64bit), but none of the providers can be installed
  - package lpcnetfreedv-0.2-9.fc35.x86_64 requires libcodec2.so.1.0()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-analog.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-audio.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-blocks.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-channels.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-digital.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-fec.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-fft.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-filter.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-network.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-pmt.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-qtgui.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-runtime.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-soapy.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-trellis.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-uhd.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-video-sdl.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-vocoder.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-wavelet.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires libgnuradio-zeromq.so.3.9.2()(64bit), but none of the providers can be installed
  - package gnuradio-devel-3.9.2.0-5.fc35.x86_64 requires gnuradio(x86-64) = 3.9.2.0-5.fc35, but none of the providers can be installed
  - problem with installed package lpcnetfreedv-0.2-7.fc34.x86_64
  - problem with installed package gnuradio-devel-3.9.0.0-5.fc34.x86_64
  - lpcnetfreedv-0.2-7.fc34.x86_64 does not belong to a distupgrade repository
  - gnuradio-devel-3.9.0.0-5.fc34.x86_64 does not belong to a distupgrade repository
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)

Comment 7 Otto Urpelainen 2021-09-26 11:58:21 UTC
I am not sure why it was expected
that updating codec2 to 1.0 would fix a problem
where gnuradio needs, but does not find, 0.9.
Anyhow, the problem remains
so let me reopen this.

Comment 8 Otto Urpelainen 2021-09-26 12:03:40 UTC
*** Bug 2002142 has been marked as a duplicate of this bug. ***

Comment 9 Miro Hrončok 2021-09-28 20:14:35 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.