Bug 199216 - Sata_promise works for kernel 2.6.16-1.2122_FC5 but not for 2.6.17-1.2157_FC5
Sata_promise works for kernel 2.6.16-1.2122_FC5 but not for 2.6.17-1.2157_FC5
Status: CLOSED DUPLICATE of bug 199142
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-17 21:32 EDT by Doug Dalton
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 20:34:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Trace of this failure (13.16 KB, text/plain)
2006-10-28 16:39 EDT, Jason M
no flags Details
output of lspci -vv (9.85 KB, text/plain)
2006-10-29 01:37 EST, Jason M
no flags Details
output of lspci -vvn (8.65 KB, text/plain)
2006-10-29 01:39 EST, Jason M
no flags Details

  None (edit)
Description Doug Dalton 2006-07-17 21:32:12 EDT
Description of problem:
When upgrading to kernel 2.6.17 fedora hangs on startup after printing disabling
ata, but if I use a previous kernel(2.6.16-1.2122_FC5) FC boots fine continuing
after disabling ata


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.yum update kernel
2.machine doesnt boot
3.mkinitrd -v --preload sata_promise /boot/initrd-2.6.17-1.2157_FC5.img
2.6.17-1.2157_FC5
  
4. still wont boot
5. go back to previous kernel and report bug

Actual results:


Expected results:
sata_promise driver should load

Additional info:
Not sure how to get additional debugging information but will be happy to
Comment 1 Jason M 2006-07-26 01:10:54 EDT
I have this too.  I am not sure whether it is sata_promise or libata.

As Doug above suggested, getting the output from the trace seems beyond my
skill, but I know it can be done if someone has a howto.  I'll do the camera
thing if requested.

This ONLY occurs on .17 kernels, but occurs on all 3 of them.  The FC .15 and
.16 kernels work ok.

Also, I'm having good luck with Debian's .17 kernel, though on different hardware.

One little detail:  This system is a hand-built 2 CPU AMD 32-bit system running
the SMP kernel.  It has 8 hard drives.  OK, laugh.  It's got 2 IDE interfaces, a
sata_promise card, and an LSI 320-2 (PERC4) 64-bit megaraid card.

While this is a dup of Bug 198937 I believe, the description here is more specific.
Comment 2 Jason M 2006-08-15 14:02:06 EDT
I am successfully running:

Linux 2.6.16-1.2122_FC5smp #1 SMP Sun May 21 15:18:32 EDT 2006 i686 athlon i386
GNU/Linux

In RH, yum typically 'adds' rather than 'replaces' the kernel package, and both
old and new are available from the GRUB menu.

I tried 2.6.17-1.2174_FC5smp but this problem is not fixed yet.  Do we have to
wait for the 2.6.18 kernel to come out before this is fixed?
Comment 3 Doug Dalton 2006-08-15 14:08:44 EDT
This bug was cc'ed to Joachim Selke who says he doesnt really use the driver so
it isnt important to him=and he doesnt have time to fix it??  cant this driver
be reverted to the previous working version??  or should people who use the
sata_promise driver switch to a different distrobution?
Comment 4 Joachim Selke 2006-08-15 14:22:10 EDT
Note that I am not a developer. I just added my name to the CC list of this bug
because I have an old test system that is affected by the bug.

Maybe someone should test whether this bug is still there in the current
development version of Fedora. If so, there is a much bigger chance to get some
developer look at it.
Comment 5 Jason M 2006-08-15 14:32:33 EDT
This seems to be the problem driver (except that it is the the .17 kernel
version that has the problem).

[#>modinfo sata_promise
filename:      
/lib/modules/2.6.16-1.2122_FC5smp/kernel/drivers/scsi/sata_promise.ko
author:         Jeff Garzik
description:    Promise ATA TX2/TX4/TX4000 low-level driver
license:        GPL
version:        1.03
vermagic:       2.6.16-1.2122_FC5smp SMP 686 REGPARM 4KSTACKS gcc-4.1
depends:        libata,scsi_mod
Comment 6 Jason M 2006-08-16 08:05:33 EDT
(In reply to comment #4)
> Maybe someone should test whether this bug is still there in the current
> development version of Fedora. If so, there is a much bigger chance to get some
> developer look at it.

I have done this.

Using package kernel-2.6.17-1.2566.fc6 obtained on 2006-08-15, I attempted to
boot using that kernel.

Much of what I saw looked the same as the original report.  The system locked up
the same.  But the final errors were different when it locked up; though it was
at about the same point in the boot process.  Several storage drivers seem to
load at once at this point.

Is there a race condition here?

One thing that I think is odd, this is not a hard lock.  Ctrl-Alt-Del suffices
to reboot.  Is that useful?

I took pictures, but they did not come out.  I can try again if needed.

So if it happens in the current DEVEL kernel, what does that mean?  What happens
next, and how can I help?
Comment 7 Joachim Selke 2006-08-17 11:57:58 EDT
(In reply to comment #6)
> So if it happens in the current DEVEL kernel, what does that mean?  What happens
> next, and how can I help?

Someone then should change the version field of the bug description to "devel".
I am not allowed to do this but Doug should. He is the reporter of this bug.

This of course does not guarantee that a developer looks at this bug. But at
least it is clear now that this bug is not fixed already in the most recent
kernel version.

Since the devel version of Fedora changes day by day you should try periodially
whether the bug is still there. It might happen that the bug is fixed
unwittingly some day.
Comment 8 Doug Dalton 2006-09-07 02:45:04 EDT
I noticed a similar bug in the ata3 driver on another system running fc5, I
opened this bug 2 months ago and I have only gotten emails from other users
confirming the same bug,  is anyone at fedora even looking at this issue?
Comment 9 Jason M 2006-10-20 00:49:17 EDT
Hello?  I've verified that this bug *still* occurs in the released 2.6.18 kernel
(1.2200.fc5smp).  Now I can't upgrade to FC6 until this bug is fixed; from my
point of view this is a "blocker" bug.

I really didn't want to wave my credentials around, but I am an (outrageously
highly paid) Enterprise distribution tester for both Novell and Red Hat.  I can
also be reached as jason_mack@dell.com after Tue 2006-10-24.

Just tell me what you need next, and I'll get it for you.

The bug's trace is shown clearly on the screen but is not dumped to a file
anywhere that I can see.  Let me know the technique and instructions for getting
the info, and I will.  I've tried using a digital camera to get it, but the
images are always "shaky" to the point of unreadability.

Note:  I am using the stock Red Hat kernels, these are not custom compiled.

In the meantime, here is dmesg from the known good 2.6.16 kernel.

Linux version 2.6.16-1.2122_FC5smp (bhcompile@hs20-bc1-3.build.redhat.com) (gcc
version 4.1.0 20060304 (Red Hat 4.1.0-3)) #1 SMP Sun May 21 15:18:32 EDT 2006
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009d400 (usable)
 BIOS-e820: 000000000009d400 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 00000000a0000000 (usable)
 BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
1664MB HIGHMEM available.
895MB LOWMEM available.
found SMP MP-table at 000f7e90
Using x86 segment limits to approximate NX protection
On node 0 totalpages: 655360
  DMA zone: 4096 pages, LIFO batch:0
  DMA32 zone: 0 pages, LIFO batch:0
  Normal zone: 225279 pages, LIFO batch:31
  HighMem zone: 425985 pages, LIFO batch:31
DMI 2.3 present.
Using APIC driver default
ACPI: RSDP (v000 ASUS                                  ) @ 0x000f85e0
  >>> ERROR: Invalid checksum
Intel MultiProcessor Specification v1.4
    Virtual Wire compatibility mode.
OEM ID: ASUS     Product ID: PROD00000000 APIC at: 0xFEE00000
Processor #0 6:8 APIC version 16
Processor #1 6:8 APIC version 16
I/O APIC #2 Version 17 at 0xFEC00000.
Enabling APIC mode:  Flat.  Using 1 I/O APICs
Processors: 2
Allocating PCI resources starting at a8000000 (gap: a0000000:5ec00000)
Built 1 zonelists
Kernel command line: ro root=LABEL=/ vga=771
mapped APIC to ffffd000 (fee00000)
mapped IOAPIC to ffffc000 (fec00000)
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
CPU 0 irqstacks, hard=c0421000 soft=c0401000
PID hash table entries: 4096 (order: 12, 65536 bytes)
Detected 1667.051 MHz processor.
Using tsc for high-res timesource
Console: colour dummy device 80x25
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Memory: 2587816k/2621440k available (2001k kernel code, 32320k reserved, 839k
data, 208k init, 1703940k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 3340.08 BogoMIPS (lpj=6680178)
Security Framework v1.0.0 initialized
SELinux:  Initializing.
SELinux:  Starting in permissive mode
selinux_register_security:  Registering secondary module capability
Capability LSM initialized as secondary
Mount-cache hash table entries: 512
CPU: After generic identify, caps: 0383fbff c1cbfbff 00000000 00000000 00000000
00000000 00000000
CPU: After vendor identify, caps: 0383fbff c1cbfbff 00000000 00000000 00000000
00000000 00000000
CPU: CLK_CTL MSR was 6003d22f. Reprogramming to 2003d22f
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After all inits, caps: 0383f3ff c1cbfbff 00000000 00000420 00000000
00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
Checking 'hlt' instruction... OK.
CPU0: AMD Athlon(TM) MP 2000+ stepping 01
Booting processor 1/1 eip 3000
CPU 1 irqstacks, hard=c0422000 soft=c0402000
Initializing CPU#1
Calibrating delay using timer specific routine.. 3333.85 BogoMIPS (lpj=6667715)
CPU: After generic identify, caps: 0383fbff c1cbfbff 00000000 00000000 00000000
00000000 00000000
CPU: After vendor identify, caps: 0383fbff c1cbfbff 00000000 00000000 00000000
00000000 00000000
CPU: CLK_CTL MSR was 6003d22f. Reprogramming to 2003d22f
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After all inits, caps: 0383f3ff c1cbfbff 00000000 00000420 00000000
00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#1.
CPU1: AMD Athlon(TM) MP 2000+ stepping 01
Total of 2 processors activated (6673.94 BogoMIPS).
ExtINT not setup in hardware but reported by MP table
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 apic1=0 pin1=2 apic2=0 pin2=0
checking TSC synchronization across 2 CPUs: passed.
Brought up 2 CPUs
migration_cost=1019
checking if image is initramfs... it is
Freeing initrd memory: 1019k freed
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xf1f20, last bus=2
PCI: Using configuration type 1
mtrr: your CPUs had inconsistent fixed MTRR settings
mtrr: probably your BIOS does not setup all CPUs.
mtrr: corrected configuration.
ACPI: Subsystem revision 20060127
ACPI: Interpreter disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI: disabled
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
Boot video device is 0000:01:05.0
PCI: Using IRQ router AMD768 [1022/7443] at 0000:00:07.3
PCI->APIC IRQ transform: 0000:00:08.0[A] -> IRQ 16
PCI->APIC IRQ transform: 0000:00:09.0[A] -> IRQ 17
PCI->APIC IRQ transform: 0000:01:05.0[A] -> IRQ 16
PCI->APIC IRQ transform: 0000:02:00.0[D] -> IRQ 19
PCI->APIC IRQ transform: 0000:02:04.0[A] -> IRQ 17
PCI->APIC IRQ transform: 0000:02:05.0[B] -> IRQ 19
PCI->APIC IRQ transform: 0000:02:05.1[C] -> IRQ 16
PCI->APIC IRQ transform: 0000:02:05.2[D] -> IRQ 17
PCI->APIC IRQ transform: 0000:02:05.3[A] -> IRQ 18
PCI->APIC IRQ transform: 0000:02:06.0[A] -> IRQ 17
PCI: Bridge: 0000:00:01.0
  IO window: d000-dfff
  MEM window: e6000000-e6dfffff
  PREFETCH window: e7f00000-f77fffff
PCI: Bridge: 0000:00:10.0
  IO window: a000-afff
  MEM window: e1800000-e4ffffff
  PREFETCH window: e6e00000-e6efffff
PCI: Setting latency timer of device 0000:00:01.0 to 64
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
apm: disabled - APM is not SMP safe.
audit: initializing netlink socket (disabled)
audit(1161318228.816:1): initialized
highmem bounce pool size: 64 pages
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
SELinux:  Registering netfilter hooks
Initializing Cryptographic API
ksign: Installing public key data
Loading keyring
- Added public key 43645308A4C9E5AD
- User ID: Red Hat, Inc. (Kernel Module GPG key)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
vesafb: framebuffer at 0xe8000000, mapped to 0xf8880000, using 937k, total 16384k
vesafb: mode is 800x600x8, linelength=800, pages=31
vesafb: protected mode interface info at c000:5699
vesafb: scrolling: redraw
vesafb: Pseudocolor: size=8:8:8:8, shift=0:0:0:0
Console: switching to colour frame buffer device 100x37
fb0: VESA VGA frame buffer device
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12ac
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected AMD 760MP chipset
agpgart: AGP aperture is 64M @ 0xf8000000
PNP: No PS/2 controller found. Probing ports directly.
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
AMD7441: IDE controller at PCI slot 0000:00:07.1
AMD7441: chipset revision 4
AMD7441: not 100% native mode: will probe irqs later
AMD7441: 0000:00:07.1 (rev 04) UDMA100 controller
    ide0: BM-DMA at 0xb800-0xb807, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xb808-0xb80f, BIOS settings: hdc:DMA, hdd:DMA
Probing IDE interface ide0...
hda: WDC WD400JB-00JJA0, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
hdc: WDC WD1200JB-00REA0, ATA DISK drive
hdd: WDC WD1200JB-00GVA0, ATA DISK drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: 78165360 sectors (40020 MB) w/8192KiB Cache, CHS=65535/16/63, UDMA(100)
hda: cache flushes supported
 hda: hda1 hda2 hda4 < hda5 >
hdc: max request size: 512KiB
hdc: 234441648 sectors (120034 MB) w/8192KiB Cache, CHS=16383/255/63, UDMA(100)
hdc: cache flushes supported
 hdc: hdc1
hdd: max request size: 512KiB
hdd: 234441648 sectors (120034 MB) w/8192KiB Cache, CHS=16383/255/63, UDMA(100)
hdd: cache flushes supported
 hdd: hdd1
ide-floppy driver 0.99.newide
usbcore: registered new driver libusual
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
mice: PS/2 mouse device common for all mice
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 4.39
NET: Registered protocol family 2
input: AT Translated Set 2 keyboard as /class/input/input0
IP route cache hash table entries: 131072 (order: 7, 524288 bytes)
TCP established hash table entries: 131072 (order: 9, 2621440 bytes)
TCP bind hash table entries: 65536 (order: 8, 1310720 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
TCP bic registered
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
powernow-k8: Processor cpuid 681 not supported
powernow-k8: Processor cpuid 681 not supported
Using IPI No-Shortcut mode
Freeing unused kernel memory: 208k freed
Write protecting the kernel read-only data: 365k
logips2pp: Detected unknown logitech mouse model 77
input: PS/2 Logitech Mouse as /class/input/input1
SCSI subsystem initialized
libata version 1.20 loaded.
sata_promise 0000:02:06.0: version 1.03
sata_promise PATA port found
ata1: SATA max UDMA/133 cmd 0xF883A200 ctl 0xF883A238 bmdma 0x0 irq 17
ata2: SATA max UDMA/133 cmd 0xF883A280 ctl 0xF883A2B8 bmdma 0x0 irq 17
ata3: PATA max UDMA/133 cmd 0xF883A300 ctl 0xF883A338 bmdma 0x0 irq 17
ata1: SATA link up 1.5 Gbps (SStatus 113)
ata1: dev 0 cfg 49:2f00 82:706b 83:7e01 84:4023 85:7069 86:3c01 87:4023 88:407f
ata1: dev 0 ATA-7, max UDMA/133, 312581808 sectors: LBA48
ata1: dev 0 configured for UDMA/133
scsi0 : sata_promise
ata2: SATA link up 1.5 Gbps (SStatus 113)
ata2: dev 0 cfg 49:2f00 82:706b 83:7e01 84:4023 85:7069 86:3c01 87:4023 88:407f
ata2: dev 0 ATA-7, max UDMA/133, 312581808 sectors: LBA48
ata2: dev 0 configured for UDMA/133
scsi1 : sata_promise
ATA: abnormal status 0x8 on port 0xF883A31C
ata3: disabling port
scsi2 : sata_promise
  Vendor: ATA       Model: WDC WD1600JS-00M  Rev: 02.0
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sda: 312581808 512-byte hdwr sectors (160042 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
SCSI device sda: 312581808 512-byte hdwr sectors (160042 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: drive cache: write back
 sda: sda1 sda2
sd 0:0:0:0: Attached scsi disk sda
  Vendor: ATA       Model: WDC WD1600JS-00M  Rev: 02.0
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sdb: 312581808 512-byte hdwr sectors (160042 MB)
sdb: Write Protect is off
sdb: Mode Sense: 00 3a 00 00
SCSI device sdb: drive cache: write back
SCSI device sdb: 312581808 512-byte hdwr sectors (160042 MB)
sdb: Write Protect is off
sdb: Mode Sense: 00 3a 00 00
SCSI device sdb: drive cache: write back
 sdb: sdb1 sdb2
sd 1:0:0:0: Attached scsi disk sdb
megaraid cmm: 2.20.2.6 (Release Date: Mon Mar 7 00:01:03 EST 2005)
megaraid: 2.20.4.7 (Release Date: Mon Nov 14 12:27:22 EST 2005)
megaraid: probe new device 0x1000:0x1960:0x1000:0x0518: bus 0:slot 9:func 0
megaraid: fw version:[1L37] bios version:[G119]
scsi3 : LSI Logic MegaRAID driver
scsi[3]: scanning scsi channel 0 [Phy 0] for non-raid devices
scsi[3]: scanning scsi channel 1 [Phy 1] for non-raid devices
scsi[3]: scanning scsi channel 2 [virtual] for logical drives
  Vendor: MegaRAID  Model: LD0 RAID5 70004R  Rev: 1L37
  Type:   Direct-Access                      ANSI SCSI revision: 02
SCSI device sdc: 143368192 512-byte hdwr sectors (73405 MB)
sdc: Write Protect is off
sdc: Mode Sense: 00 00 00 00
sdc: asking for cache data failed
sdc: assuming drive cache: write through
SCSI device sdc: 143368192 512-byte hdwr sectors (73405 MB)
sdc: Write Protect is off
sdc: Mode Sense: 00 00 00 00
sdc: asking for cache data failed
sdc: assuming drive cache: write through
 sdc: sdc1 sdc2 sdc3 sdc4 < sdc5 >
sd 3:2:0:0: Attached scsi disk sdc
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
SELinux:  Disabled at runtime.
SELinux:  Unregistering netfilter hooks
Intel(R) PRO/1000 Network Driver - version 6.3.9-k4-NAPI
Copyright (c) 1999-2005 Intel Corporation.
e1000: 0000:00:08.0: e1000_probe: (PCI:66MHz:64-bit) 00:02:b3:ef:4b:ec
MC: drivers/edac/edac_mc.c version edac_mc  Ver: 2.0.0 May 21 2006
hw_random: AMD768 system management I/O registers at 0xE400.
hw_random hardware driver 1.0.0 loaded
e1000: eth0: e1000_probe: Intel(R) PRO/1000 Network Connection
ohci_hcd: 2005 April 22 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ohci_hcd 0000:02:00.0: OHCI Host Controller
ohci_hcd 0000:02:00.0: new USB bus registered, assigned bus number 1
ohci_hcd 0000:02:00.0: irq 19, io mem 0xe4800000
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 4 ports detected
sd 0:0:0:0: Attached scsi generic sg0 type 0
sd 1:0:0:0: Attached scsi generic sg1 type 0
sd 3:2:0:0: Attached scsi generic sg2 type 0
ohci_hcd 0000:02:05.0: OHCI Host Controller
ohci_hcd 0000:02:05.0: new USB bus registered, assigned bus number 2
ohci_hcd 0000:02:05.0: irq 19, io mem 0xe4000000
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ohci_hcd 0000:02:05.1: OHCI Host Controller
ohci_hcd 0000:02:05.1: new USB bus registered, assigned bus number 3
ohci_hcd 0000:02:05.1: irq 16, io mem 0xe3800000
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
usb 1-3: new full speed USB device using ohci_hcd and address 2
ohci_hcd 0000:02:05.2: OHCI Host Controller
ohci_hcd 0000:02:05.2: new USB bus registered, assigned bus number 4
ohci_hcd 0000:02:05.2: irq 17, io mem 0xe3000000
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
usb 1-3: configuration #1 chosen from 1 choice
ehci_hcd 0000:02:05.3: EHCI Host Controller
ehci_hcd 0000:02:05.3: debug port 1
Initializing USB Mass Storage driver...
ehci_hcd 0000:02:05.3: new USB bus registered, assigned bus number 5
ehci_hcd 0000:02:05.3: irq 18, io mem 0xe2800000
ehci_hcd 0000:02:05.3: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb5: configuration #1 chosen from 1 choice
hub 5-0:1.0: USB hub found
hub 5-0:1.0: 6 ports detected
scsi4 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
Non-volatile memory driver v1.2
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
lp: driver loaded but no devices found
usb 3-1: new low speed USB device using ohci_hcd and address 2
usb 3-1: configuration #1 chosen from 1 choice
md: Autodetecting RAID arrays.
md: autorun ...
md: considering sdb2 ...
md:  adding sdb2 ...
md: sdb1 has different UUID to sdb2
md:  adding sda2 ...
md: sda1 has different UUID to sdb2
md: hdd1 has different UUID to sdb2
md: hdc1 has different UUID to sdb2
md: created md1
md: bind<sda2>
md: bind<sdb2>
md: running: <sdb2><sda2>
md: raid0 personality registered for level 0
md1: setting max_sectors to 128, segment boundary to 32767
raid0: looking at sdb2
raid0:   comparing sdb2(39070016) with sdb2(39070016)
raid0:   END
raid0:   ==> UNIQUE
raid0: 1 zones
raid0: looking at sda2
raid0:   comparing sda2(39070016) with sdb2(39070016)
raid0:   EQUAL
raid0: FINAL 1 zones
raid0: done.
raid0 : md_size is 78140032 blocks.
raid0 : conf->hash_spacing is 78140032 blocks.
raid0 : nb_zone is 1.
raid0 : Allocating 4 bytes for hash.
md: considering sdb1 ...
md:  adding sdb1 ...
md:  adding sda1 ...
md:  adding hdd1 ...
md:  adding hdc1 ...
md: created md0
md: bind<hdc1>
md: bind<hdd1>
md: bind<sda1>
md: bind<sdb1>
md: running: <sdb1><sda1><hdd1><hdc1>
md: raid10 personality registered for level 10
raid10: raid set md0 active with 4 out of 4 devices
md: ... autorun DONE.
device-mapper: 4.5.0-ioctl (2005-10-04) initialised: dm-devel@redhat.com
device-mapper: dm-multipath version 1.0.4 loaded
program dmraid is using a deprecated SCSI ioctl, please convert it to SG_IO
hiddev96: USB HID v1.10 Device [American Power Conversion Back-UPS BR  800
FW:9.o2 .D USB FW:o2 ] on usb-0000:02:05.1-1
EXT3 FS on sdc3, internal journal
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sdc5, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
EXT3 FS on md1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on md0, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
EXT3 FS on hda5, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
Adding 1839400k swap on /dev/sdc1.  Priority:-1 extents:1 across:1839400k
Adding 265064k swap on /dev/sdc2.  Priority:-2 extents:1 across:265064k
Comment 10 Jason M 2006-10-28 16:39:58 EDT
Created attachment 139651 [details]
Trace of this failure

Trace captured.  This is the kernel BUG Oops output captured via serial port
for 2.6.18-1.2200.fc5.	Note this is the UP kernel, I can also get SMP kernel
output if needed.

Special thanks to Fedora Board member Matt Domsch for lending guidance and a
cable.
Comment 11 Matt Domsch 2006-10-29 00:15:50 EDT
Lovely.

static u32 pdc_sata_scr_read (struct ata_port *ap, unsigned int sc_reg)
{
        if (sc_reg > SCR_CONTROL)
                return 0xffffffffU;
        return readl((void __iomem *) ap->ioaddr.scr_addr + (sc_reg * 4));
}

sc_reg = SCR_CONTROL = 2, so ap->ioaddr.scr_addr must be zero for us to
dereference NULL+8.  Why isn't scr_addr set here yet?
Comment 12 Matt Domsch 2006-10-29 00:29:31 EDT
Jason or someone, please attach an lspci -vv and lspci -vvn so we know which
cards this is.

I suspect the "disabling port" message is the culprit, coming from
ata_bus_reset().  This is a 3-or-more port card, but ap->ioaddr.scr_addr didn't
get set in pdc_ata_init_one() for it...
Comment 13 Jason M 2006-10-29 01:37:52 EST
Created attachment 139658 [details]
output of lspci -vv

It might be important for me to note that my Promise card has a SATA drive
attached to each SATA port, but that the IDE controller is not actually being
used.

lspci -vvn follows.
Comment 14 Jason M 2006-10-29 01:39:07 EST
Created attachment 139659 [details]
output of lspci -vvn
Comment 15 Jason Mack 2006-11-14 20:34:16 EST

*** This bug has been marked as a duplicate of 199142 ***

Note You need to log in before you can comment on or make changes to this bug.