Bug 199243 - piranha "edit monitoring scripts" removes slashes
piranha "edit monitoring scripts" removes slashes
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: piranha (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Grac
Cluster QE
:
: 220764 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-18 07:29 EDT by Rainer Canavan
Modified: 2009-04-24 21:18 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0794
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 15:08:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rainer Canavan 2006-07-18 07:29:21 EDT
Description of problem:
virtual_edit_services.php unneccesarily uses  stripslashes, and therefore
reduces e.g. HTTP/1.0\r\n\r\n to HTTP/1.0rnrn

Version-Release number of selected component (if applicable):
piranha-0.8.2-1

How reproducible:
set Send string to "GET /test.fit HTTP/1.0\r\n\r\n"
and accept.
Comment 1 Stanko Kupcevic 2006-07-18 09:44:00 EDT
Ownership taken
Comment 4 Stanko Kupcevic 2006-11-15 15:13:42 EST
Patch in -HEAD
Comment 5 Stanko Kupcevic 2007-01-04 12:02:21 EST
*** Bug 220764 has been marked as a duplicate of this bug. ***
Comment 7 Wade Mealing 2007-07-23 03:24:04 EDT
Marek,

Is this bug in the right place ? Much of the cluster suite tools seem to have
been moved to the RHEL category.
Comment 12 errata-xmlrpc 2008-07-25 15:08:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0794.html
Comment 13 Rainer Canavan 2008-07-28 06:28:04 EDT
The description claims that "GUI would remove trailing slashes", while in fact,
it removes backslashes. http://php.net/manual/en/function.stripslashes.php

Note You need to log in before you can comment on or make changes to this bug.