Bug 199470 - lockdep: BUG: warning at kernel/lockdep.c:1803/trace_hardirqs_on() (Not tainted)
Summary: lockdep: BUG: warning at kernel/lockdep.c:1803/trace_hardirqs_on() (Not tainted)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: Reopened
: 202055 (view as bug list)
Depends On:
Blocks: FCMETA_LOCKDEP
TreeView+ depends on / blocked
 
Reported: 2006-07-19 18:49 UTC by Jurgen Kramer
Modified: 2015-01-04 22:28 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 23:11:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full dmesg ouput (31.28 KB, text/plain)
2006-07-19 18:49 UTC, Jurgen Kramer
no flags Details

Description Jurgen Kramer 2006-07-19 18:49:37 UTC
Description of problem:
Booting the system shows a lockdep issue

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2416.fc6

How reproducible:
always

Steps to Reproduce:
1. Boot system
2.
3.
  
Actual results:
BUG: warning at kernel/lockdep.c:1803/trace_hardirqs_on() (Not tainted)
 [<c04051e1>] show_trace_log_lvl+0x54/0xfd
 [<c040579d>] show_trace+0xd/0x10
 [<c04058b6>] dump_stack+0x19/0x1b
 [<c043a624>] trace_hardirqs_on+0xa2/0x11e
 [<c0606573>] _spin_unlock_irq+0x22/0x26
 [<c05383b4>] rtc_get_rtc_time+0x32/0x176
 [<c0419830>] hpet_rtc_interrupt+0x92/0x14d
 [<c044f650>] handle_IRQ_event+0x20/0x4d
 [<c044f711>] __do_IRQ+0x94/0xef
 [<c0406744>] do_IRQ+0xb9/0xcd
 [<c0404a49>] common_interrupt+0x25/0x2c


Expected results:
No lockdep issues

Additional info:
This is on a MacBook

Comment 1 Jurgen Kramer 2006-07-19 18:49:37 UTC
Created attachment 132703 [details]
full dmesg ouput

Comment 2 Wade Mealing 2006-07-23 09:33:04 UTC
Getting the same thing.

uname -a
Linux localhost.localdomain 2.6.17-1.2405.fc6PAE #1 SMP Sun Jul 16 00:56:07 EDT
2006 i686 i686 i386 GNU/Linux

Also a macbook.

Comment 3 Jurgen Kramer 2006-07-23 10:47:06 UTC
lockdep issue is still there with 2.6.17-1.2432.fc6

Comment 4 Jurgen Kramer 2006-07-23 15:17:32 UTC
Unfortunately still there with 2.6.17-1.2437 as well.


Comment 5 cq92j9y+rlkr0w 2006-07-24 06:28:33 UTC
I'm getting the same error with kernel 2.6.17-1.2437. I'm *not* using a mac.

Comment 6 cq92j9y+rlkr0w 2006-07-25 04:19:54 UTC
still there with 2.6.17-1.2439.fc6

Comment 7 Jurgen Kramer 2006-07-28 17:26:28 UTC
2.6.17-1.2462.fc6, still there. As is the cpufreq lockdep problem as discussed
on LKML.

Lukewarm IQ detected in hotplug locking
BUG: warning at kernel/cpu.c:38/lock_cpu_hotplug() (Not tainted)
 [<c04051ea>] show_trace_log_lvl+0x54/0xfd
 [<c04057a6>] show_trace+0xd/0x10
 [<c04058bf>] dump_stack+0x19/0x1b
 [<c043f2d3>] lock_cpu_hotplug+0x49/0x6f
 [<c04338e3>] __create_workqueue+0x52/0x116
 [<f8bc934b>] cpufreq_governor_dbs+0x9f/0x2c3 [cpufreq_ondemand]
 [<c05a1e8f>] __cpufreq_governor+0x57/0xd8
 [<c05a204d>] __cpufreq_set_policy+0x13d/0x1a9
 [<c05a225f>] store_scaling_governor+0x12d/0x15b
 [<c05a18e0>] store+0x37/0x48
 [<c04a8db4>] sysfs_write_file+0xab/0xd1
 [<c0471ffb>] vfs_write+0xab/0x157
 [<c0472640>] sys_write+0x3b/0x60
 [<c0403faf>] syscall_call+0x7/0xb


Comment 8 Kjartan Maraas 2006-08-01 11:14:38 UTC
I'm seeing this too with 2.6.17-1.2462.fc6. This is a HP Compaq nc4010 laptop.

Comment 9 Jurgen Kramer 2006-08-02 19:06:40 UTC
Should this bug be fixed with 2.6.17-1.2505.fc6? (there are lockdep fixes in
this version).

BUG: warning at kernel/lockdep.c:1803/trace_hardirqs_on() (Not tainted)
 [<c04051ee>] show_trace_log_lvl+0x58/0x159
 [<c04057ea>] show_trace+0xd/0x10
 [<c0405903>] dump_stack+0x19/0x1b
 [<c043ab30>] trace_hardirqs_on+0xa2/0x11e
 [<c0608e7b>] _spin_unlock_irq+0x22/0x26
 [<c0539a4c>] rtc_get_rtc_time+0x32/0x176
 [<c0419b9c>] hpet_rtc_interrupt+0x92/0x14d
 [<c045015c>] handle_IRQ_event+0x20/0x4d
 [<c045021d>] __do_IRQ+0x94/0xef
 [<c0406790>] do_IRQ+0xb9/0xcd
 [<c0404a49>] common_interrupt+0x25/0x2c
DWARF2 unwinder stuck at common_interrupt+0x25/0x2c
Leftover inexact backtrace:
 [<c04057ea>] show_trace+0xd/0x10
 [<c0405903>] dump_stack+0x19/0x1b
 [<c043ab30>] trace_hardirqs_on+0xa2/0x11e
 [<c0608e7b>] _spin_unlock_irq+0x22/0x26
 [<c0539a4c>] rtc_get_rtc_time+0x32/0x176
 [<c0419b9c>] hpet_rtc_interrupt+0x92/0x14d
 [<c045015c>] handle_IRQ_event+0x20/0x4d
 [<c045021d>] __do_IRQ+0x94/0xef
 [<c0406790>] do_IRQ+0xb9/0xcd
 [<c0404a49>] common_interrupt+0x25/0x2c

This one was expected:
Lukewarm IQ detected in hotplug locking
BUG: warning at kernel/cpu.c:43/lock_cpu_hotplug() (Not tainted)
 [<c04051ee>] show_trace_log_lvl+0x58/0x159
 [<c04057ea>] show_trace+0xd/0x10
 [<c0405903>] dump_stack+0x19/0x1b
 [<c043f639>] lock_cpu_hotplug+0x49/0x6f
 [<c04338e7>] __create_workqueue+0x52/0x116
 [<f8be834b>] cpufreq_governor_dbs+0x9f/0x2c3 [cpufreq_ondemand]
 [<c05a249f>] __cpufreq_governor+0x57/0xd8
 [<c05a265d>] __cpufreq_set_policy+0x13d/0x1a9
 [<c05a286f>] store_scaling_governor+0x12d/0x15b
 [<c05a1ef0>] store+0x37/0x48
 [<c04a9358>] sysfs_write_file+0xab/0xd1
 [<c0472637>] vfs_write+0xab/0x157
 [<c0472c7c>] sys_write+0x3b/0x60
 [<c0403faf>] syscall_call+0x7/0xb
DWARF2 unwinder stuck at syscall_call+0x7/0xb
Leftover inexact backtrace:
 [<c04057ea>] show_trace+0xd/0x10
 [<c0405903>] dump_stack+0x19/0x1b
 [<c043f639>] lock_cpu_hotplug+0x49/0x6f
 [<c04338e7>] __create_workqueue+0x52/0x116
 [<f8be834b>] cpufreq_governor_dbs+0x9f/0x2c3 [cpufreq_ondemand]
 [<c05a249f>] __cpufreq_governor+0x57/0xd8
 [<c05a265d>] __cpufreq_set_policy+0x13d/0x1a9
 [<c05a286f>] store_scaling_governor+0x12d/0x15b
 [<c05a1ef0>] store+0x37/0x48
 [<c04a9358>] sysfs_write_file+0xab/0xd1
 [<c0472637>] vfs_write+0xab/0x157
 [<c0472c7c>] sys_write+0x3b/0x60
 [<c0403faf>] syscall_call+0x7/0xb


Comment 10 Jurgen Kramer 2006-08-04 18:54:31 UTC
Still with us with 2.6.17-1.2517.fc6

BUG: warning at kernel/lockdep.c:1803/trace_hardirqs_on() (Not tainted)
 [<c04051ee>] show_trace_log_lvl+0x58/0x159
 [<c04057ea>] show_trace+0xd/0x10
 [<c0405903>] dump_stack+0x19/0x1b
 [<c043ab30>] trace_hardirqs_on+0xa2/0x11e
 [<c0608e8b>] _spin_unlock_irq+0x22/0x26
 [<c0539a04>] rtc_get_rtc_time+0x32/0x176
 [<c0419b9c>] hpet_rtc_interrupt+0x92/0x14d
 [<c045015c>] handle_IRQ_event+0x20/0x4d
 [<c045021d>] __do_IRQ+0x94/0xef
 [<c0406790>] do_IRQ+0xb9/0xcd
 [<c0404a49>] common_interrupt+0x25/0x2c
DWARF2 unwinder stuck at common_interrupt+0x25/0x2c
Leftover inexact backtrace:
 [<c04057ea>] show_trace+0xd/0x10
 [<c0405903>] dump_stack+0x19/0x1b
 [<c043ab30>] trace_hardirqs_on+0xa2/0x11e
 [<c0608e8b>] _spin_unlock_irq+0x22/0x26
 [<c0539a04>] rtc_get_rtc_time+0x32/0x176
 [<c0419b9c>] hpet_rtc_interrupt+0x92/0x14d
 [<c045015c>] handle_IRQ_event+0x20/0x4d
 [<c045021d>] __do_IRQ+0x94/0xef
 [<c0406790>] do_IRQ+0xb9/0xcd
 [<c0404a49>] common_interrupt+0x25/0x2c
 [<c0483b88>] sys_select+0x93/0x167
 [<c0403faf>] syscall_call+0x7/0xb


Comment 11 Dave Jones 2006-08-11 00:33:51 UTC
*** Bug 202055 has been marked as a duplicate of this bug. ***

Comment 12 Arjan van de Ven 2006-08-11 01:46:37 UTC
this should have been fixed in 2.6.18-rc4
not shure which rawhide version number corresponds to that

Comment 13 Dave Jones 2006-08-11 05:32:36 UTC
2.6.17-1.2517.fc6 which is the newest kernel reported above was rc3 based, so
this should be fixed in current builds.
 

Comment 14 Jurgen Kramer 2006-08-11 07:41:37 UTC
No so fast! The bug is still there with 2.6.17-1.2543.fc6

BUG: warning at kernel/lockdep.c:1803/trace_hardirqs_on() (Not tainted)
 [<c04051ee>] show_trace_log_lvl+0x58/0x159
 [<c04057ea>] show_trace+0xd/0x10
 [<c0405903>] dump_stack+0x19/0x1b
 [<c043ab64>] trace_hardirqs_on+0xa2/0x11e
 [<c0613a8b>] _spin_unlock_irq+0x22/0x26
 [<c0540f0c>] rtc_get_rtc_time+0x32/0x176
 [<c0419ba0>] hpet_rtc_interrupt+0x92/0x14d
 [<c0450e2c>] handle_IRQ_event+0x20/0x4d
 [<c0450eed>] __do_IRQ+0x94/0xef
 [<c0406790>] do_IRQ+0xb9/0xcd
 [<c0404a49>] common_interrupt+0x25/0x2c
DWARF2 unwinder stuck at common_interrupt+0x25/0x2c
Leftover inexact backtrace:
 [<c04057ea>] show_trace+0xd/0x10
 [<c0405903>] dump_stack+0x19/0x1b
 [<c043ab64>] trace_hardirqs_on+0xa2/0x11e
 [<c0613a8b>] _spin_unlock_irq+0x22/0x26
 [<c0540f0c>] rtc_get_rtc_time+0x32/0x176
 [<c0419ba0>] hpet_rtc_interrupt+0x92/0x14d
 [<c0450e2c>] handle_IRQ_event+0x20/0x4d
 [<c0450eed>] __do_IRQ+0x94/0xef
 [<c0406790>] do_IRQ+0xb9/0xcd
 [<c0404a49>] common_interrupt+0x25/0x2c
 [<c04ebd2f>] copy_from_user+0x4e/0x71
 [<c048480a>] sys_select+0x31/0x167
 [<c0403faf>] syscall_call+0x7/0xb


Comment 15 Jurgen Kramer 2006-08-11 19:41:53 UTC
Still with us with 2.6.17-1.2548.fc6


Comment 16 Konstantin Ryabitsev 2006-08-12 00:04:05 UTC
Seeing this, too. Sorry, Dave. :)

Comment 17 Jurgen Kramer 2006-08-18 12:09:27 UTC
Just for the record, the bug is still there with 2.6.17-1.2571.fc6

Comment 18 Jurgen Kramer 2006-08-28 18:22:14 UTC
Unfortunately still there with 2.6.17-1.2586.fc6

Comment 19 Jurgen Kramer 2006-09-09 15:59:07 UTC
Still there with 2.6.17-1.2630, only now the backtrace is missing:

BUG: warning at kernel/lockdep.c:1816/trace_hardirqs_on() (Not tainted)
 [<c04051ee>] show_trace_log_lvl+0x58/0x171
 [<c0405802>] show_trace+0xd/0x10
 [<c040591b>] dump_stack+0x19/0x1b
 [<c043abee>] trace_hardirqs_on+0xa2/0x11e
 [<c06143c3>] _spin_unlock_irq+0x22/0x26
 [<c0541540>] rtc_get_rtc_time+0x32/0x176
 [<c0419ba4>] hpet_rtc_interrupt+0x92/0x14d
 [<c0450f94>] handle_IRQ_event+0x20/0x4d
 [<c0451055>] __do_IRQ+0x94/0xef
 [<c040678d>] do_IRQ+0x9e/0xbd
 [<c0404a49>] common_interrupt+0x25/0x2c
DWARF2 unwinder stuck at common_interrupt+0x25/0x2c
Leftover inexact backtrace:


Comment 20 Jurgen Kramer 2006-09-19 19:48:35 UTC
2.6.17-1.2647.fc6 #1 SMP:

BUG: warning at kernel/lockdep.c:1816/trace_hardirqs_on() (Not tainted)
 [<c04051ee>] show_trace_log_lvl+0x58/0x171
 [<c0405802>] show_trace+0xd/0x10
 [<c040591b>] dump_stack+0x19/0x1b
 [<c043acba>] trace_hardirqs_on+0xa2/0x11e
 [<c0615603>] _spin_unlock_irq+0x22/0x26
 [<c0541778>] rtc_get_rtc_time+0x32/0x176
 [<c0419ba4>] hpet_rtc_interrupt+0x92/0x14d
 [<c04511b4>] handle_IRQ_event+0x20/0x4d
 [<c0451275>] __do_IRQ+0x94/0xef
 [<c040678d>] do_IRQ+0x9e/0xbd
 [<c0404a49>] common_interrupt+0x25/0x2c
DWARF2 unwinder stuck at common_interrupt+0x25/0x2c
Leftover inexact backtrace:
usbcore: registered new driver appletouch


Comment 21 Peter Zijlstra 2006-09-26 13:07:34 UTC
dave this looks like a dup of BZ206786, or vice versa ofcourse ;-)

Comment 22 Jurgen Kramer 2006-09-30 14:56:32 UTC
Not seeing this anymore with 2.6.18-1.2708 :)


Note You need to log in before you can comment on or make changes to this bug.