This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 199473 - debugedit "Unhandled relocation" errors on ppc
debugedit "Unhandled relocation" errors on ppc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks: 199487
  Show dependency treegraph
 
Reported: 2006-07-19 15:11 EDT by Roland McGrath
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 15:51:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
simple patch for debugedit.c braino (356 bytes, patch)
2006-07-19 15:11 EDT, Roland McGrath
no flags Details | Diff

  None (edit)
Description Roland McGrath 2006-07-19 15:11:19 EDT
Description of problem:

The debugedit program fails to recognize relocs in debug info that it can fix up
on ppc.

Version-Release number of selected component (if applicable):

rpm-4.4.2, and looks like all rpm-4.3 and later.

How reproducible:

100%
Steps to Reproduce:
1. do a kernel rpm build on ppc
2. see errors
3. marvel that noone noticed in all these years
  
Actual results:

Lots of errors like this one:

/usr/lib/rpm/debugedit:
/var/tmp/kernel-2.6.17-1.2419.fc6-root/lib/modules/2.6.17-1.2419.fc6smp/kernel/net/ipv6/ipv6.ko:
Unhandled relocation 1 in .debug_info section

Expected results:

It should be able to handle that reloc type.

Additional info:

This looks like a simple braino/typo in the ppc part of the original reloc-fixup
patch to debugedit.  I'll attach the trivial patch to fix it.
Comment 1 Roland McGrath 2006-07-19 15:11:19 EDT
Created attachment 132704 [details]
simple patch for debugedit.c braino

Note You need to log in before you can comment on or make changes to this bug.