Bug 199503 - nc not honoring '-w' timeout values
nc not honoring '-w' timeout values
Status: CLOSED DUPLICATE of bug 182736
Product: Fedora
Classification: Fedora
Component: nc (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2006-07-19 19:12 EDT by Stuart J. Browne
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-20 03:06:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stuart J. Browne 2006-07-19 19:12:00 EDT
Description of problem:

'nc' doesn't honor the '-w <val>' argument for timing out connection failures

Version-Release number of selected component (if applicable):

1.82-fc4.1, 1.84-3.2 (FC5 source recompiled onto FC4)

How reproducible:

Every time.

Steps to Reproduce:

Create a DROP firewall on a test machine for a port.

1. nc -w 2 <test machine> <dropped port>
Actual results:

Command hangs until TCP connect timeout

Expected results:

Previous versions of nc (in particular 1.10), and documentation and help state 
that 'Timeout for connects and final net reads'.  It is not exiting or timing 
out after the defined '-w' period of seconds if the connection attempt hangs 
(as when a machine is under load, or trying to connect to a dropped port).

Additional info:
Comment 1 Radek Vokal 2006-07-20 03:06:09 EDT
Already fixed in rawhide 1.84-4

*** This bug has been marked as a duplicate of 182736 ***

Note You need to log in before you can comment on or make changes to this bug.