Bug 199547 - history is NOT updated while changing tables from scim-setup
history is NOT updated while changing tables from scim-setup
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: SCIM
  Show dependency treegraph
 
Reported: 2006-07-20 06:01 EDT by A S Alam
Modified: 2013-07-02 20:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-31 23:13:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image showing HISTORY (71.85 KB, image/png)
2006-07-25 09:26 EDT, A S Alam
no flags Details

  None (edit)
Description A S Alam 2006-07-20 06:01:31 EDT
Description of problem:
while Add/remove tables from scim-setup and run 'scim-setup' command, then
table is Add/removed from scim-menu, but History Above the menu is not update
ex:

Version-Release number of selected component (if applicable):


How reproducible:
scim-1.4.4-24.fc6
scim-bridge-gtkimm-0.2.4-1.1.fc6

Steps to Reproduce:
1. select scim table (Hindi-inscipt) (so that it added to history)
2.  start typing 
3. open scim-setup
4. uncheck a table (Hindi-inscript)
5. Apply and scim-restart
  
Actual results:
table is present in History, but also you can select and type with Hindi-inscript

Expected results:
table should Remove from History as table is removed from History

Additional info:
Comment 1 Jens Petersen 2006-07-25 07:23:36 EDT
What do you mean by "history"?
Comment 2 A S Alam 2006-07-25 09:26:27 EDT
Created attachment 132980 [details]
Image showing HISTORY
Comment 3 Jens Petersen 2006-07-31 23:13:40 EDT
I think this not a bug of the "history" (aka recently used IMEs list) but
a limitation of current scim: basically it needs to be restarted for
the currently installed IMEs to be correctly reflected in the menu.
I think once scim looks an IME module it keep it in memory.
I expect this to improve in scim2.

Note You need to log in before you can comment on or make changes to this bug.