Bug 199568 - installation crashed while formatting swap space
installation crashed while formatting swap space
Status: CLOSED DUPLICATE of bug 201773
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-20 09:44 EDT by Ingo Schaefer
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-17 01:54:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ingo Schaefer 2006-07-20 09:44:28 EDT
Description of problem:
Installation broke during formatting of the swap space

Version-Release number of selected component (if applicable):
fc6 devel rescue cd dated 2006/07/17

How reproducible:
just tried one time, doing the same things with fc5 rescue worked

Steps to Reproduce:
1. start text mode installation
2. create swap partitions
3. choose packages
  
Actual results:
Message: "formatting swap was not successful, installation cancelled."

Expected results:
It should of course install correctly

Additional info:
Debug output from tty4: (all I could see on the screen)
<4> but task is already holding lock.
<4>   (&bdev->bd_mutex){--..}, at: [<c0464486>] do_open+0x6b/0x3b2
<4>
<4> other info that might us debug this:
<4> 1 lock held by anaconda/452
<4>   #0 (&bdev->bd_mutex){--..}, at: [<c0464486>] do_open+0x6b/0x3b2
<4> stack backtrace
<4> show_trace_log_lvl
<4> show_trace
<4> dump_stack
<4> __lock_acquire
<4> mutex_lock_nested
<4> __blkdev_put
<4> do_open
<4> blkdev_open
<4> __dentry_open
<4> nameidata_to_filp
<4> do_filp_open
<4> do_sys_open
<4> sys_open
<4> syscall_call
Comment 1 Ingo Schaefer 2006-07-20 16:13:38 EDT
I just want to clarify, that the system (=kernel) was responding all the time.
So "installation crashed" was maybe a bit mitleading. Installation could not be
finished after this bug would be a better description - sorry.

Jeremy, if you really think this is kernel, keep it assigned to kernel. I
thought, it was anaconda stuff, because anaconda held the lock.

Regards,
Ingo

PS: One idea: I forgot to add swap space and the installation program asked me
if I really want to proceed without swap. I said: "No" and corrected the
partitioning. Maybe this had an effekt?
Comment 2 Dave Jones 2006-09-17 01:54:03 EDT

*** This bug has been marked as a duplicate of 201773 ***

Note You need to log in before you can comment on or make changes to this bug.