Bug 201773 - INFO: possible recursive locking detected (bdev->bd_mutex)
INFO: possible recursive locking detected (bdev->bd_mutex)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Zijlstra
Brian Brock
:
: 199568 203137 (view as bug list)
Depends On:
Blocks: FCMETA_LOCKDEP 208290
  Show dependency treegraph
 
Reported: 2006-08-08 15:45 EDT by Orion Poplawski
Modified: 2014-08-11 01:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 19:25:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full syslog from install (18.42 KB, text/plain)
2006-08-08 15:45 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2006-08-08 15:45:40 EDT
Description of problem:

From syslog during FC6T2 PXE/kickstart/NFS install:


<4>=============================================
<4>[ INFO: possible recursive locking detected ]
<4>---------------------------------------------
<4>anaconda/441 is trying to acquire lock:
<4> (&bdev->bd_mutex){--..}, at: [<c0464aeb>] __blkdev_put+0x1f/0x11f
<4>
<4>but task is already holding lock:
<4> (&bdev->bd_mutex){--..}, at: [<c0464d7e>] do_open+0x6b/0x3b2
<4>
<4>other info that might help us debug this:
<4>1 lock held by anaconda/441:
<4> #0:  (&bdev->bd_mutex){--..}, at: [<c0464d7e>] do_open+0x6b/0x3b2
<4>
<4>stack backtrace:
<4> [<c04037db>] show_trace_log_lvl+0x58/0x159
<4> [<c0403d9e>] show_trace+0xd/0x10
<4> [<c0403e3b>] dump_stack+0x19/0x1b
<4> [<c042bd47>] __lock_acquire+0x760/0x987
<4> [<c042c4df>] lock_acquire+0x4b/0x6c
<4> [<c05e8a16>] mutex_lock_nested+0xcb/0x214
<4> [<c0464aeb>] __blkdev_put+0x1f/0x11f
<4> [<c0464c04>] blkdev_put+0xa/0xc
<4> [<c0465056>] do_open+0x343/0x3b2
<4> [<c0465260>] blkdev_open+0x1f/0x48
<4> [<c045ca88>] __dentry_open+0xb8/0x186
<4> [<c045cbc4>] nameidata_to_filp+0x1c/0x2e
<4> [<c045cc05>] do_filp_open+0x2f/0x36
<4> [<c045cc4c>] do_sys_open+0x40/0xbb
<4> [<c045ccf3>] sys_open+0x16/0x18
<4> [<c0402e57>] syscall_call+0x7/0xb
<4>DWARF2 unwinder stuck at syscall_call+0x7/0xb
<4>Leftover inexact backtrace:
<4> [<c0403d9e>] show_trace+0xd/0x10
<4> [<c0403e3b>] dump_stack+0x19/0x1b
<4> [<c042bd47>] __lock_acquire+0x760/0x987
<4> [<c042c4df>] lock_acquire+0x4b/0x6c
<4> [<c05e8a16>] mutex_lock_nested+0xcb/0x214
<4> [<c0464aeb>] __blkdev_put+0x1f/0x11f
<4> [<c0464c04>] blkdev_put+0xa/0xc
<4> [<c0465056>] do_open+0x343/0x3b2
<4> [<c0465260>] blkdev_open+0x1f/0x48
<4> [<c045ca88>] __dentry_open+0xb8/0x186
<4> [<c045cbc4>] nameidata_to_filp+0x1c/0x2e
<4> [<c045cc05>] do_filp_open+0x2f/0x36
<4> [<c045cc4c>] do_sys_open+0x40/0xbb
<4> [<c045ccf3>] sys_open+0x16/0x18
<4> [<c0402e57>] syscall_call+0x7/0xb
Comment 1 Orion Poplawski 2006-08-08 15:45:41 EDT
Created attachment 133826 [details]
Full syslog from install
Comment 5 Brian Brock 2006-08-16 13:16:44 EDT
a full trace on x86_64 with kernel 2.6.17-1.2568.el5 looks like:

[ INFO: possible recursive locking detected ]
2.6.17-1.2568.el5 #1
---------------------------------------------
anaconda/613 is trying to acquire lock:
 (&bdev->bd_mutex){--..}, at: [<ffffffff802e266c>] __blkdev_put+0x32/0x174

but task is already holding lock:
 (&bdev->bd_mutex){--..}, at: [<ffffffff802e297a>] do_open+0x84/0x3da

other info that might help us debug this:
1 lock held by anaconda/613:
 #0:  (&bdev->bd_mutex){--..}, at: [<ffffffff802e297a>] do_open+0x84/0x3da

stack backtrace:

Call Trace:
 [<ffffffff8026d8ed>] show_trace+0xae/0x319
 [<ffffffff8026db6d>] dump_stack+0x15/0x17
 [<ffffffff802a7193>] __lock_acquire+0x135/0xa64
 [<ffffffff802a806a>] lock_acquire+0x4b/0x69
 [<ffffffff802655b4>] mutex_lock_nested+0x101/0x27f
 [<ffffffff802e266c>] __blkdev_put+0x32/0x174
 [<ffffffff802411da>] blkdev_put+0xb/0xd
 [<ffffffff802e2c3c>] do_open+0x346/0x3da
 [<ffffffff802e2f75>] blkdev_open+0x2c/0x5e
 [<ffffffff8021eed1>] __dentry_open+0xe9/0x1f5
 [<ffffffff80226657>] nameidata_to_filp+0x2d/0x3e
 [<ffffffff80228754>] do_filp_open+0x36/0x46
 [<ffffffff80219ff8>] do_sys_open+0x4f/0xcd
 [<ffffffff80233066>] sys_open+0x1b/0x1d
 [<ffffffff8025f60e>] system_call+0x7e/0x83
DWARF2 unwinder stuck at system_call+0x7e/0x83
Leftover inexact backtrace:


<nothing else displayed>
Comment 7 Dave Jones 2006-09-17 01:54:40 EDT
*** Bug 199568 has been marked as a duplicate of this bug. ***
Comment 8 Linda Wang 2006-10-03 15:33:56 EDT
*** Bug 203137 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.