Bug 199599 - "unexpected tag 3" sending to rsync daemon
"unexpected tag 3" sending to rsync daemon
Status: CLOSED DUPLICATE of bug 206536
Product: Fedora
Classification: Fedora
Component: rsync (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Simo Sorce
Depends On:
  Show dependency treegraph
Reported: 2006-07-20 13:58 EDT by Pim Zandbergen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-02-16 09:31:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Pim Zandbergen 2006-07-20 13:58:56 EDT
Description of problem:
rsync client fails with error message
unexpected tag 3 [sender] rsync error: error in rsync protocol data stream (code
12) at io.c(843) [sender]
when sending files to rsync daemon

Version-Release number of selected component (if applicable):

How reproducible:
always, given enough data

Steps to Reproduce:
1. setup rsync-2.6.8-1.FC5.1 as rsync daemon on receiver
2. use rsync-2.6.8-1.FC5.1 on client to send files to receiver

Actual results:
client stops sending after random time with error message

Expected results:
client finishes transfer

Additional info:
downgrading receiver to rsync-2.6.6-2.2.1 fixes problem
Problem is already fixed upstream in CVS and in upcoming
version 2.6.9. See
Comment 1 Simo Sorce 2007-02-16 09:31:29 EST

*** This bug has been marked as a duplicate of 206536 ***

Note You need to log in before you can comment on or make changes to this bug.