Bug 206536 - rsync --daemon (as an upload server) generates errors
Summary: rsync --daemon (as an upload server) generates errors
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rsync   
(Show other bugs)
Version: 5
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Simo Sorce
QA Contact:
URL:
Whiteboard:
Keywords:
: 199599 202286 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-14 21:49 UTC by Chris Schanzle
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 2.6.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-16 14:30:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix tag-3 errors (2.94 KB, patch)
2006-09-14 21:49 UTC, Chris Schanzle
no flags Details | Diff

Description Chris Schanzle 2006-09-14 21:49:15 UTC
Description of problem:
rsync server (--daemon) with "transfer logging = yes" generates protocol errors:
rsync error: error in rsync protocol data stream (code 12) at io.c(808)

This makes running an rsync server with logging enabled unreliable.


Version-Release number of selected component (if applicable):
rsync-2.6.8-1.FC5.1

How reproducible:
very, with enough files to transfer.

Steps to Reproduce:
all on rsync server:
1.  chkconfig xinetd on; chkconfig rsync on
2.  configure /etc/rsyncd.conf to permit uploading; - here's a simple sample

use chroot = false
log file = /var/log/rsyncd.log
transfer logging = true
hosts allow = 129.6.80.0/24 129.6.88.0/24 132.163.129.0/24 132.163.229.0/24

[HEV]
path = /var/tmp/HEV/
comment = "High End Visualization (HEV) Distribution"
read only = false


3.  rsync -aH  /usr/share/doc server::HEV
  
Actual results:
(ignore "failed to open...permission denied" messages)

unexpected tag 3 [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(808)


Expected results:
no messages, no aborts

Additional info:

-H (retain hard links) makes the problem appear more frequently.

rsync mailing list thread at
http://www.mail-archive.com/rsync@lists.samba.org/msg16204.html
Patch (in same thread) at: 
http://www.mail-archive.com/rsync@lists.samba.org/msg16405.html

Applying the patch to fc5 rsync package fixed it for me.

Comment 1 Chris Schanzle 2006-09-14 21:49:15 UTC
Created attachment 136312 [details]
patch to fix tag-3 errors

Comment 2 Simo Sorce 2007-02-16 14:31:31 UTC
*** Bug 199599 has been marked as a duplicate of this bug. ***

Comment 3 Simo Sorce 2007-02-16 14:41:52 UTC
*** Bug 202286 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.