Bug 199656 - fltk-config --cflags prints RPM_OPT_FLAGS
fltk-config --cflags prints RPM_OPT_FLAGS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fltk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened
: 199657 (view as bug list)
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-07-21 02:11 EDT by Anthony Green
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-04 18:00:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2006-07-21 02:11:28 EDT
Description of problem:
Check this out...
$ fltk-config --cflags
-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables

This is not appropriate for fltk-config --cflags output, which IMO should be
limited to library specific options (like special -I or -D settings).  This
looks like it's just regurgitating the RPM_OPT_FLAGS used to build fltk, but as
far as I can tell it shouldn't really be printing anything.

This is making the generation of spec files for packages using fltk-config a
little more complicated.

Version-Release number of selected component (if applicable):
fltk-devel-1.1.7-1.fc5

How reproducible:
Always.

Steps to Reproduce:
1.Run fltk-config --cflags.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rex Dieter 2006-12-12 00:43:07 EST
*** Bug 199657 has been marked as a duplicate of this bug. ***
Comment 2 Rex Dieter 2006-12-12 01:06:07 EST
Should be fixed in 1.1.7-4 (and later).  Thanks.


%changelog
* Mon Dec 11 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.1.7-4
- use included icon/.desktop files
- fix up fltk-config (#199656)
Comment 3 Thomas Fitzsimmons 2007-04-04 15:48:21 EDT
This change:

* Wed Dec 13 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.1.7-7.r5555
- fltk-1.1.x-r5555 snapshot, for 64bit issues (#219348)
- restore static libs (they're tightly coupled with fltk-config)
- cleanup %%description's

reintroduced this problem, by making the fix application conditional on snap
being defined (otherwise the old patch doesn't apply):

%if "%{?snap:1}" != "1"
%patch1 -p1 -b .199656
%endif

Why not just commit to using the snapshot on the devel branch, update the patch
and remove these snap conditionals?
Comment 4 Thomas Fitzsimmons 2007-04-04 18:00:20 EDT
I fixed this specific issue in Rawhide with a minimal patch.  Rex, I think you
should go back and remove the snap conditionals.  Also, since this is a 1.1.8
fltk pre-release package, you should follow the pre-release naming guidelines
(the package version should be 1.1.8, the release should start with 0.):

http://fedoraproject.org/wiki/Packaging/NamingGuidelines#head-d97a3f40b6dd9d2288206ac9bd8f1bf9b791b22a
Comment 5 Rex Dieter 2007-04-05 08:14:40 EDT
Thanks Thomas.

I stuck with 1.1.7, considering snap a post release of 1.1.7, not a pre-release
of 1.1.8, so the referenced guideline doesn't apply.

> Why not just commit to using the snapshot on the devel branch, update the patch
> and remove these snap conditionals?

I think that's where we're headed.  Previously, I was keeping the option open to
dropping back to stable 1.1.7 if there were any show-stopper bugs.
Comment 6 Rex Dieter 2007-04-05 08:28:38 EDT
Ah, I see fltk-config (in the latest snap anyway), includes:
MAJOR_VERSION=1
MINOR_VERSION=1
PATCH_VERSION=8
So, pre-release it is...

Note You need to log in before you can comment on or make changes to this bug.